Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Maximize windows on current physical screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lbalan79
n00b
n00b


Joined: 12 Jun 2005
Posts: 55

PostPosted: Tue Aug 13, 2013 1:25 am    Post subject: Maximize windows on current physical screen Reply with quote

I have a two monitor setup. I got double monitor set-up to work fine with one exception: windows maximized span on both monitors. I would like to get the windows to maximize on current physical monitor.

Here is the xorg.conf:
Code:


# File: xorg.conf

Section "ServerLayout"
    Identifier     "Server Layout"
#    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
#    Option         "Xinerama" "1"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/local/"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/75dpi/"
    FontPath        "/usr/share/fonts/100dpi/"
EndSection

Section "Module"

#SubSection "extmod" #Seems an older version xorg.conf
#Option "omit xfree86-dga" # don't initialise the DGA extension #Maybe this line was causing problems...
#EndSubSection
    Load           "dbe" # Double buffer extension
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
    Load           "dri"
EndSection

Section "InputDevice"

#Option "Protocol" "keyboard"
#Option "AutoRepeat" "500 30"
#Option "XkbRules" "xfree86"
    Identifier     "Keyboard1"
    Driver         "evdev"
    Option         "XkbModel" "evdev"
#Option "XkbLayout" "ca"
    Option         "XkbOptions" "altwin:super_win"
    Option         "Device" "/dev/input/event1"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "evdev"
     Option         "XkbModel" "evdev"
#Option "XkbLayout" "ca"
    Option         "XkbOptions" "altwin:super_win"
    Option         "Device" "/dev/input/event1"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "evdev"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Device" "/dev/input/mice"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection


And here is the output from xrandr -q:
Code:

      xrandr -q
Screen 0: minimum 8 x 8, current 3200 x 1200, maximum 8192 x 8192
DVI-I-0 disconnected primary (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
TV-0 disconnected (normal left inverted right x axis y axis)
DVI-I-2 connected 1920x1200+1280+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1920x1080      60.0 
   1680x1050      60.0 
   1600x1200      60.0 
   1280x1024      60.0 
   1280x960       60.0 
   1024x768       60.0 
   800x600        60.3 
   640x480        59.9 
DVI-I-3 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0 
   1152x864       75.0 
   1024x768       75.0     60.0 
   800x600        75.0     60.3 
   640x480        75.0     59.9 


Any other information you require please let me know.

Thank you
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1223
Location: 42.68n 85.41w

PostPosted: Tue Aug 13, 2013 1:42 am    Post subject: Reply with quote

Code:

su -c '/opt/bin/nvidia-settings'


x server display configuration -> configuration -> seperate x screen -> save to x configuration file.....

if its not that then its twin view. i dont have 2 screens hooked up right now but did a while ago.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
lbalan79
n00b
n00b


Joined: 12 Jun 2005
Posts: 55

PostPosted: Tue Aug 13, 2013 1:56 am    Post subject: Reply with quote

Creating a new screen does work but does not allow drag and drop from one monitor to another. They just act like totally separate "screens".

I will read more about twin view. Not sure how to set that up yet and see if that solves the issue.
Back to top
View user's profile Send private message
lbalan79
n00b
n00b


Joined: 12 Jun 2005
Posts: 55

PostPosted: Tue Aug 13, 2013 2:47 am    Post subject: Reply with quote

TwinView doesn't really work either. Maybe I do not know how to set it. Here is the xorg.conf:

Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 325.15  (buildmeister@swio-display-x64-rhel04-03)  Wed Jul 31 19:04:13 PDT 2013

# File: xorg.conf

Section "ServerLayout"
    Identifier     "Server Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/local/"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/75dpi/"
    FontPath        "/usr/share/fonts/100dpi/"
EndSection

Section "Module"

#SubSection "extmod" #Seems an older version xorg.conf
#Option "omit xfree86-dga" # don't initialise the DGA extension #Maybe this line was causing problems...
#EndSubSection
    Load           "dbe" # Double buffer extension
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
    Load           "dri"
EndSection

Section "InputDevice"

#Option "Protocol" "keyboard"
#Option "AutoRepeat" "500 30"
#Option "XkbRules" "xfree86"
    Identifier     "Keyboard1"
    Driver         "evdev"
    Option         "XkbModel" "evdev"
#Option "XkbLayout" "ca"
    Option         "XkbOptions" "altwin:super_win"
    Option         "Device" "/dev/input/event1"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "evdev"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Device" "/dev/input/mice"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2412M"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 61.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "DELL U2412M"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 61.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Device0"
    Monitor        "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DVI-I-3: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DVI-I-3: nvidia-auto-select +0+0, DVI-I-2: nvidia-auto-select +1280+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "TwinView" "1"       
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +1280+0, DVI-I-3: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum