Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.8 and systemd and sys-devel/gcc-config
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fromthatplace
n00b
n00b


Joined: 12 Aug 2013
Posts: 1

PostPosted: Mon Aug 12, 2013 11:26 pm    Post subject: Gnome 3.8 and systemd and sys-devel/gcc-config Reply with quote

Hello, I'm using systemd with gnome 3.8. When I finished installing everything I tried to update gcc and found that the gcc-config did not function without openrc. Openrc provides text formatting operations in /etc/init.d/functions.sh that gcc-config depends on. These are unnecessary and should be replaced with stub functions, in the event that functions.sh is missing, to support systemd.

A similar problem has been encountered in funtoo and dealt with in this way.

I'm not sure if I should file a bug or what. I just wanted this information out there in case anyone else has trouble.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Mon Aug 12, 2013 11:43 pm    Post subject: Reply with quote

Known problem, developers are working on fixing it; this became more important these days now that systemd becomes used by more users, due to GNOME 3.8.
Back to top
View user's profile Send private message
Khumarahn
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2009
Posts: 128

PostPosted: Sun Aug 18, 2013 7:27 pm    Post subject: Reply with quote

I can't install systemd together with openrc now... openrc conflicts with kmod which is required by systemd. Any updates here?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Sun Aug 18, 2013 9:16 pm    Post subject: Reply with quote

Can we see the conflict you mean? I have both installed at the same time and haven't seen a conflict.
Back to top
View user's profile Send private message
Khumarahn
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2009
Posts: 128

PostPosted: Mon Aug 19, 2013 12:15 am    Post subject: Reply with quote

sure... below I have "sys-apps/systemd ~amd64" in package.keywords.

Code:

sinkpad ~ # emerge -av openrc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-apps/sysvinit-2.88-r4  USE="(-ibm) (-selinux) -static" 0 kB
[ebuild  N     ] sys-apps/openrc-0.11.8  USE="ncurses pam unicode -debug -newnet (-prefix) (-selinux) -static-libs" 0 kB
[blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking sys-apps/kmod-14-r2)

Total: 2 packages (2 new), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.11.8::gentoo, ebuild scheduled for merge) pulled in by
    openrc
    sys-apps/openrc required by (virtual/service-manager-0::gentoo, installed)

  (sys-apps/kmod-14-r2::gentoo, installed) pulled in by
    sys-apps/kmod required by (sys-apps/pciutils-3.2.0::gentoo, installed)
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, installed)
    >=sys-apps/kmod-14-r1 required by (sys-apps/systemd-206-r3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


emerge --info is here: http://pastebin.com/Nz0LgSiD
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Mon Aug 19, 2013 8:25 am    Post subject: Reply with quote

Quote:
[ebuild N ] sys-apps/openrc-0.11.8 USE="ncurses pam unicode -debug -newnet (-prefix) (-selinux) -static-libs" 0 kB


Sync your Portage tree, then you need to upgrade to =sys-apps/openrc-0.12; because kmod with the openrc USE flag only works with 0.12 and later.
Back to top
View user's profile Send private message
Khumarahn
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2009
Posts: 128

PostPosted: Mon Aug 19, 2013 10:59 am    Post subject: Reply with quote

Thank you, unmasking openrc-0.12 seems to work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum