Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to emerge libreoffice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 128

PostPosted: Mon Aug 12, 2013 3:24 am    Post subject: Unable to emerge libreoffice Reply with quote

Libreoffice emerged fine. Then I switched to unstable and got an emerge error on (among other things) libreoffice.

So I switched libreoffice back to stable and tried again. Didn't work, needed some perl module, installed that, then tried emerge a fourth time, now I get the following error:

Code:

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 512 occurred while making /var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/tail_build/prj

 it seems that the error is inside 'tail_build', please re-run build
 inside this module to isolate the error and/or test your fix.

-----------------------------------------------------------------------
To rebuild a specific module:

make tail_build.clean # not recommended, this will re-build almost everything
make tail_build

when the problem is isolated and fixed, re-run 'make'
make[1]: *** [build-packimages] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2'
make: *** [build] Error 2
 * ERROR: app-office/libreoffice-4.0.4.2::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 7222:  Called die
 * The specific snippet of code:
 *       make build || die
 *
 * If you need support, post the output of `emerge --info '=app-office/libreoffice-4.0.4.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-office/libreoffice-4.0.4.2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME="/home/printer/.gentoo/java-config-2/current-user-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =libreoffice-4.0.4.2
 * The complete build log is located at '/var/tmp/portage/app-office/libreoffice-4.0.4.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/libreoffice-4.0.4.2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2'
 * S: '/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2'

>>> Failed to emerge app-office/libreoffice-4.0.4.2, Log file:

>>>  '/var/tmp/portage/app-office/libreoffice-4.0.4.2/temp/build.log'

 * Messages for package app-office/libreoffice-4.0.4.2:

 * ERROR: app-office/libreoffice-4.0.4.2::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 7222:  Called die
 * The specific snippet of code:
 *       make build || die
 *
 * If you need support, post the output of `emerge --info '=app-office/libreoffice-4.0.4.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-office/libreoffice-4.0.4.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-office/libreoffice-4.0.4.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/libreoffice-4.0.4.2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2'
 * S: '/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2'


More info:

Code:

Portage 2.1.13.7 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.17, 3.8.13-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.2
KiB Mem:     6098468 total,   3028668 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of tree: Sat, 10 Aug 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r1, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x-reprap perl-experimental steam-overlay bitcoin x-portage
Installed sets: @steam
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j 2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/reprap /var/lib/layman/perl-experimental /var/lib/layman/steam /var/lib/layman/bitcoin /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus disable-watermark dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify lock mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline sdl session spell sse sse2 ssl startup-notification svg tcpd thunar tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-office/libreoffice-4.0.4.2 was built with the following:
USE="bluetooth branding cups dbus gtk opengl vba webdav (-aqua) -debug -eds -gnome -gstreamer -java -jemalloc -kde -mysql -odk -postgres -telepathy -test" LIBREOFFICE_EXTENSIONS="presenter-minimizer -nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 -python3_3"
Back to top
View user's profile Send private message
lysergicacid
Guru
Guru


Joined: 25 Nov 2003
Posts: 352
Location: The Universe,Virgo Super Cluster,Milky Way,Earth

PostPosted: Tue Aug 13, 2013 1:06 am    Post subject: Reply with quote

Hi, i presume you did unmerge the unstable version and its dependencies ie run
Code:
emerge --depclean -p
and rip off the crap the unstable libreoffice installed, might be that perl module you installed for the unstable version or something similar.
_________________
[img]http://valid.canardpc.com/cache/banner/2040927.png[/img]
Desktop:
[img]http://valid.canardpc.com/cache/banner/2703952.png[/img]
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 128

PostPosted: Tue Aug 13, 2013 7:40 am    Post subject: Reply with quote

lysergicacid wrote:
Hi, i presume you did unmerge the unstable version and its dependencies ie run
Code:
emerge --depclean -p
and rip off the crap the unstable libreoffice installed, might be that perl module you installed for the unstable version or something similar.


This doesn't seem to work for me for the following reason:

Code:

# emerge --depclean -p

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=dev-libs/icu-4.8.1.1:0/51.1= pulled in by:
 *     app-office/libreoffice-4.0.4.2
 *
 *   >=app-text/poppler-0.16:0/35=[xpdf-headers(+),cxx] pulled in by:
 *     app-office/libreoffice-4.0.4.2
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
 *
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 *
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the portage tree, since it may
 * not be possible to satisfy their dependencies.
Back to top
View user's profile Send private message
lysergicacid
Guru
Guru


Joined: 25 Nov 2003
Posts: 352
Location: The Universe,Virgo Super Cluster,Milky Way,Earth

PostPosted: Tue Aug 13, 2013 8:36 pm    Post subject: Reply with quote

personally i'd remove icu and poppler then run emerge --depclean -p again and see what it says
_________________
[img]http://valid.canardpc.com/cache/banner/2040927.png[/img]
Desktop:
[img]http://valid.canardpc.com/cache/banner/2703952.png[/img]
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 128

PostPosted: Thu Aug 15, 2013 10:32 pm    Post subject: Reply with quote

lysergicacid wrote:
personally i'd remove icu and poppler then run emerge --depclean -p again and see what it says


Do you mean -P, as in --prune? I can't do that, because I need an older version of libpng in order to run Slic3r.
Back to top
View user's profile Send private message
GenProm
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2011
Posts: 78
Location: Germany

PostPosted: Thu Jan 30, 2014 6:42 pm    Post subject: Reply with quote

Hi

I normaly dont hijack threads but i have the same problem as deltamalloc and on my machine it started after a emerge @preserved-rebuild.

I did already run perlcleaner and python-Updater. Also icu is the stable version.

I'm a bit out of ideas now but maybe it has something to do with the java versions ?

Thanks for any ideas tho :-D
_________________
Thank you for your help.

Manuel
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Thu Jan 30, 2014 8:12 pm    Post subject: Reply with quote

deltamalloc,

The last few times I have updated libreoffice, Ive had to
Code:
FEATURES=-userpriv emerge libreoffice -1

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
GenProm
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2011
Posts: 78
Location: Germany

PostPosted: Fri Jan 31, 2014 3:09 pm    Post subject: Reply with quote

Hi

Unfortunately this did not work. It still gives me that same error.

Also I don't have the use flag: userpriv activated (i don't see it in the list of flags) on libreoffice or otherwise.

I narroed it down to:

Code:

     
[build CXX] ucb/source/ucp/webdav-neon/webdavprovider.cxx
/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/ucb/source/ucp/webdav-neon/NeonSession.cxx: In member function ‘void webdav_ucp::NeonSession::Init()’:
/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/ucb/source/ucp/webdav-neon/NeonSession.cxx:837:85: error: invalid conversion from ‘int (*)(void*, const char*, const char*, int, char*, char*)’ to ‘ne_auth_creds {aka int (*)(void*, const char*, int, char*, char*)}’ [-fpermissive]
In file included from /var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/ucb/source/ucp/webdav-neon/NeonSession.cxx:37:0:
/usr/include/neon/ne_auth.h:132:6: error:   initializing argument 3 of ‘void ne_add_server_auth(ne_session*, unsigned int, ne_auth_creds, void*)’ [-fpermissive]
/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/ucb/source/ucp/webdav-neon/NeonSession.cxx:838:85: error: invalid conversion from ‘int (*)(void*, const char*, const char*, int, char*, char*)’ to ‘ne_auth_creds {aka int (*)(void*, const char*, int, char*, char*)}’ [-fpermissive]
In file included from /var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/ucb/source/ucp/webdav-neon/NeonSession.cxx:37:0:
/usr/include/neon/ne_auth.h:134:6: error:   initializing argument 3 of ‘void ne_add_proxy_auth(ne_session*, unsigned int, ne_auth_creds, void*)’ [-fpermissive]
S=/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2 && O=$S/solver/unxlngx6.pro && W=$S/workdir/unxlngx6.pro &&  mkdir -p $W/CxxObject/ucb/source/ucp/webdav-neon/ $W/Dep/CxxObject/ucb/source/ucp/webdav-neon/ && cd /var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2 &&  x86_64-pc-linux-gnu-g++ -DCPPU_ENV=gcc3 -DENABLE_GRAPHITE -DENABLE_GTK -DENABLE_KDE4 -DGCC -DHAVE_CXX11_PERFECT_FORWARDING -DHAVE_GCC_BUILTIN_ATOMIC -DHAVE_THREADSAFE_STATICS -DLIBO_INTERNAL_ONLY -DLINUX -DNDEBUG -DOPTIMIZE -DOSL_DEBUG_LEVEL=0 -DSOLAR_JAVA -DSUPD=400 -DUNIX -DUNX -DX86_64 -D_PTHREADS -D_REENTRANT  -DRTL_USING   -DSYSTEM_LIBXML  -DNEON_VERSION=0x0300   -DHAVE_GCC_VISIBILITY_FEATURE -fvisibility=hidden   -Wall -Wendif-labels -Wextra -fmessage-length=0 -fno-common -pipe  -fvisibility-inlines-hidden -DLIBO_MERGELIBS -fPIC -Wshadow -Wsign-promo -Woverloaded-virtual  -Wnon-virtual-dtor -std=gnu++0x  -DEXCEPTIONS_ON -fexceptions -fno-enforce-eh-specs -march=native -O2 -pipe -c $S/ucb/source/ucp/webdav-neon/webdavprovider.cxx -o $W/CxxObject/ucb/source/ucp/webdav-neon/webdavprovider.o  -I$S/ucb/source/ucp/webdav-neon/  -I$O/inc/external -I$O/inc -I$S/solenv/inc  -I/opt/oracle-jdk-bin-1.7.0.51/include -I/opt/oracle-jdk-bin-1.7.0.51/include/linux -I/opt/oracle-jdk-bin-1.7.0.51/include/native_threads/include -I$S/config  -I$O/inc/udkapi -I$O/inc/offapi  -I/usr/include/libxml2    -I/usr/include/neon       
[build CXX] ucb/source/ucp/webdav-neon/webdavresultset.cxx
make[2]: *** [/var/tmp/portage/app-office/libreoffice-4.0.4.2/work/libreoffice-4.0.4.2/workdir/unxlngx6.pro/CxxObject/ucb/source/ucp/webdav-neon/NeonSession.o] Error 1
make[2]: *** Waiting for unfinished jobs....


It seems like there is an error in the source code with that conversation to int. But this should fixed upstream right ?

Any other ideas ?

Thanks a lot :-D
_________________
Thank you for your help.

Manuel
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Fri Jan 31, 2014 9:40 pm    Post subject: Reply with quote

GenProm,

userpriv is a FEATURE, not a use flag.

deltamalloc has
Code:
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"


userpriv makes portage do everything it can as a non root user.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
GenProm
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2011
Posts: 78
Location: Germany

PostPosted: Sat Feb 01, 2014 11:08 am    Post subject: Reply with quote

Yes i read about it and is deactivates the sandbox but why would it help convert that int in the source code?

Nonetheless I will try with the Feature from deltamalloc and report back.

No it did not work. Still same error.
_________________
Thank you for your help.

Manuel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum