Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[FIXED] OpenRC updated, broken.
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 21 Jun 2013
Posts: 19
Location: The Moon

PostPosted: Mon Aug 19, 2013 12:51 pm    Post subject: [FIXED] OpenRC updated, broken. Reply with quote

Basically, I ran an emerge --sync, then did the whole world, then --depcleaned, then compiled me a new kernel (3.9.6) to enable USB Webcam drivers, backed up my old kernel, and restarted the computer. During boot I got to see some "umount" errors in the boot stream, and some nice stuff telling me how to use umount, my networking is nonexistant, my OpenRC scripts are completely disabled, and I can't even start tmux.

When I try to run any OpenRC script, I get told it is already starting. When I try to stop it, I get told someone else already stopped it. When I call for a status, I get told that it is dangerous to run an OpenRC script on a system that OpenRC didn't boot. This brings to mind that I had enabled the SystemD stuff in the kernel, but I have no traces of SystemD in my system at all. I hate SystemD, for one thing. But anyway, the OpenRC warning concludes by telling me that if I so wish, I can touch a file and start OpenRC scripts anyway.

And that leads me to my next problem. My read-only filesystem. I can not touch or write any files at all. Not /etc/default/grub, not /run/openrc/softlevel, not ~/hi.txt

There is one warning about having no system bus running in `dmesg | tail -n 20`.

Oh, and when I run "tmux", I just get a new line, as if I had just pressed enter instead.

Any advice would be really much loved, as I have summer assignments to complete before school starts again in a few days.

Thank you,

- Aviator


Confirming that "SystemD stuff" is just the kernel requirements for SystemD.
I do have both CONFIG_TMPFS and CONFIG_DEVTMPFS _ENABLED_ in my kernel.
My FSTAB is correct.
My old kernel has the same errors.
I am running OpenRC 0.12. I enabled interactive mode and stepped through the boot process, failing at "bootmisc" where mount, umount, and read-only filesystems come into play.
I can `mount / -o remount,rw` and get writing back, but still no services working.
I saw the boot and sysinit level stuff start... but when I get to runlevel 3 for some reason, it's all dead.

I added mtab and lvm to runlevel boot, and that fixed my problem. Thank you to #gentoo on and the gentoo wiki.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum