Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Multiple instances in single slot for make, glib, udev
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rbergen
n00b
n00b


Joined: 10 Aug 2003
Posts: 44

PostPosted: Sun Sep 15, 2013 4:23 pm    Post subject: Multiple instances in single slot for make, glib, udev Reply with quote

I'm trying to update a system that has been dormant for a while, and run into a problem I don't quite know how to approach myself.

When I try to emerge practically anything (like gentoo-sources), I get output similar to the following:

Code:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/automake-wrapper-9 [7]
[ebuild  N     ] dev-libs/gobject-introspection-common-1.32.1
[ebuild  NS    ] sys-kernel/gentoo-sources-3.10.7 [3.3.8, 3.4.9] USE="-build -deblob -symlink"
[ebuild     U  ] sys-devel/make-3.82-r4 [3.82-r3]
[ebuild  NS    ] sys-devel/automake-1.13.4 [1.11.6]
[ebuild     U  ] dev-libs/glib-2.32.4-r1 [2.30.3] USE="-static-libs*"
[ebuild  N     ] sys-apps/kmod-13-r1  USE="tools zlib -debug -doc -lzma -static-libs"
[ebuild     U  ] dev-libs/gobject-introspection-1.32.1 [1.30.0-r2] USE="-doctool%"
[blocks b      ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)
[ebuild     U  ] sys-fs/udev-204 [171-r6] USE="acl%* firmware-loader%* introspection* kmod%* openrc%* -doc% -static-libs%"
[ebuild  N     ] virtual/udev-200  USE="gudev hwdb introspection keymap kmod (-selinux) -static-libs"
[ebuild  N     ] sys-fs/udev-init-scripts-26
[ebuild     U  ] sys-apps/hwids-20130329 [20120922] USE="udev%*"
[blocks B      ] <sys-fs/lvm2-2.02.97-r1 ("<sys-fs/lvm2-2.02.97-r1" is blocking sys-fs/udev-204)
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-26)
[blocks B      ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-204)
[blocks B      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-13-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-devel/make:0

  (sys-devel/make-3.82-r3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-devel/make-3.82-r4::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/make-3.82-r4 required by (sys-fs/udev-204::gentoo, ebuild scheduled for merge)

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.31.22:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, ebuild scheduled for merge)

  (dev-libs/glib-2.30.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-fs/udev:0

  (sys-fs/udev-171-r6::gentoo, installed) pulled in by
    >=sys-fs/udev-145[extras] required by (net-misc/modemmanager-0.4::gentoo, installed)

  (sys-fs/udev-204::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-200[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?] required by (virtual/udev-200::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/module-init-tools-3.16-r1::gentoo, installed) pulled in by
    >=sys-apps/module-init-tools-3.2_pre4 required by (sys-apps/pcmciautils-014-r1::gentoo, installed)

  (sys-fs/lvm2-2.02.88::gentoo, installed) pulled in by
    >=sys-fs/lvm2-2.02.66 required by (sys-fs/udisks-1.0.4-r2::gentoo, installed)

  (sys-fs/udev-init-scripts-26::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-init-scripts-25 required by (sys-fs/udev-204::gentoo, ebuild scheduled for merge)

  (sys-apps/openrc-0.9.8.4::gentoo, installed) pulled in by
    sys-apps/openrc required by (sys-apps/baselayout-2.1-r1::gentoo, installed)
    sys-apps/openrc required by @system
    sys-apps/openrc required by (sys-fs/udev-init-scripts-26::gentoo, ebuild scheduled for merge)

  (sys-apps/kmod-13-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, installed)
    >=sys-apps/kmod-13 required by (sys-fs/udev-204::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Considering the packages involved, I can't just unmerge installed package versions to make room for the new ones, as that will leave the system unusable.

Does anyone have any suggestions on how to deal with this?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8602

PostPosted: Sun Sep 15, 2013 5:59 pm    Post subject: Reply with quote

Start with the leaves. Update trivial packages that have no unsatisfied dependencies, then come back to the more central packages. I would do sys-devel/make net-misc/modemmanager first, then dev-libs/glib dev-libs/gobject-introspection, then work on the core packages.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum