Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Strange symbol in place of ' in terminal output
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
crazzyfool
n00b
n00b


Joined: 13 Jan 2009
Posts: 37

PostPosted: Wed Aug 07, 2013 3:16 pm    Post subject: [SOLVED] Strange symbol in place of ' in terminal output Reply with quote

I've just installed Gentoo, my locale settings look fine but if I:

Code:

# touch a.txt
# cp -v a.txt b.txt


I see the below output:

Code:

âa.txtâ -> âb.txtâ


This is what it looks like though putty. Directly through the terminal the 'â' symbols are little white squares.

Any ideas?


Last edited by crazzyfool on Sat Aug 10, 2013 2:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
crazzyfool
n00b
n00b


Joined: 13 Jan 2009
Posts: 37

PostPosted: Thu Aug 08, 2013 3:17 pm    Post subject: Reply with quote

I thought this would be an easy/quick one! :wink:

Here is my locale settings:

Code:

# locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
Back to top
View user's profile Send private message
crazzyfool
n00b
n00b


Joined: 13 Jan 2009
Posts: 37

PostPosted: Thu Aug 08, 2013 3:21 pm    Post subject: Reply with quote

Also, I've noticed that if I change the translation options within putty to use the UTF-8 remote character set, the output is displayed as I would expect.

Code:

‘a.txt’ -> ‘b.txt’
removed ‘./a.txt’
removed ‘./b.txt’


What's going on here then?
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2222
Location: UK

PostPosted: Thu Aug 08, 2013 7:50 pm    Post subject: Reply with quote

You're asking for Linux to output UTF-8 to a system that can't handle it.
Back to top
View user's profile Send private message
crazzyfool
n00b
n00b


Joined: 13 Jan 2009
Posts: 37

PostPosted: Thu Aug 08, 2013 8:40 pm    Post subject: Reply with quote

Thanks for your help but what can't handle it? The rm command/verbose option?
Back to top
View user's profile Send private message
crazzyfool
n00b
n00b


Joined: 13 Jan 2009
Posts: 37

PostPosted: Sat Aug 10, 2013 2:06 pm    Post subject: [SOLVED] Strange symbol in place of ' in terminal output Reply with quote

I posted the question on www.linuxquestions.org and got my answer pretty quickly. Here it is in case it helps anyone.

http://www.linuxquestions.org/questions/gentoo-87/strange-white-square-symbols-in-place-of-left-and-right-apostrophe-4175472785/
Back to top
View user's profile Send private message
crazzyfool
n00b
n00b


Joined: 13 Jan 2009
Posts: 37

PostPosted: Fri Oct 11, 2013 12:10 pm    Post subject: [SOLVED] Strange symbol in place of ' in terminal output Reply with quote

For any British people using Gentoo, the output from "locale" should look like this.

Code:

andy@storm ~ $ locale
LANG=en_GB.utf8
LC_CTYPE="en_GB.utf8"
LC_NUMERIC="en_GB.utf8"
LC_TIME="en_GB.utf8"
LC_COLLATE=C
LC_MONETARY="en_GB.utf8"
LC_MESSAGES="en_GB.utf8"
LC_PAPER="en_GB.utf8"
LC_NAME="en_GB.utf8"
LC_ADDRESS="en_GB.utf8"
LC_TELEPHONE="en_GB.utf8"
LC_MEASUREMENT="en_GB.utf8"
LC_IDENTIFICATION="en_GB.utf8"
LC_ALL=
andy@storm ~ $


That means editing /etc/env.d/02locale and setting the LANG variable to "en_GB.utf8". Note, "en_GB.UTF-8" is incorrect.

Code:

andy@storm ~ $ cat /etc/env.d/02locale
LANG="en_GB.utf8"
LC_COLLATE="C"
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 466
Location: United Kingdom

PostPosted: Mon Oct 14, 2013 2:28 pm    Post subject: Reply with quote

:? Doesn't happen to me.

Code:
meshedgedx fitzcarraldo # touch a.txt
meshedgedx fitzcarraldo # cp -v a.txt b.txt
‘a.txt’ -> ‘b.txt’
meshedgedx fitzcarraldo # locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=en_GB.UTF-8
meshedgedx fitzcarraldo # cat /etc/env.d/02locale
LANG="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LANGUAGE="en_GB.UTF-8"
GDM_LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
SYSFONT="latarcyrheb-sun16"
meshedgedx fitzcarraldo #

_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum