Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage] trop de problemes de dépendences
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sat Aug 17, 2013 12:17 pm    Post subject: [portage] trop de problemes de dépendences Reply with quote

Bonjours,
j'ai des gros soucis de conflits de dépendences avec portage depuis que je migre un de mes ordis à systemd

Quote:
pouet package.use # emerge -aDvNn1 @system
!!! Repository 'games' is missing masters attribute in '/var/lib/layman/games/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'artemis' is missing masters attribute in '/var/lib/layman/arthemis/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'arcon' is missing masters attribute in '/var/lib/layman/arcon/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage-overlay' is missing masters attribute in '/var/lib/layman/portage-overlay/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
WARNING: One or more repositories have missing repo_name entries:

/var/lib/layman/portage-overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



* IMPORTANT: 20 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


* IMPORTANT: 3 config files in '/etc/portage' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-python/python-exec-0.3.1 PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) (-pypy1_9*) (-python2_5*) (-python3_1*)" 73 kB
[ebuild U ] app-arch/bzip2-1.0.6-r4 [1.0.6-r3] USE="-static -static-libs" ABI_X86="(64%*) -32% (-x32)" 764 kB
[ebuild U ] dev-libs/expat-2.1.0-r3 [2.1.0-r2] USE="unicode -examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 550 kB
[ebuild U ] virtual/libiconv-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] app-arch/xz-utils-5.0.5-r1 [5.0.4-r1] USE="nls threads -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,276 kB
[ebuild U ] media-libs/libogg-1.3.1 [1.3.0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 398 kB
[ebuild U ] dev-libs/libffi-3.0.13-r1 [3.0.13] USE="-debug -pax_kernel -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 826 kB
[ebuild U ] media-libs/jpeg-9-r1 [8d] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 979 kB
[ebuild U ] dev-libs/libusb-1.0.9-r2:1 [1.0.9:1] USE="-debug -doc -examples% -static-libs" ABI_X86="(64%*) -32% (-x32)" 413 kB
[ebuild U ] media-libs/webrtc-audio-processing-0.1-r1 [0.1] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 384 kB
[ebuild U ] media-libs/vo-aacenc-0.1.3 [0.1.2] USE="-examples (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 599 kB
[ebuild U ] app-arch/gzip-1.6 [1.5] USE="-pic -static (-nls%*)" 709 kB
[ebuild U ] virtual/jpeg-0-r2 [0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] virtual/libusb-1-r1:1 [1:1] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] media-libs/xvid-1.3.2-r1 [1.3.2] USE="threads -examples -pic" ABI_X86="(64%*) -32% (-x32)" 681 kB
[ebuild U ] sys-process/procps-3.3.8 [3.3.4] USE="ncurses nls%* unicode -static-libs" 541 kB
[ebuild N ] dev-libs/libusb-compat-0.1.5-r2 USE="-debug -examples -static-libs" ABI_X86="(64) -32 (-x32)" 271 kB
[uninstall ] dev-libs/libusb-0.1.12-r7 USE="cxx -debug -doc -static-libs"
[blocks b ] dev-libs/libusb:0 ("dev-libs/libusb:0" is blocking dev-libs/libusb-compat-0.1.5-r2)
[blocks b ] dev-libs/libusb-compat ("dev-libs/libusb-compat" is blocking dev-libs/libusb-0.1.12-r7)
[ebuild U ] virtual/libusb-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild NS ] dev-lang/spidermonkey-17.0.0-r1:17 [1.8.5-r4:0/mozjs185] USE="-debug -jit -minimal -static-libs {-test}" 6,621 kB
[ebuild U ] dev-python/sip-4.14.7:0/10 [4.14.6:0/9] USE="-debug -doc" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 738 kB
[ebuild U ] dev-python/setuptools-0.9.8-r1 [0.7.2-r1] PYTHON_TARGETS="python2_7 python3_3* (-pypy1_9) -pypy2_0 (-python2_5) -python2_6 (-python3_1) -python3_2*" 749 kB
[ebuild R ] dev-python/numpy-1.7.1 USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 2,772 kB
[ebuild U ] dev-libs/libcdio-0.90-r1 [0.90] USE="cxx -cddb -minimal -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 2,589 kB
[ebuild U ] app-admin/eselect-1.3.7 [1.3.4] USE="-doc -emacs% -vim-syntax%" 163 kB
[ebuild R ] dev-java/java-config-2.2.0:2::java PYTHON_TARGETS="python2_7 python3_3* (-pypy1_9) -python2_6 (-python3_1) -python3_2*" 51 kB
[ebuild U ] net-misc/iputils-20121221-r1 [20101006-r2] USE="filecaps%* ipv6 ssl -SECURITY_HAZARD -caps% -doc -gnutls% -idn -static" 175 kB
[ebuild U ] media-libs/libv4l-1.0.0 [0.9.5] ABI_X86="(64%*) -32% (-x32)" 941 kB
[ebuild R ] sys-auth/pambase-20120417-r2 USE="cracklib sha512 systemd* -consolekit* -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB
[ebuild R ] sys-apps/busybox-1.21.0 USE="ipv6 pam static systemd* -livecd -make-symlinks -math -mdev -savedconfig (-selinux) -sep-usr -syslog%" 2,150 kB
[ebuild N ] virtual/service-manager-0 USE="(-prefix)" 0 kB
[ebuild U ] virtual/ffmpeg-9 [0.10.3] USE="X encode mp3 sdl theora truetype vdpau x264 -gsm -jpeg2k -opus% -speex -threads -vaapi" 0 kB
[ebuild U ] sys-apps/attr-2.4.47-r1 [2.4.47] USE="nls -static-libs" ABI_X86="(64%*) -32% (-x32)" 336 kB
[ebuild U ] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)" 558 kB
[ebuild U ] sys-apps/dbus-1.6.12 [1.6.10] USE="X systemd* -debug -doc (-selinux) -static-libs {-test}" 1,889 kB
[ebuild U ] media-libs/alsa-lib-1.0.27.2 [1.0.27-r2] USE="-alisp -debug -doc -python" ABI_X86="(64%*) -32% (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 886 kB
[ebuild U ] media-libs/libvorbis-1.3.3-r1 [1.3.3] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 1,063 kB
[ebuild U ] app-text/libpaper-1.1.24-r2 [1.1.24-r1] ABI_X86="(64%*) -32% (-x32)" 347 kB
[ebuild U ] media-libs/libsamplerate-0.1.8-r1 [0.1.8] USE="-sndfile -static-libs" ABI_X86="(64%*) -32% (-x32)" 4,203 kB
[ebuild U ] media-libs/flac-1.2.1-r5 [1.2.1-r4] USE="cxx ogg sse -3dnow (-altivec) -debug -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,971 kB
[ebuild UD ] dev-libs/icu-51.1:0/51.1 [51.2:0/51.2] USE="-debug -doc -examples -static-libs" 0 kB
[ebuild U ] dev-java/icedtea-web-1.3.2-r7:7 [1.3.1-r7:7] USE="nsplugin -build -doc -javascript {-test} (-gtk2%) (-gtk3%)" 1,015 kB
[ebuild U ] media-libs/speex-1.2_rc1-r2 [1.2_rc1-r1] USE="ogg sse -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,037 kB
[ebuild U ] media-libs/libaacplus-2.0.2-r2 [2.0.2-r1] USE="-bindist -fftw -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,358 kB
[ebuild U ] media-sound/lame-3.99.5-r1 [3.99.5] USE="-debug (-mmx) -mp3rtp -sndfile -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,412 kB
[ebuild U ] media-libs/libmodplug-0.8.8.4-r1 [0.8.8.4] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 534 kB
[ebuild U ] media-libs/faac-1.28-r4 [1.28-r3] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 663 kB
[ebuild U ] dev-libs/fribidi-0.19.5-r2 [0.19.5-r1] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 611 kB
[ebuild U ] media-libs/gavl-1.4.0-r1 [1.4.0] USE="-doc -static-libs" ABI_X86="(64%*) -32% (-x32)" 4,486 kB
[ebuild U ] dev-libs/libcdio-paranoia-0.90_p1-r1 [0.90_p1] USE="cxx -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 620 kB
[ebuild R ] net-nds/openldap-2.4.35 USE="berkdb crypt gnutls ipv6 minimal ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -kerberos -odbc -overlays -perl -samba* -sasl (-selinux) -slp -smbkrb5passwd" 5,370 kB
[ebuild R ] dev-lang/perl-5.16.3:0/5.16 USE="berkdb gdbm -debug -doc -ithreads (-build%)" 13,420 kB
[ebuild U ] media-libs/libpng-1.6.3-r1:0/16 [1.6.2:0/16] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 859 kB
[ebuild U ] net-print/cups-1.6.3-r2 [1.6.2-r5] USE="X acl dbus debug filters gnutls java pam ssl threads usb -kerberos -lprng-compat -python (-selinux) -static-libs -xinetd -zeroconf" LINGUAS="fr -ca -es -ja -ru" PYTHON_SINGLE_TARGET="python2_7%* (-python2_5) -python2_6%" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%" 8,072 kB
[ebuild U ] media-libs/tiff-4.0.3-r3 [4.0.3-r2] USE="cxx jpeg zlib -jbig -lzma -static-libs" ABI_X86="(64%*) -32% (-x32)" 2,004 kB
[ebuild U ] sys-apps/util-linux-2.23.2 [2.23.1] USE="cramfs ncurses nls static-libs suid udev unicode -bash-completion* -caps -cytune -fdformat -old-linux (-selinux) -slang {-test} -tty-helpers" 3,304 kB
[ebuild U ] dev-libs/elfutils-0.155-r1 [0.155] USE="bzip2 nls static-libs threads utils zlib -lzma {-test}" ABI_X86="(64%*) -32% (-x32)" 2,538 kB
[ebuild U ] media-libs/libsndfile-1.0.25-r1 [1.0.25] USE="alsa -minimal -sqlite -static-libs {-test%}" ABI_X86="(64%*) -32% (-x32)" 1,036 kB
[ebuild R ] dev-python/dbus-python-1.2.0 USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 589 kB
[ebuild U ] sys-libs/cracklib-2.9.0-r1 [2.9.0] USE="nls zlib -python -static-libs (-build%)" 612 kB
[ebuild U ] media-libs/libtheora-1.1.1-r1 [1.1.1] USE="encode -doc -examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,859 kB
[ebuild U ] media-libs/audiofile-0.3.6-r1:0/1 [0.3.6:0/1] USE="flac -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 519 kB
[ebuild R ] net-misc/wget-1.14 USE="ipv6 nls pcre ssl zlib -debug -gnutls* -idn -ntlm -static -uuid" 1,547 kB
[ebuild U ] media-libs/lcms-2.5-r1:2 [2.4-r1:2] USE="jpeg tiff zlib -doc -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 6,837 kB
[ebuild R ] media-libs/lcms-1.19-r1 USE="jpeg python tiff zlib -static-libs" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 -python3_2*" 907 kB
[ebuild U ] dev-libs/libxml2-2.9.1-r1:2 [2.9.0-r2:2] USE="ipv6 python readline -debug -examples -icu -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_3%* (-python2_5) -python2_6 (-python3_1) -python3_2%" 5,052 kB
[ebuild U ] dev-lang/orc-0.4.17-r1 [0.4.17] USE="-examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 708 kB
[ebuild R ] x11-proto/xcb-proto-1.8-r3 ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 123 kB
[ebuild R ] x11-libs/libxcb-1.9.1 USE="-doc (-selinux) -static-libs -xkb" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python2_6 (-python3_1) -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3* -python2_6 (-python3_1) -python3_2*" 365 kB
[ebuild R ] sys-apps/kmod-14-r1 USE="tools zlib -debug -doc -lzma -static-libs (-openrc%*)" 0 kB
[ebuild U ] x11-libs/cairo-1.12.14-r4 [1.12.14-r2] USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers -openvg (-qt4) -static-libs -valgrind% -xlib-xcb%" 41,145 kB
[ebuild U ] sys-auth/polkit-0.111-r1 [0.111] USE="gtk introspection nls pam systemd* -examples -kde (-selinux)" 1,364 kB
[ebuild R ] dev-python/pycairo-1.10.0-r4 USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 (-python3_1) -python3_2*" 634 kB
[ebuild U ] dev-python/pygobject-3.8.3:3 [3.4.2-r1:3] USE="cairo threads -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 (-python3_1) -python3_2*" 642 kB
[ebuild R ] net-wireless/bluez-4.101-r5 USE="alsa cups readline test-programs usb -consolekit* -debug -gstreamer -pcmcia (-selinux)" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 867 kB
[ebuild U ] dev-qt/qtcore-4.8.5:4 [4.8.4-r5:4] USE="exceptions glib iconv qt3support ssl (-aqua) -c++0x -debug -icu -pch" 235,832 kB
[ebuild U ] dev-qt/qtscript-4.8.5:4 [4.8.4:4] USE="exceptions iconv jit (-aqua) -c++0x -debug -pch" 0 kB
[ebuild U ] dev-qt/qtgui-4.8.5:4 [4.8.4-r1:4] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -c++0x -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama (-dbus%*) (-gif%*)" 0 kB
[ebuild U ] dev-qt/qtsql-4.8.5:4 [4.8.4:4] USE="exceptions qt3support sqlite (-aqua) -c++0x -debug -firebird -freetds -mysql -oci8 -odbc -pch -postgres" 0 kB
[ebuild U ] dev-qt/qt3support-4.8.5:4 [4.8.4:4] USE="accessibility exceptions (-aqua) -c++0x -debug -pch" 0 kB
[ebuild N ] dev-qt/designer-4.8.5:4 USE="exceptions qt3support (-aqua) -c++0x -debug -declarative -pch (-phonon) -webkit" 0 kB
[ebuild U ] dev-python/PyQt4-4.10.2 [4.10.1] USE="X dbus opengl svg -debug -declarative -doc -examples -help -kde -multimedia -phonon -script -scripttools -sql -webkit -xmlpatterns" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 11,017 kB
[ebuild R ] media-sound/pulseaudio-4.0 USE="X alsa asyncns bluetooth caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt4 ssl systemd* tcpd udev webrtc-aec -avahi* -doc -gnome* -jack -lirc (-neon) (-oss) -realtime (-system-wide) {-test} -xen" 1,360 kB
[ebuild U ] media-video/ffmpeg-1.2.2 [1.0.7] USE="X aac aacplus alsa avx bluray bzip2 cdio doc encode faac fontconfig frei0r hardcoded-tables iconv%* libass libv4l mmx modplug mp3 network pulseaudio sdl theora truetype v4l vdpau vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -amr -bindist (-celt) -cpudetection -debug -examples -fdk -flite -gnutls* -gsm -iec61883 -ieee1394 -jack -jpeg2k -libcaca -libsoxr% -mmxext (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -threads -twolame -vaapi (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape%* ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 5,829 kB

Total: 84 packages (63 upgrades, 1 downgrade, 3 new, 1 in new slot, 16 reinstalls, 1 uninstall), Size of downloads: 402,779 kB
Conflict: 2 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:4

(dev-qt/qtcore-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtcore-4.8.5[aqua=,debug=] required by (dev-qt/designer-4.8.5::gentoo, ebuild scheduled for merge)
(and 4 more with the same problem)

(dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
~dev-qt/qtcore-4.8.4[aqua=,debug=] required by (dev-qt/qtxmlpatterns-4.8.4::gentoo, installed)
(and 11 more with the same problem)

dev-qt/qtgui:4

(dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge)
(and 2 more with the same problem)

(dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
dev-qt/qtgui:4/4=[dbus] required by (net-p2p/transmission-2.77::gentoo, installed)
~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support=,trace?] required by (dev-qt/qthelp-4.8.4::gentoo, installed)
(and 7 more with the same problems)

dev-qt/qtscript:4

(dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
(and 1 more with the same problem)

dev-qt/qt3support:4

(dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
~dev-qt/qt3support-4.8.4[accessibility=,aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.4::gentoo, installed)
(and 1 more with the same problem)

(dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

dev-qt/qtsql:4

(dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.4::gentoo, installed)
(and 2 more with the same problem)

(dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge)

dev-lang/perl:0

(dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-lang/perl-5.16.3::gentoo, installed) pulled in by
dev-lang/perl[-build] required by (app-arch/rpm-4.10.0::gentoo, installed)
>=dev-lang/perl-5.8.2-r1[-build] required by (net-im/pidgin-2.10.6::gentoo, installed)
dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.6::gentoo, installed)
dev-lang/perl[-build] required by (dev-vcs/git-1.8.2.1::gentoo, installed)

dev-python/setuptools:0

(dev-python/setuptools-0.9.8-r1::gentoo, ebuild scheduled for merge) pulled in by
dev-python/setuptools[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/numpy-1.7.1::gentoo, ebuild scheduled for merge)

(dev-python/setuptools-0.7.2-r1::gentoo, installed) pulled in by
dev-python/setuptools[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy1_9(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy1_9(-),-python_single_target_pypy2_0(-)] required by (dev-python/jinja-2.6-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


du coup j'avoue ne pas trop savoir quoi faire pour m'en sortir
je n'ose meme plus rebooter la machine car d'ici à ce que ca ne boot pas y'a pas des kilometres :s
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Sat Aug 17, 2013 12:50 pm    Post subject: Reply with quote

Rajoute "t" comme option à emerge, ça sera déjà plus lisible pour toi.
Et sinon, tu n'as qu'à faire ta migration vers systemd en 2 temps. D'abord tu MAJ ton système, et ensuite tu migres à systemd (changement de flag). Ça devrait simplifier les choses et pas qu'un peu.
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sat Aug 17, 2013 1:42 pm    Post subject: Reply with quote

alors apres un repassage au useflag: consolekit -systemd
j'ai ca:

Quote:
la-yote package.use # emerge -aDvNn1t @system
!!! Repository 'games' is missing masters attribute in '/var/lib/layman/games/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'artemis' is missing masters attribute in '/var/lib/layman/arthemis/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'arcon' is missing masters attribute in '/var/lib/layman/arcon/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage-overlay' is missing masters attribute in '/var/lib/layman/portage-overlay/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
WARNING: One or more repositories have missing repo_name entries:

/var/lib/layman/portage-overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



* IMPORTANT: 20 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


* IMPORTANT: 3 config files in '/etc/portage' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild U ] media-video/ffmpeg-1.2.2 [1.0.7] USE="X aac aacplus alsa avx bluray bzip2 cdio doc encode faac fontconfig frei0r hardcoded-tables iconv%* libass libv4l mmx modplug mp3 network pulseaudio sdl theora truetype v4l vdpau vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -amr -bindist (-celt) -cpudetection -debug -examples -fdk -flite -gnutls* -gsm -iec61883 -ieee1394 -jack -jpeg2k -libcaca -libsoxr% -mmxext (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -threads -twolame -vaapi (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape%* ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 5,829 kB
[ebuild R ] sys-auth/pambase-20120417-r2 USE="consolekit cracklib sha512 systemd* -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB
[ebuild R ] media-sound/pulseaudio-4.0 USE="X alsa asyncns bluetooth caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt4 ssl tcpd udev webrtc-aec -avahi* -doc -gnome* -jack -lirc (-neon) (-oss) -realtime (-system-wide) -systemd {-test} -xen" 1,360 kB
[nomerge ] dev-db/phpmyadmin-3.5.2.2:3.5.2.2 USE="-setup -vhosts"
[nomerge ] dev-lang/php-5.5.1-r1:5.5 USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter fpm gd gdbm hash iconv inifile ipv6 json ldap mysql mysqli nls opcache phar posix readline session simplexml sockets spell ssl systemd tokenizer truetype unicode xml xmlreader xmlrpc xmlwriter zip zlib -bcmath -calendar -cdb -cgi -cjk -curl -debug -embed -enchant -firebird -flatfile (-frontbase) -ftp -gmp -imap -intl -iodbc -kerberos -ldap-sasl -libedit -libmysqlclient -mhash -mssql -oci8-instant-client -odbc -pcntl -pdo -postgres -qdbm -recode (-selinux) -sharedmem -snmp -soap -sqlite (-sybase-ct) -sysvipc -threads -tidy -wddx -xpm -xslt"
[ebuild N ] sys-apps/systemd-206-r3 USE="acl filecaps firmware-loader gudev introspection kmod openrc pam policykit qrcode tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild U ] sys-apps/util-linux-2.23.2 [2.23.1] USE="cramfs ncurses nls static-libs suid udev unicode -bash-completion* -caps -cytune -fdformat -old-linux (-selinux) -slang {-test} -tty-helpers" 3,304 kB
[ebuild R ] net-misc/wget-1.14 USE="ipv6 nls pcre ssl zlib -debug -gnutls* -idn -ntlm -static -uuid" 1,547 kB
[nomerge ] media-video/ffmpeg-1.2.2 [1.0.7] USE="X aac aacplus alsa avx bluray bzip2 cdio doc encode faac fontconfig frei0r hardcoded-tables iconv%* libass libv4l mmx modplug mp3 network pulseaudio sdl theora truetype v4l vdpau vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -amr -bindist (-celt) -cpudetection -debug -examples -fdk -flite -gnutls* -gsm -iec61883 -ieee1394 -jack -jpeg2k -libcaca -libsoxr% -mmxext (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -threads -twolame -vaapi (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape%* ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
[nomerge ] media-plugins/frei0r-plugins-1.3 USE="facedetect scale0tilt -doc"
[ebuild U ] media-libs/gavl-1.4.0-r1 [1.4.0] USE="-doc -static-libs" ABI_X86="(64%*) -32% (-x32)" 4,486 kB
[nomerge ] media-tv/xbmc-11.0-r1 USE="alsa avahi bluetooth profile projectm pulseaudio rsxs samba sse sse2 udev vdpau xrandr -airplay (-altivec) -bluray -cec -css -debug -goom -joystick -midi -mysql -pvr -rtmp -vaapi -webserver"
[ebuild U ] dev-libs/fribidi-0.19.5-r2 [0.19.5-r1] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 611 kB
[nomerge ] sys-boot/unetbootin-583 LINGUAS="fr -am -ar -ast -be -bg -bn -ca -cs -da -de -el -eo -es -et -eu -fi -fo -gl -he -hr -hu -id -it -ja -lt -lv -ml -ms -nan -nb -nl -nn -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -sw -tr -uk -ur -vi -zh_CN -zh_TW"
[nomerge ] app-arch/p7zip-9.20.1-r3 USE="pch wxwidgets -doc -kde -rar (-static)"
[nomerge ] x11-libs/wxGTK-2.8.12.1:2.8 USE="X gnome gstreamer opengl sdl tiff (-aqua) -debug -doc -odbc -pch"
[nomerge ] media-libs/libsdl-1.2.15-r4 USE="X alsa audio joystick opengl pulseaudio video xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama"
[ebuild U ] media-libs/audiofile-0.3.6-r1:0/1 [0.3.6:0/1] USE="flac -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 519 kB
[ebuild U ] dev-python/pygobject-3.8.3:3 [3.4.2-r1:3] USE="cairo threads -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 (-python3_1) -python3_2*" 642 kB
[nomerge ] games-action/minecraft-20120805-r1::java USE="ipv6"
[nomerge ] dev-java/icedtea-7.2.4.0:7::java USE="X alsa cups jbootstrap nsplugin nss pulseaudio source webstart -cacao -cjk -debug -doc -examples -jamvm -javascript -pax_kernel {-test} -zero"
[ebuild U ] dev-java/icedtea-web-1.3.2-r7:7 [1.3.1-r7:7] USE="nsplugin -build -doc -javascript {-test} (-gtk2%) (-gtk3%)" 1,015 kB
[nomerge ] media-gfx/gimp-2.8.2:2 USE="bzip2 curl dbus doc exif gnome jpeg jpeg2k lcms mmx mng pdf png postscript sse svg tiff udev webkit -aalib -alsa (-altivec) -debug -python -smp -wmf -xpm" LINGUAS="fr -am -ar -ast -az -be -bg -br -ca -ca@valencia -cs -csb -da -de -dz -el -en_CA -en_GB -eo -es -et -eu -fa -fi -ga -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -lt -lv -mk -ml -ms -my -nb -nds -ne -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -rw -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -tt -uk -vi -xh -yi -zh_CN -zh_HK -zh_TW"
[ebuild R ] media-libs/lcms-1.19-r1 USE="jpeg python tiff zlib -static-libs" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 -python3_2*" 907 kB
[nomerge ] virtual/shadow-0
[nomerge ] sys-apps/shadow-4.1.5.1-r1 USE="acl cracklib nls pam -audit (-selinux) -skey -xattr"
[ebuild U ] sys-libs/cracklib-2.9.0-r1 [2.9.0] USE="nls zlib -python -static-libs (-build%)" 612 kB
[nomerge ] media-video/dvdrip-0.98.11-r1 USE="ffmpeg mplayer ogg subtitles vorbis xvid -fping -vcd -xine"
[nomerge ] media-gfx/imagemagick-6.7.9.9 USE="X bzip2 cxx jpeg lcms openmp pango png svg tiff truetype xml zlib -autotrace -corefonts -djvu -fftw -fontconfig -fpx -graphviz -hdri -jbig -jpeg2k -lqr -lzma -opencl -openexr -perl -postscript -q32 -q64 -q8 -raw -static-libs {-test} -webp -wmf"
[ebuild U ] media-libs/lcms-2.5-r1:2 [2.4-r1:2] USE="jpeg tiff zlib -doc -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 6,837 kB
[nomerge ] games-util/qtsixa-1.2.1::artemis USE="doc qt -hal"
[ebuild U ] dev-python/PyQt4-4.10.2 [4.10.1] USE="X dbus opengl svg -debug -declarative -doc -examples -help -kde -multimedia -phonon -script -scripttools -sql -webkit -xmlpatterns" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 11,017 kB
[ebuild N ] dev-qt/designer-4.8.5:4 USE="exceptions qt3support (-aqua) -c++0x -debug -declarative -pch (-phonon) -webkit" 235,832 kB
[ebuild U ] dev-qt/qt3support-4.8.5:4 [4.8.4:4] USE="accessibility exceptions (-aqua) -c++0x -debug -pch" 0 kB
[ebuild U ] dev-qt/qtsql-4.8.5:4 [4.8.4:4] USE="exceptions qt3support sqlite (-aqua) -c++0x -debug -firebird -freetds -mysql -oci8 -odbc -pch -postgres" 0 kB
[ebuild U ] dev-qt/qtgui-4.8.5:4 [4.8.4-r1:4] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -c++0x -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama (-dbus%*) (-gif%*)" 0 kB
[ebuild U ] dev-qt/qtscript-4.8.5:4 [4.8.4:4] USE="exceptions iconv jit (-aqua) -c++0x -debug -pch" 0 kB
[ebuild U ] dev-qt/qtcore-4.8.5:4 [4.8.4-r5:4] USE="exceptions glib iconv qt3support ssl (-aqua) -c++0x -debug -icu -pch" 0 kB
[ebuild R ] net-nds/openldap-2.4.35 USE="berkdb crypt gnutls ipv6 minimal ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -kerberos -odbc -overlays -perl -samba* -sasl (-selinux) -slp -smbkrb5passwd" 5,370 kB
[nomerge ] media-sound/sonata-1.6.2.1 USE="dbus trayicon -lyrics -taglib"
[nomerge ] dev-python/pygtk-2.24.0-r3:2 USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild R ] dev-python/pycairo-1.10.0-r4 USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 (-python3_1) -python3_2*" 634 kB
[ebuild R ] sys-apps/kmod-14-r1 USE="tools zlib -debug -doc -lzma -static-libs (-openrc%*)" 0 kB
[nomerge ] mate-base/mate-1.6.0::mate-overlay USE="bluetooth extras"
[nomerge ] mate-extra/mate-power-manager-1.6.1::mate-overlay USE="applet policykit (-gtk3) -systemd {-test}"
[nomerge ] mate-base/mate-panel-1.6.0::mate-overlay USE="introspection networkmanager"
[ebuild U ] x11-libs/cairo-1.12.14-r4 [1.12.14-r2] USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers -openvg (-qt4) -static-libs -valgrind% -xlib-xcb%" 41,145 kB
[ebuild R ] x11-libs/libxcb-1.9.1 USE="-doc (-selinux) -static-libs -xkb" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python2_6 (-python3_1) -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3* -python2_6 (-python3_1) -python3_2*" 365 kB
[nomerge ] app-pda/gtkpod-2.1.4_pre20130428 USE="aac curl flac mp3 vorbis webkit -cdr -clutter -gstreamer"
[nomerge ] net-libs/webkit-gtk-2.0.4:3/25 USE="geoloc gstreamer introspection jit spell webgl (-aqua) -coverage -debug -libsecret {-test}"
[nomerge ] media-libs/gst-plugins-base-1.0.7:1.0 USE="X alsa introspection nls ogg orc pango theora vorbis -ivorbis"
[ebuild U ] dev-lang/orc-0.4.17-r1 [0.4.17] USE="-examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 708 kB
[nomerge ] media-sound/pulseaudio-4.0 USE="X alsa asyncns bluetooth caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt4 ssl tcpd udev webrtc-aec -avahi* -doc -gnome* -jack -lirc (-neon) (-oss) -realtime (-system-wide) -systemd {-test} -xen"
[nomerge ] x11-libs/xcb-util-0.3.9 USE="-doc -static-libs {-test}"
[nomerge ] x11-libs/xcb-util-wm-0.3.9 USE="-doc -static-libs {-test}"
[ebuild R ] x11-proto/xcb-proto-1.8-r3 ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 123 kB
[ebuild U ] dev-libs/libxml2-2.9.1-r1:2 [2.9.0-r2:2] USE="ipv6 python readline -debug -examples -icu -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_3%* (-python2_5) -python2_6 (-python3_1) -python3_2%" 5,052 kB
[nomerge ] media-video/ffmpeg-1.2.2 [1.0.7] USE="X aac aacplus alsa avx bluray bzip2 cdio doc encode faac fontconfig frei0r hardcoded-tables iconv%* libass libv4l mmx modplug mp3 network pulseaudio sdl theora truetype v4l vdpau vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -amr -bindist (-celt) -cpudetection -debug -examples -fdk -flite -gnutls* -gsm -iec61883 -ieee1394 -jack -jpeg2k -libcaca -libsoxr% -mmxext (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -threads -twolame -vaapi (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape%* ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
[ebuild U ] dev-libs/libcdio-paranoia-0.90_p1-r1 [0.90_p1] USE="cxx -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 620 kB
[ebuild U ] media-libs/libtheora-1.1.1-r1 [1.1.1] USE="encode -doc -examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,859 kB
[ebuild U ] media-libs/faac-1.28-r4 [1.28-r3] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 663 kB
[ebuild U ] media-libs/libmodplug-0.8.8.4-r1 [0.8.8.4] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 534 kB
[ebuild U ] media-sound/lame-3.99.5-r1 [3.99.5] USE="-debug (-mmx) -mp3rtp -sndfile -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,412 kB
[ebuild U ] media-libs/libaacplus-2.0.2-r2 [2.0.2-r1] USE="-bindist -fftw -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,358 kB
[nomerge ] media-video/mplayer-1.1-r1 USE="X a52 alsa bl bluray cdio dts dv dvd dvdnav enca encode faac faad gif iconv ipv6 jpeg libass libcaca libmpeg2 live mad mmx mng mp3 network opengl osdmenu png pulseaudio quicktime rar real rtc samba sdl shm speex sse sse2 ssse3 theora toolame tremor truetype twolame unicode v4l vdpau vorbis x264 xscreensaver xv xvid xvmc -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bindist -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dvb -dxr3 -fbcon -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -lirc -lzo -md5sum -mmxext -nas -nut -openal -oss -pnm -pvr -radio -rtmp -tga (-vidix) -win32codecs -xanim -xinerama -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild U ] media-libs/speex-1.2_rc1-r2 [1.2_rc1-r1] USE="ogg sse -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,037 kB
[ebuild UD ] dev-libs/icu-51.1:0/51.1 [51.2:0/51.2] USE="-debug -doc -examples -static-libs" 0 kB
[nomerge ] net-wireless/bluez-4.101-r5 USE="alsa consolekit cups readline test-programs usb -debug -gstreamer -pcmcia (-selinux)" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild U ] media-libs/libsndfile-1.0.25-r1 [1.0.25] USE="alsa -minimal -sqlite -static-libs {-test%}" ABI_X86="(64%*) -32% (-x32)" 1,036 kB
[ebuild U ] media-libs/flac-1.2.1-r5 [1.2.1-r4] USE="cxx ogg sse -3dnow (-altivec) -debug -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,971 kB
[nomerge ] media-tv/xbmc-11.0-r1 USE="alsa avahi bluetooth profile projectm pulseaudio rsxs samba sse sse2 udev vdpau xrandr -airplay (-altivec) -bluray -cec -css -debug -goom -joystick -midi -mysql -pvr -rtmp -vaapi -webserver"
[ebuild U ] media-libs/libsamplerate-0.1.8-r1 [0.1.8] USE="-sndfile -static-libs" ABI_X86="(64%*) -32% (-x32)" 4,203 kB
[ebuild U ] net-print/cups-1.6.3-r2 [1.6.2-r5] USE="X acl dbus debug filters gnutls java pam ssl threads usb -kerberos -lprng-compat -python (-selinux) -static-libs -xinetd -zeroconf" LINGUAS="fr -ca -es -ja -ru" PYTHON_SINGLE_TARGET="python2_7%* (-python2_5) -python2_6%" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%" 8,072 kB
[ebuild U ] app-text/libpaper-1.1.24-r2 [1.1.24-r1] ABI_X86="(64%*) -32% (-x32)" 347 kB
[nomerge ] app-arch/rpm-4.10.0 USE="acl nls -caps -doc -lua -python"
[ebuild U ] dev-libs/elfutils-0.155-r1 [0.155] USE="bzip2 nls static-libs threads utils zlib -lzma {-test}" ABI_X86="(64%*) -32% (-x32)" 2,538 kB
[nomerge ] media-sound/rhythmbox-0.13.3 USE="cdr gnome-keyring ipod lastfm libnotify nsplugin udev upnp webkit -daap -debug -doc -lirc -mtp -musicbrainz -python {-test}"
[nomerge ] media-plugins/gst-plugins-libmms-1.0.7:1.0
[nomerge ] media-libs/gst-plugins-bad-1.0.7:1.0 USE="nls orc"
[nomerge ] media-libs/gst-plugins-base-1.0.7:1.0 USE="X alsa introspection nls ogg orc pango theora vorbis -ivorbis"
[ebuild U ] media-libs/libvorbis-1.3.3-r1 [1.3.3] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 1,063 kB
[ebuild U ] media-libs/alsa-lib-1.0.27.2 [1.0.27-r2] USE="-alisp -debug -doc -python" ABI_X86="(64%*) -32% (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 886 kB
[nomerge ] net-ftp/filezilla-3.5.3 USE="dbus nls {-test}"
[nomerge ] x11-libs/wxGTK-2.8.12.1:2.8 USE="X gnome gstreamer opengl sdl tiff (-aqua) -debug -doc -odbc -pch"
[ebuild U ] media-libs/tiff-4.0.3-r3 [4.0.3-r2] USE="cxx jpeg zlib -jbig -lzma -static-libs" ABI_X86="(64%*) -32% (-x32)" 2,004 kB
[ebuild U ] media-libs/libpng-1.6.3-r1:0/16 [1.6.2:0/16] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 859 kB
[nomerge ] app-portage/genlop-0.30.9-r1
[nomerge ] dev-perl/libwww-perl-6.40.0 USE="ssl"
[nomerge ] dev-perl/LWP-Protocol-https-6.30.0
[nomerge ] dev-perl/IO-Socket-SSL-1.840.0 USE="-idn"
[nomerge ] virtual/perl-Scalar-List-Utils-1.270.0
[nomerge ] perl-core/Scalar-List-Utils-1.270.0
[ebuild R ] dev-lang/perl-5.16.3:0/5.16 USE="berkdb gdbm -debug -doc -ithreads (-build%)" 13,420 kB
[ebuild U ] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)" 558 kB
[nomerge ] sys-auth/pambase-20120417-r2 USE="consolekit cracklib sha512 systemd* -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)"
[nomerge ] sys-apps/systemd-206-r3 USE="acl filecaps firmware-loader gudev introspection kmod openrc pam policykit qrcode tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[nomerge ] sys-libs/libcap-2.22-r1 USE="pam"
[ebuild U ] sys-apps/attr-2.4.47-r1 [2.4.47] USE="nls -static-libs" ABI_X86="(64%*) -32% (-x32)" 336 kB
[ebuild U ] virtual/ffmpeg-9 [0.10.3] USE="X encode mp3 sdl theora truetype vdpau x264 -gsm -jpeg2k -opus% -speex -threads -vaapi" 0 kB
[ebuild N ] virtual/service-manager-0 USE="(-prefix)" 0 kB
[ebuild R ] sys-apps/busybox-1.21.0 USE="ipv6 pam static -livecd -make-symlinks -math -mdev -savedconfig (-selinux) -sep-usr -syslog% -systemd" 2,150 kB
[nomerge ] app-emulation/wine-1.5.13 USE="X alsa cups gecko gnutls jpeg lcms ldap mono mp3 ncurses nls opengl oss perl png pulseaudio samba ssl threads truetype udisks v4l win32 win64 xml -capi -custom-cflags -fontconfig -gphoto2 -gsm (-gstreamer) -hardened -odbc -openal -opencl -osmesa -scanner (-selinux) {-test} -xcomposite -xinerama"
[ebuild U ] media-libs/libv4l-1.0.0 [0.9.5] ABI_X86="(64%*) -32% (-x32)" 941 kB
[ebuild U ] net-misc/iputils-20121221-r1 [20101006-r2] USE="filecaps%* ipv6 ssl -SECURITY_HAZARD -caps% -doc -gnutls% -idn -static" 175 kB
[nomerge ] games-action/minecraft-20120805-r1::java USE="ipv6"
[nomerge ] dev-java/lwjgl-2.8.5:2.8::java USE="-doc -egl -source"
[ebuild R ] dev-java/java-config-2.2.0:2::java PYTHON_TARGETS="python2_7 python3_3* (-pypy1_9) -python2_6 (-python3_1) -python3_2*" 51 kB
[nomerge ] media-tv/xbmc-11.0-r1 USE="alsa avahi bluetooth profile projectm pulseaudio rsxs samba sse sse2 udev vdpau xrandr -airplay (-altivec) -bluray -cec -css -debug -goom -joystick -midi -mysql -pvr -rtmp -vaapi -webserver"
[nomerge ] media-libs/fontconfig-2.10.2-r1:1.0 USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge ] app-admin/eselect-fontconfig-1.1
[ebuild U ] app-admin/eselect-1.3.7 [1.3.4] USE="-doc -emacs% -vim-syntax%" 163 kB
[ebuild U ] dev-libs/libcdio-0.90-r1 [0.90] USE="cxx -cddb -minimal -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 2,589 kB
[nomerge ] media-plugins/frei0r-plugins-1.3 USE="facedetect scale0tilt -doc"
[nomerge ] media-libs/opencv-2.4.5 USE="ffmpeg gtk jpeg opengl png qt4 tiff v4l -cuda -doc -eigen -examples -gstreamer -ieee1394 (-ipp) -java -jpeg2k -opencl -openexr -pch -testprograms -threads -xine"
[ebuild R ] dev-python/numpy-1.7.1 USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 2,772 kB
[ebuild U ] dev-python/setuptools-0.9.8-r1 [0.7.2-r1] PYTHON_TARGETS="python2_7 python3_3* (-pypy1_9) -pypy2_0 (-python2_5) -python2_6 (-python3_1) -python3_2*" 749 kB
[nomerge ] media-sound/pulseaudio-4.0 USE="X alsa asyncns bluetooth caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt4 ssl tcpd udev webrtc-aec -avahi* -doc -gnome* -jack -lirc (-neon) (-oss) -realtime (-system-wide) -systemd {-test} -xen"
[nomerge ] dev-python/PyQt4-4.10.2 [4.10.1] USE="X dbus opengl svg -debug -declarative -doc -examples -help -kde -multimedia -phonon -script -scripttools -sql -webkit -xmlpatterns" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*"
[ebuild U ] dev-python/sip-4.14.7:0/10 [4.14.6:0/9] USE="-debug -doc" PYTHON_TARGETS="python2_7 python3_3* (-python2_5) -python2_6 (-python3_1) -python3_2*" 738 kB
[ebuild R ] dev-python/dbus-python-1.2.0 USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 589 kB
[nomerge ] net-wireless/bluez-4.101-r5 USE="alsa consolekit cups readline test-programs usb -debug -gstreamer -pcmcia (-selinux)" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild U ] virtual/libusb-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[nomerge ] net-print/mtink-1.0.16-r1 USE="X cups -doc"
[nomerge ] virtual/libusb-0-r1 [0] ABI_X86="(64%*) -32% (-x32)"
[nomerge ] dev-libs/libusb-compat-0.1.5-r2 USE="-debug -examples -static-libs" ABI_X86="(64) -32 (-x32)"
[blocks b ] dev-libs/libusb:0 ("dev-libs/libusb:0" is blocking dev-libs/libusb-compat-0.1.5-r2)
[uninstall ] dev-libs/libusb-0.1.12-r7 USE="cxx -debug -doc -static-libs"
[ebuild N ] dev-libs/libusb-compat-0.1.5-r2 USE="-debug -examples -static-libs" ABI_X86="(64) -32 (-x32)" 271 kB
[ebuild U ] sys-process/procps-3.3.8 [3.3.4] USE="ncurses nls%* unicode -static-libs" 541 kB
[ebuild U ] app-arch/gzip-1.6 [1.5] USE="-pic -static (-nls%*)" 709 kB
[nomerge ] media-video/mplayer-1.1-r1 USE="X a52 alsa bl bluray cdio dts dv dvd dvdnav enca encode faac faad gif iconv ipv6 jpeg libass libcaca libmpeg2 live mad mmx mng mp3 network opengl osdmenu png pulseaudio quicktime rar real rtc samba sdl shm speex sse sse2 ssse3 theora toolame tremor truetype twolame unicode v4l vdpau vorbis x264 xscreensaver xv xvid xvmc -3dnow -3dnowext -aalib (-altivec) (-aqua) -bidi -bindist -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dvb -dxr3 -fbcon -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -lirc -lzo -md5sum -mmxext -nas -nut -openal -oss -pnm -pvr -radio -rtmp -tga (-vidix) -win32codecs -xanim -xinerama -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild U ] media-libs/xvid-1.3.2-r1 [1.3.2] USE="threads -examples -pic" ABI_X86="(64%*) -32% (-x32)" 681 kB
[nomerge ] media-video/ffmpeg-1.2.2 [1.0.7] USE="X aac aacplus alsa avx bluray bzip2 cdio doc encode faac fontconfig frei0r hardcoded-tables iconv%* libass libv4l mmx modplug mp3 network pulseaudio sdl theora truetype v4l vdpau vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -amr -bindist (-celt) -cpudetection -debug -examples -fdk -flite -gnutls* -gsm -iec61883 -ieee1394 -jack -jpeg2k -libcaca -libsoxr% -mmxext (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -threads -twolame -vaapi (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape%* ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
[ebuild U ] media-libs/vo-aacenc-0.1.3 [0.1.2] USE="-examples (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 599 kB
[nomerge ] media-sound/pulseaudio-4.0 USE="X alsa asyncns bluetooth caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt4 ssl tcpd udev webrtc-aec -avahi* -doc -gnome* -jack -lirc (-neon) (-oss) -realtime (-system-wide) -systemd {-test} -xen"
[ebuild U ] media-libs/webrtc-audio-processing-0.1-r1 [0.1] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 384 kB
[nomerge ] media-tv/xbmc-11.0-r1 USE="alsa avahi bluetooth profile projectm pulseaudio rsxs samba sse sse2 udev vdpau xrandr -airplay (-altivec) -bluray -cec -css -debug -goom -joystick -midi -mysql -pvr -rtmp -vaapi -webserver"
[nomerge ] sys-power/upower-0.9.20-r2 USE="deprecated introspection -doc -ios -systemd"
[ebuild U ] virtual/libusb-1-r1:1 [1:1] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] dev-libs/libusb-1.0.9-r2:1 [1.0.9:1] USE="-debug -doc -examples% -static-libs" ABI_X86="(64%*) -32% (-x32)" 413 kB
[ebuild U ] virtual/jpeg-0-r2 [0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] media-libs/jpeg-9-r1 [8d] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 979 kB
[nomerge ] dev-lang/python-3.3.2:3.3 USE="gdbm ipv6 ncurses readline sqlite ssl threads xml -build -doc -examples -hardened -tk -wininst"
[ebuild U ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] dev-libs/libffi-3.0.13-r1 [3.0.13] USE="-debug -pax_kernel -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 826 kB
[nomerge ] media-sound/rhythmbox-0.13.3 USE="cdr gnome-keyring ipod lastfm libnotify nsplugin udev upnp webkit -daap -debug -doc -lirc -mtp -musicbrainz -python {-test}"
[nomerge ] media-libs/gst-plugins-base-1.0.7:1.0 USE="X alsa introspection nls ogg orc pango theora vorbis -ivorbis"
[ebuild U ] media-libs/libogg-1.3.1 [1.3.0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 398 kB
[ebuild U ] app-arch/xz-utils-5.0.5-r1 [5.0.4-r1] USE="nls threads -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,276 kB
[nomerge ] net-misc/rsync-3.0.9-r2 USE="acl iconv ipv6 -static -xattr"
[ebuild U ] virtual/libiconv-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[nomerge ] x11-libs/wxGTK-2.8.12.1:2.8 USE="X gnome gstreamer opengl sdl tiff (-aqua) -debug -doc -odbc -pch"
[ebuild U ] dev-libs/expat-2.1.0-r3 [2.1.0-r2] USE="unicode -examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 550 kB
[ebuild U ] app-arch/bzip2-1.0.6-r4 [1.0.6-r3] USE="-static -static-libs" ABI_X86="(64%*) -32% (-x32)" 764 kB
[nomerge ] net-wireless/bluez-4.101-r5 USE="alsa consolekit cups readline test-programs usb -debug -gstreamer -pcmcia (-selinux)" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild R ] dev-python/python-exec-0.3.1 PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) (-pypy1_9*) (-python2_5*) (-python3_1*)" 73 kB

Total: 81 packages (61 upgrades, 1 downgrade, 4 new, 15 reinstalls, 1 uninstall), Size of downloads: 392,040 kB
Conflict: 2 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:4

(dev-qt/qtcore-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtcore-4.8.5[aqua=,debug=] required by (dev-qt/designer-4.8.5::gentoo, ebuild scheduled for merge)
(and 4 more with the same problem)

(dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
~dev-qt/qtcore-4.8.4[aqua=,debug=] required by (dev-qt/qtxmlpatterns-4.8.4::gentoo, installed)
(and 11 more with the same problem)

dev-qt/qtgui:4

(dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge)
(and 2 more with the same problem)

(dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
dev-qt/qtgui:4/4=[dbus] required by (net-p2p/transmission-2.77::gentoo, installed)
~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support=,trace?] required by (dev-qt/qthelp-4.8.4::gentoo, installed)
(and 7 more with the same problems)

dev-qt/qtscript:4

(dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
(and 1 more with the same problem)

dev-qt/qt3support:4

(dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
~dev-qt/qt3support-4.8.4[accessibility=,aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.4::gentoo, installed)
(and 1 more with the same problem)

(dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

dev-qt/qtsql:4

(dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.4::gentoo, installed)
(and 2 more with the same problem)

(dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge)

dev-lang/perl:0

(dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-lang/perl-5.16.3::gentoo, installed) pulled in by
dev-lang/perl[-build] required by (app-arch/rpm-4.10.0::gentoo, installed)
>=dev-lang/perl-5.8.2-r1[-build] required by (net-im/pidgin-2.10.6::gentoo, installed)
dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.6::gentoo, installed)
dev-lang/perl[-build] required by (dev-vcs/git-1.8.2.1::gentoo, installed)

dev-python/setuptools:0

(dev-python/setuptools-0.9.8-r1::gentoo, ebuild scheduled for merge) pulled in by
dev-python/setuptools[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/numpy-1.7.1::gentoo, ebuild scheduled for merge)

(dev-python/setuptools-0.7.2-r1::gentoo, installed) pulled in by
dev-python/setuptools[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy1_9(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy1_9(-),-python_single_target_pypy2_0(-)] required by (dev-python/jinja-2.6-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


autant dire que je ne suis pas beaucoup plus avancé :s
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Sat Aug 17, 2013 2:00 pm    Post subject: Reply with quote

Pour les dépendances de qt qui se bloquent, c'est lié à un changement dans la gestion des versions des SLOTs de qt.

A priori, si je lis bien ton blocage, cela vient de "transmission". Les dépendances ont été mises à jour dans l'ebuild (le 5 aout d'après le changelog). Mais j'ai déjà remarqué sur d'autres paquets que pour réglé les blocages, il fallait ré-emerger le paquet concerné.
Donc tente donc un petit "emerge transmission". Cela devrait te débloquer au moins une partie du blocage !



Pour la partie liée à perl, j'aimerai bien voir un petit "emerge -pv perl", j'ai l'impression qu'un USE flag qui tue des chatons est utilisé ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sat Aug 17, 2013 5:51 pm    Post subject: Reply with quote

alors deja merci pour le conseil, ca semble avoir un peu démelé le sac de noeuds,

en revanche, j'ai maintenant un probleme avec qtqui:

Quote:
x86_64-pc-linux-gnu-g++ -c -O2 -pipe -mtune=core2 -march=core2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -fvisibility=hidden -fvisibility-inlines-hidden -D_REENTRANT -Wall -W -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_HAVE_SSE4_1 -DQT_HAVE_SSE4_2 -DQT_HAVE_AVX -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_SHARED -I../../../../mkspecs/linux-g++ -I. -I../../../../include/QtCore -I../../../../include/QtGui -I../../../../include -I../../../gui/image -I.moc/release-shared -o .obj/release-shared/main.o main.cpp
../../../gui/image/qjpeghandler.cpp: In function 'boolean qt_fill_input_buffer(j_decompress_ptr)':
../../../gui/image/qjpeghandler.cpp:163:12: erreur: cannot convert 'bool' to 'boolean' in return
../../../gui/image/qjpeghandler.cpp: In function 'boolean qt_empty_output_buffer(j_compress_ptr)':
../../../gui/image/qjpeghandler.cpp:495:12: erreur: cannot convert 'bool' to 'boolean' in return
../../../gui/image/qjpeghandler.cpp: In function 'bool write_jpeg_image(const QImage&, QIODevice*, int)':
../../../gui/image/qjpeghandler.cpp:591:83: erreur: cannot convert 'bool' to 'boolean' for argument '3' to 'void jpeg_set_quality(j_compress_ptr, int, boolean)'
../../../gui/image/qjpeghandler.cpp:592:41: erreur: cannot convert 'bool' to 'boolean' for argument '2' to 'void jpeg_start_compress(j_compress_ptr, boolean)'
../../../gui/image/qjpeghandler.cpp: In member function 'bool QJpegHandlerPrivate::readJpegHeader(QIODevice*)':
../../../gui/image/qjpeghandler.cpp:757:48: erreur: cannot convert 'bool' to 'boolean' for argument '2' to 'int jpeg_read_header(j_decompress_ptr, boolean)'
../../../gui/image/qjpeghandler.cpp: In function 'boolean qt_empty_output_buffer(j_compress_ptr)':
../../../gui/image/qjpeghandler.cpp:497:1: attention : contr�le a atteint la fin non void de la fonction [-Wreturn-type]
../../../gui/image/qjpeghandler.cpp: In function 'boolean qt_fill_input_buffer(j_decompress_ptr)':
../../../gui/image/qjpeghandler.cpp:165:1: attention : contr�le a atteint la fin non void de la fonction [-Wreturn-type]
make: *** [.obj/release-shared/qjpeghandler.o] Erreur 1
* ERROR: dev-qt/qtgui-4.8.5::gentoo failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=dev-qt/qtgui-4.8.5::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-qt/qtgui-4.8.5::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-qt/qtgui-4.8.5/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtgui-4.8.5/temp/environment'.
* Working directory: '/var/tmp/portage/dev-qt/qtgui-4.8.5/work/qt-everywhere-opensource-src-4.8.5/src/plugins/imageformats/jpeg'
* S: '/var/tmp/portage/dev-qt/qtgui-4.8.5/work/qt-everywhere-opensource-src-4.8.5'

>>> Failed to emerge dev-qt/qtgui-4.8.5, Log file:


et la me vient une question toute simple: le mec qui commit, il la teste au moin sa maj ou il attends juste le retour sur bugzilla ? xD
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Sun Aug 18, 2013 7:52 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=480182

Au passage, il n'y a pas ce problème avec libjpeg-turbo à la place de jpeg-9 ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Aug 18, 2013 6:54 pm    Post subject: Reply with quote

le passage a jpeg turbo a corrigé le probleme avec qtgui mais maintenant c'est consolekit qui m'en fait voir de toutes les couleurs:

Quote:
configure: error: Package requirements (glib-2.0 >= 2.22.0 gobject-2.0 >= 2.22.0 libudev) were not met:

No package 'libudev' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables UDEV_ACL_CFLAGS
and UDEV_ACL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-auth/consolekit-0.4.6/work/ConsoleKit-0.4.6/config.log
* ERROR: sys-auth/consolekit-0.4.6::gentoo failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 93: Called src_configure
* environment, line 4156: Called econf 'XMLTO_FLAGS=--skip-validation' '--libexecdir=/usr/lib/ConsoleKit' '--localstatedir=/var' '--enable-pam-module' '--disable-docbook-docs' '--disable-docbook-docs' '--disable-debug' '--enable-polkit' '--enable-udev-acl' '--with-dbus-services=/usr/share/dbus-1/services' '--with-pam-module-dir=/lib64/security' '--with-systemdsystemunitdir=/usr/lib/systemd/system'
* phase-helpers.sh, line 521: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of `emerge --info '=sys-auth/consolekit-0.4.6::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-auth/consolekit-0.4.6::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-auth/consolekit-0.4.6/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-auth/consolekit-0.4.6/temp/environment'.
* Working directory: '/var/tmp/portage/sys-auth/consolekit-0.4.6/work/ConsoleKit-0.4.6'
* S: '/var/tmp/portage/sys-auth/consolekit-0.4.6/work/ConsoleKit-0.4.6'


alors que:
Quote:
pouet package.use # eix gobject
[I] dev-libs/gobject-introspection
Available versions: 1.32.1 (~)1.34.2-r1{tbz2} (~)1.36.0{tbz2} {cairo doc doctool test PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"}
Installed versions: 1.36.0{tbz2}(22:48:55 16/08/2013)(cairo -doctool -test PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7")
Homepage: http://live.gnome.org/GObjectIntrospection/
Description: Introspection infrastructure for generating gobject library bindings for various languages

[I] dev-libs/gobject-introspection-common
Available versions: 1.32.1 (~)1.34.2{tbz2} (~)1.36.0{tbz2}
Installed versions: 1.36.0{tbz2}(15:01:49 14/08/2013)
Homepage: http://live.gnome.org/GObjectIntrospection/
Description: Build infrastructure for GObject Introspection

[I] dev-python/pygobject
Available versions:
(2) 2.28.6-r53{tbz2}
(3) 3.2.2-r1 (~)3.4.2-r1{tbz2} (~)3.8.2 (~)3.8.3{tbz2}
{+cairo examples libffi test +threads PYTHON_TARGETS="python2_6 python2_7 python3_1 python3_2 python3_3"}
Installed versions: 2.28.6-r53(2){tbz2}(11:50:13 18/02/2013)(-examples -libffi -test PYTHON_TARGETS="python2_7 -python2_6") 3.8.3(3){tbz2}(16:24:37 18/08/2013)(cairo threads -examples -test PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_1 -python3_2")
Homepage: http://www.pygtk.org/
Description: GLib's GObject library bindings for Python

* dev-ruby/ruby-cairo-gobject
Available versions: (~)1.2.6 {test ELIBC="FreeBSD" RUBY_TARGETS="ruby19"}
Homepage: http://ruby-gnome2.sourceforge.jp/
Description: Ruby cairo-gobject bindings

* dev-ruby/ruby-gobject-introspection
Available versions: (~)1.2.6 {test ELIBC="FreeBSD" RUBY_TARGETS="ruby19"}
Homepage: http://ruby-gnome2.sourceforge.jp/
Description: Ruby GObjectIntrosprction bindings

Found 5 matches.
pouet package.use # eix -I glib
[U] dev-cpp/glibmm
Available versions: (2) 2.32.1 (~)2.34.1{tbz2} (~)2.36.0 (~)2.36.2
{debug doc examples test}
Installed versions: 2.34.1(2){tbz2}(22:21:49 31/01/2013)(-debug -doc -examples -test)
Homepage: http://www.gtkmm.org
Description: C++ interface for glib2

[I] dev-libs/dbus-glib
Available versions: 0.100.2{tbz2} {debug doc static-libs test}
Installed versions: 0.100.2{tbz2}(22:00:39 16/06/2013)(-debug -doc -static-libs -test)
Homepage: http://dbus.freedesktop.org/
Description: D-Bus bindings for glib

[D] dev-libs/glib
Available versions:
(1) 1.2.10-r5
(2) 2.32.4-r1{tbz2} (~)2.34.3{tbz2} (~)2.36.2 (~)2.36.3
{debug fam hardened selinux static-libs systemtap test utils xattr KERNEL="linux" PYTHON_TARGETS="python2_5 python2_6 python2_7"}
Installed versions: 2.36.4(2){tbz2}(13:28:05 17/08/2013)(-debug -fam -selinux -static-libs -systemtap -test -utils -xattr ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32" KERNEL="linux" PYTHON_TARGETS="python2_7 -python2_5 -python2_6")
Homepage: http://www.gtk.org/
Description: The GLib library of C routines

[U] dev-libs/json-glib
Available versions: 0.14.2 0.15.2 (~)0.16.0 {debug +introspection}
Installed versions: 0.14.2(18:50:19 25/12/2012)(introspection -debug)
Homepage: http://live.gnome.org/JsonGlib
Description: A library providing GLib serialization and deserialization support for the JSON format

[U] dev-perl/glib-perl
Available versions: 1.262.0 1.280.0
Installed versions: 1.262.0(10:19:12 12/08/2012)
Homepage: http://gtk2-perl.sf.net/ http://search.cpan.org/dist/Glib/
Description: Glib - Perl wrappers for the GLib utility and Object libraries

[I] media-libs/taglib
Available versions: 1.7.2 1.8-r1{tbz2} {+asf debug examples +mp4 test}
Installed versions: 1.8-r1{tbz2}(22:04:02 16/06/2013)(asf mp4 -debug -examples -test)
Homepage: http://developer.kde.org/~wheeler/taglib.html
Description: A library for reading and editing audio meta data

[U] media-plugins/gst-plugins-taglib
Available versions:
(0.10) 0.10.31^t
(1.0) 1.0.5^t (~)1.0.6^t (~)1.0.7^t
Installed versions: 0.10.31(0.10)^t(20:27:35 14/12/2012)
Homepage: http://gstreamer.freedesktop.org/
Description: GStreamer taglib based tag handler

[I] net-libs/glib-networking
Available versions: 2.32.3 (~)2.34.2{tbz2} (~)2.36.1 (~)2.36.2{tbz2} {+gnome +libproxy smartcard +ssl test}
Installed versions: 2.36.2{tbz2}(16:46:09 18/08/2013)(gnome libproxy ssl -smartcard -test)
Homepage: http://git.gnome.org/browse/glib-networking/
Description: Network-related giomodules for glib

[U] net-libs/telepathy-glib
Available versions: 0.20.1-r1 (~)0.20.2 (~)0.20.3 {debug +introspection test +vala PYTHON_TARGETS="python2_5 python2_6 python2_7"}
Installed versions: 0.18.2(11:55:27 21/09/2012)(introspection vala -debug -test)
Homepage: http://telepathy.freedesktop.org
Description: GLib bindings for the Telepathy D-Bus protocol.

[I] sys-libs/glibc
Available versions: (2.2) (~)2.9_p20081201-r3^s 2.10.1-r1^s 2.11.3^s (~)2.12.1-r3^s 2.12.2^s (~)2.13-r2^s 2.13-r4^s (~)2.14^s (~)2.14.1-r2^s 2.14.1-r3^s (~)2.15-r1^s 2.15-r2^s 2.15-r3^s (~)2.16.0^s (~)2.17^s{tbz2} **9999^s
{debug gd hardened multilib nscd profile selinux suid systemtap vanilla CROSSCOMPILE_OPTS="headers-only"}
Installed versions: 2.17(2.2)^s{tbz2}(19:58:55 16/06/2013)(multilib -debug -gd -hardened -nscd -profile -selinux -suid -systemtap -vanilla CROSSCOMPILE_OPTS="-headers-only")
Homepage: http://www.gnu.org/software/libc/libc.html
Description: GNU libc6 (also called glibc2) C library

Found 10 matches.


j'avoue être un peu perplexe la :s
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 188

PostPosted: Sun Aug 18, 2013 8:18 pm    Post subject: Reply with quote

en fait il manquais pas libudev mais sys-fs/udev (logique, pourquoi metre le bon nom ^)

me reste encore 277 mises à jours avant de pouvoir passer a systemd, je pense que je ne suis pas au bout de mes peines :s

edit:

comme prévu nouveau probleme de compilation , sur boost cette fois ci:

Quote:
"x86_64-pc-linux-gnu-g++" -o "../bin.v2/tools/wave/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/wave" -Wl,--start-group "../bin.v2/tools/wave/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/cpp.o" "../bin.v2/libs/date_time/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_date_time.a" "../bin.v2/libs/thread/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_thread.a" "../bin.v2/libs/filesystem/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_filesystem.a" "../bin.v2/libs/system/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_system.a" "../bin.v2/libs/serialization/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_serialization.a" "../bin.v2/libs/program_options/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_program_options.a" "../bin.v2/libs/wave/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_wave.a" "../bin.v2/libs/chrono/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_chrono.a" "../bin.v2/libs/date_time/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_date_time.a" "../bin.v2/libs/thread/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_thread.a" "../bin.v2/libs/filesystem/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_filesystem.a" "../bin.v2/libs/system/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/libboost_system.a" -Wl,-Bstatic -Wl,-Bdynamic -lrt -Wl,--end-group -Wl,-O1 -Wl,--as-needed -pthread


common.copy ../dist/bin/wave

cp "../bin.v2/tools/wave/build/gcc-4.7/gentoorelease/link-static/pch-off/threading-multi/wavetool-on/wave" "../dist/bin/wave"

...failed updating 1 target...


pour le coup je ne vois pas vraiment l'erreur :s

edit: fixé en retirant l'useflag "tools" de boost ( echo "dev-libs/boost -tools" >> /etc/portage/package.use/boost.use ) (je met la solution des fois que le probleme arrive à quelqu'un d'autre)
en revanche a présent j'ai un soucis avec freeimage, je pense que c'est en raport avec jpeg turbo:

Quote:
Source/transupp.c: In function 'do_flip_h_no_crop':
Source/transupp.c:136:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c: In function 'do_flip_h':
Source/transupp.c:202:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c: In function 'do_flip_v':
Source/transupp.c:267:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c: In function 'do_rot_90':
Source/transupp.c:395:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c: In function 'do_rot_270':
Source/transupp.c:476:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c: In function 'do_rot_180':
Source/transupp.c:544:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:546:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c: In function 'do_transverse':
Source/transupp.c:655:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:657:42: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c: In function 'jtransform_request_workspace':
Source/transupp.c:907:11: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:908:11: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c:914:40: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:915:40: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c:934:40: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c:935:41: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:938:38: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c:940:38: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:947:40: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:948:41: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c:951:38: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:953:38: erreur: 'struct jpeg_decompress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c: In function 'transpose_critical_parameters':
Source/transupp.c:1126:18: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:1127:10: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_h_scaled_size'
Source/transupp.c:1127:43: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c:1128:10: erreur: 'struct jpeg_compress_struct' has no member named 'min_DCT_v_scaled_size'
Source/transupp.c: In function 'jtransform_adjust_parameters':
Source/transupp.c:1364:10: erreur: 'struct jpeg_compress_struct' has no member named 'jpeg_width'
Source/transupp.c:1365:10: erreur: 'struct jpeg_compress_struct' has no member named 'jpeg_height'
Source/transupp.c:1392:16: erreur: 'struct jpeg_compress_struct' has no member named 'jpeg_width'
Source/transupp.c:1393:9: erreur: 'struct jpeg_compress_struct' has no member named 'jpeg_height'
Source/transupp.c:1397:9: erreur: 'struct jpeg_compress_struct' has no member named 'jpeg_width'
Source/transupp.c:1397:30: erreur: 'struct jpeg_compress_struct' has no member named 'jpeg_height'
make: *** [Source/transupp.o] Erreur 1
make: *** Attente des t�ches non termin�es....
* ERROR: media-libs/freeimage-3.15.4::gentoo failed (compile phase):


que faire ? repasser a la lib standard ou utiliser un patch ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum