Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I lost my sound after the emerge -e system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
bluephoenix
n00b
n00b


Joined: 01 Nov 2008
Posts: 71

PostPosted: Sun Aug 18, 2013 7:22 pm    Post subject: I lost my sound after the emerge -e system Reply with quote

I found I also lost my sound when I play a video or mp3.

I can find my sound card if I use "lspci" or "alsamixer".

But i fail to play even a mp3 whatever I use moc or SMPlayer.

Who can give me a hint about how to detect the fault?

I didn't change the kernel, so I think it should be the problem.

Thank you very much!
Back to top
View user's profile Send private message
bluephoenix
n00b
n00b


Joined: 01 Nov 2008
Posts: 71

PostPosted: Sun Aug 18, 2013 7:26 pm    Post subject: Reply with quote

I remember when I upgrade my system by using "emerge --depclean", Gentoo asked me to delete some file relative with sound, was saying there is conflict with Alsa. I confirmed at that time. I guess this action cause the problem.

But I think even this is the real reason, I don't know the way to find them back.
Back to top
View user's profile Send private message
tryn
Apprentice
Apprentice


Joined: 21 Dec 2002
Posts: 262

PostPosted: Sun Aug 18, 2013 7:34 pm    Post subject: Reply with quote

bluephoenix

If you have this file it might tell you what you removed with emerge --depclean.
Look here /var/log/emerge.log

If you have this file it should show you what you removed with the command emerge --depclean.
Back to top
View user's profile Send private message
bluephoenix
n00b
n00b


Joined: 01 Nov 2008
Posts: 71

PostPosted: Mon Aug 19, 2013 7:49 am    Post subject: Reply with quote

I checked <emerge.log> and i found the deleted document is alsa-headers. And I found it is replaced by linux-headers.

So I emerged linux-header then.

But still no sound now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum