Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel panic - not syncing no init found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Satay
n00b
n00b


Joined: 26 Jul 2012
Posts: 2

PostPosted: Wed Aug 07, 2013 9:39 am    Post subject: kernel panic - not syncing no init found Reply with quote

Ставлю 2 системы на 1 машину.
fdisk -l
Code:

Disk /dev/sda: 500.1 GB, 500107862016 bytes, 976773168 sectors
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   163839999    81816576    7  HPFS/NTFS/exFAT
/dev/sda3   *   163840000   168034303     2097152   83  Linux
/dev/sda4       168034304   976773167   404369432    5  Extended
/dev/sda5       168036352   272893951    52428800   83  Linux


lilo.conf
Code:

lba32
boot = /dev/sda
map = /boot/.map
#install = /boot/boot-menu.b   # Note that for lilo-22.5.5 or later you

menu-scheme=Wb
prompt
delay = 50
vga = normal

image = /boot/vmlinuz-3.8.13
   root = /dev/sda3
   #root = /devices/discs/disc0/part3
   label = Gentoo
   read-only # read-only for checking

other = /dev/sda1
   #other = /devices/discs/disc0/part1
   label = Windows
   table = /dev/sda


При загрузке Gentoo получаю
Code:
kernel panic - not syncing no init found

В чем может быть беда?
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3601
Location: USA

PostPosted: Thu Aug 08, 2013 9:54 pm    Post subject: Reply with quote

Ok, I apologize, no Russian at all in me.

First off I noticed your fdisk -l contains two active boot partitions. This is most certainly incorrect, there can only be one.

Next off, what are you planning on using as your primary bootloader (the first one that boots up?)

On my dual boot machine, Windows7 bootloader is the primary bootloader. Unfortunately I don't remember how I set this up, but basically I go through the windows bootloader, then the linux bootloader (which happens to be grub-0.99) which loads the kernel.

You have two Linux partitions, what are the function of each? What is the small one for? The root= needs to point to what you're using as your root partition.

One thing that I'm not sure of, since I haven't used lilo in a long time: Could you need "append = root=/dev/sda3" ?

Also was the kernel able to mount the partition at all? (probably did, but just to make sure), and how was your installation installed? Might need to recheck the Gentoo handbook to make sure that you untarred the stage3 on the right directory.

(another potential future issue: you may need loader=chainloader or something like that to boot windows with lilo).
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum