Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] can't emerge gwenview-4.10.5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SylaSebas
n00b
n00b


Joined: 07 Aug 2013
Posts: 26

PostPosted: Wed Aug 07, 2013 7:20 am    Post subject: [SOLVED] can't emerge gwenview-4.10.5 Reply with quote

hi everyone

I've been using gentoo for quite some time now and I've always found the solution to my problems somewhere in this forum or elsewhere in the web. however, I haven't found a solution to this particular problem so I thought I'd post it myself this time.

in short: gwenview-4.10.5 doesn't emerge ... seems like a problem with the jpeg library ... or to be more specific libjpeg-turbo

it started with this message after an emerge world -uDv:
Code:


!!! existing preserved libs:
>>> package: media-libs/jpeg-8d
 *  - /usr/lib64/libjpeg.so.8
 *  - /usr/lib64/libjpeg.so.8.4.0
 *      used by /opt/icedtea-bin-6.1.12.6/jre/lib/amd64/libsplashscreen.so (dev-java/icedtea-bin-6.1.12.6)
Use emerge @preserved-rebuild to rebuild packages using these libraries


i did this and it always emerge the icedtea-bin-6.1.12.6 again but it's unable to emerge gwenview. here's the error message:

Code:

-- No version defined in /usr/include/jpeglib.h, looking for jconfig.h
-- Found jconfig.h: /usr/include/jconfig.h
-- Looking for libjpeg version in /usr/include/jconfig.h
CMake Error at lib/CMakeLists.txt:36 (message):
  Unknown libjpeg version:


anyone an idea on how to solve this?

thanks in advance and best regards, Silvan



PS: here's the output from emerge --info '=kde-base/gwenview-4.10.5'

Code:

emerge --info '=kde-base/gwenview-4.10.5'
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3                             , 3.8.13-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.8.13-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1055T_Processor-wi                             th-gentoo-2.2
KiB Mem:     8176780 total,   6917588 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Wed, 07 Aug 2013 06:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5, 3.2.5-r1
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo ohnobinki_overlay steam-overlay regen2-overlay
Installed sets: @steam
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share                             /polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf                              /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo                              /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/tex                             mf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild                             -locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned san                             dbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch                             "
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress                              --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/                             distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/ohnobinki /var/lib/layman/steam /var/lib/layman                             /regen2-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi aim airplay alsa amd64 berkdb bindist blu                             etooth bluray branding bzip2 cairo calendar cdda cdr clamav clamdtop cli console                             kit cracklib crypt cups cvs cxx dbus declarative dedicated display dri dts dvb d                             vd dvdr embedded emboss encode exif extras fam fat firefox flac flash fortran ft                             p gdbm gif gimp git gpm gptfdisk gudev gzip hwdb iconv ieee1394 imagemagick imap                              introspection ipod ipv6 java java6 javascript joystick jpeg jpeg2k kde kdrive k                             erberos keymap kipi lame latex lcms ldap libkms libnotify libwww mad mercurial m                             essages midi milter mime minizip mmx mng modules mozilla mp3 mp4 mpeg mpg123 mpl                             ayer msn mudflap multilib mysql mysqli nas ncurses nfs nls nptl ntfs ocaml ogg o                             penal openexr opengl openmp oss pam pango pcre pdf perl phonon php plasma png po                             licykit postscript ppds profile pulseaudio python qt3support qt4 quicktime readl                             ine rule_generator samba sdl semantic-desktop session sftp sound spell sse sse2                              sse3 ssl startup-notification steamgames_journey_down steamgames_tf2 steamgames_                             trine2 steamgames_unwritten_tales subversion svg tcpd tiff timidity truetype ude                             v udisks unicode upnp upower usb v4l vim-syntax vorbis webserver win32 win32code                             cs win64 wma wxwidgets x264 xa xcb xcomposite xine xinerama xml xorg xscreensave                             r xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem                              bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel                             8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_M                             ODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn                             _alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default aut                             hz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_                             fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter head                             ers include info log_config logio mem_cache mime mime_magic negotiation rewrite                              setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATUR                             ES="kexi words flow plan sheets stage tables krita karbon braindump author" CAME                             RAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" E                             LIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmin                             txt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104                             v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev"                              KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 m                             txorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimize                             r" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_                             SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="rub                             y19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknoc                             k lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit s                             ysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BU                             NZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPT                             S, USE_PYTHON


Last edited by SylaSebas on Wed Aug 07, 2013 9:11 am; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Wed Aug 07, 2013 9:05 am    Post subject: Reply with quote

It was fixed half an week ago in Portage,

Quote:

*gwenview-4.10.5-r1 (03 Aug 2013)

03 Aug 2013; Jonathan Callen <jcallen@gentoo.org> +gwenview-4.10.5-r1.ebuild:
Revision bump to fix build with multilib libjpeg-turbo


Plus the icedtea-bin issue is tracked at https://bugs.gentoo.org/show_bug.cgi?id=479442
Back to top
View user's profile Send private message
SylaSebas
n00b
n00b


Joined: 07 Aug 2013
Posts: 26

PostPosted: Wed Aug 07, 2013 9:10 am    Post subject: SOLVED: can't emerge gwenview-4.10.5 Reply with quote

now I was pretty sure I added gwenview to package.keywords...

well thank you very much for the tip, it works just fine! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum