Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-drivers-319.30/325-08 failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Mark Knecht
n00b
n00b


Joined: 16 Sep 2003
Posts: 63

PostPosted: Sun Aug 04, 2013 3:15 pm    Post subject: nvidia-drivers-319.30/325-08 failing Reply with quote

Hi,
The newest nvidia-drivers packages ( 319.32 & 325.08 ) are failing silently here. I see a bit of graphics start for a second but it disappears quickly. I'm dropped back to the console and never see a login screen. nvidia-drivers-313.30 works fine. There are no error messages (EE) in Xorg.0.log. There is however this warning which has been there for awhile including 313.30 which I'm using while I write this post:

Quote:

[ 33.201] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[ 33.201] (WW) NVIDIA: is an unsupported configuration. The driver will continue
[ 33.201] (WW) NVIDIA: to load, but may behave strangely.
[ 33.201] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[ 33.201] (WW) NVIDIA: X server.
[ 33.201] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support


QUESTION: What 'Composite' are they talking about here and where do I disable it? (Assuming I should...)

The machine has 2 NVidia cards and 3 monitors set up with Xinerama to create 1 desktop.

I will post the complete Xorg.0.log file from the failing setup in a few minutes. xorg.conf follows.

Thanks,
Mark

Quote:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 275.09.07 (buildmeister@swio-display-x86-rhel47-03.nvidia.com) Wed Jun 8 14:38:19 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
Screen 2 "Screen2" RightOf "Screen1"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "1"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from data in "/etc/conf.d/gpm"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 75.0
VertRefresh 56.0 - 61.0
# Option "DPMS"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 75.0
VertRefresh 56.0 - 61.0
# Option "DPMS"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor2"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
# Option "DPMS"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 465"
BusID "PCI:2:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 465"
BusID "PCI:2:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device2"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400GS"
BusID "PCI:4:0:0"
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP-2: 1920x1080 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP-0: 1920x1080 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device "Device2"
Monitor "Monitor2"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1280x1024 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


Last edited by Mark Knecht on Sun Aug 04, 2013 4:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mark Knecht
n00b
n00b


Joined: 16 Sep 2003
Posts: 63

PostPosted: Sun Aug 04, 2013 4:08 pm    Post subject: Reply with quote

Here is the log file for 3225.08 which fails immediately when running /etc/init.d/xdm start from the command line:

Quote:

c2RAID6 ~ # cat Xorg.0.log-325.08
[ 5807.530]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[ 5807.530] X Protocol Version 11, Revision 0
[ 5807.530] Build Operating System: Linux 3.7.10-gentoo-r1 x86_64 Gentoo
[ 5807.530] Current Operating System: Linux c2RAID6 3.8.13-gentoo #5 SMP PREEMPT Fri Jul 19 10:28:53 PDT 2013 x86_64
[ 5807.530] Kernel command line: root=LABEL=RAID6root video=vesafb vga=0x307
[ 5807.530] Build Date: 03 May 2013 08:51:39AM
[ 5807.530]
[ 5807.530] Current version of pixman: 0.28.0
[ 5807.530] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 5807.530] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 5807.530] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 4 08:34:13 2013
[ 5807.530] (==) Using config file: "/etc/X11/xorg.conf"
[ 5807.530] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 5807.530] (==) ServerLayout "Layout0"
[ 5807.530] (**) |-->Screen "Screen0" (0)
[ 5807.530] (**) | |-->Monitor "Monitor0"
[ 5807.530] (**) | |-->Device "Device0"
[ 5807.530] (**) |-->Screen "Screen1" (1)
[ 5807.530] (**) | |-->Monitor "Monitor1"
[ 5807.530] (**) | |-->Device "Device1"
[ 5807.530] (**) |-->Screen "Screen2" (2)
[ 5807.530] (**) | |-->Monitor "Monitor2"
[ 5807.530] (**) | |-->Device "Device2"
[ 5807.530] (**) |-->Input Device "Keyboard0"
[ 5807.530] (**) |-->Input Device "Mouse0"
[ 5807.530] (**) Option "Xinerama" "1"
[ 5807.530] (==) Automatically adding devices
[ 5807.530] (==) Automatically enabling devices
[ 5807.530] (==) Automatically adding GPU devices
[ 5807.530] (**) Xinerama: enabled
[ 5807.530] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 5807.530] Entry deleted from font path.
[ 5807.530] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 5807.531] Entry deleted from font path.
[ 5807.531] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 5807.531] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 5807.531] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 5807.531] (WW) Disabling Keyboard0
[ 5807.531] (WW) Disabling Mouse0
[ 5807.531] (II) Loader magic: 0x808bc0
[ 5807.531] (II) Module ABI versions:
[ 5807.531] X.Org ANSI C Emulation: 0.4
[ 5807.531] X.Org Video Driver: 13.1
[ 5807.531] X.Org XInput driver : 18.0
[ 5807.531] X.Org Server Extension : 7.0
[ 5807.532] (--) PCI:*(0:2:0:0) 10de:06c4:3842:1467 rev 163, Mem @ 0xf6000000/33554432, 0xc0000000/134217728, 0xc8000000/67108864, I/O @ 0x00007c00/128, BIOS @ 0x????????/524288
[ 5807.532] (--) PCI: (0:4:0:0) 10de:10c3:3842:1301 rev 162, Mem @ 0xfa000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000ac00/128, BIOS @ 0x????????/524288
[ 5807.532] (II) Open ACPI successful (/var/run/acpid.socket)
[ 5807.532] Initializing built-in extension Generic Event Extension
[ 5807.532] Initializing built-in extension SHAPE
[ 5807.532] Initializing built-in extension MIT-SHM
[ 5807.533] Initializing built-in extension XInputExtension
[ 5807.533] Initializing built-in extension XTEST
[ 5807.533] Initializing built-in extension BIG-REQUESTS
[ 5807.533] Initializing built-in extension SYNC
[ 5807.533] Initializing built-in extension XKEYBOARD
[ 5807.533] Initializing built-in extension XC-MISC
[ 5807.533] Initializing built-in extension XINERAMA
[ 5807.533] Initializing built-in extension XFIXES
[ 5807.533] Initializing built-in extension RENDER
[ 5807.533] Initializing built-in extension RANDR
[ 5807.533] Initializing built-in extension COMPOSITE
[ 5807.533] Initializing built-in extension DAMAGE
[ 5807.533] Initializing built-in extension MIT-SCREEN-SAVER
[ 5807.533] Initializing built-in extension DOUBLE-BUFFER
[ 5807.533] Initializing built-in extension RECORD
[ 5807.533] Initializing built-in extension DPMS
[ 5807.533] Initializing built-in extension X-Resource
[ 5807.533] Initializing built-in extension XVideo
[ 5807.533] Initializing built-in extension XVideo-MotionCompensation
[ 5807.533] Initializing built-in extension XFree86-VidModeExtension
[ 5807.533] Initializing built-in extension XFree86-DGA
[ 5807.533] Initializing built-in extension XFree86-DRI
[ 5807.533] Initializing built-in extension DRI2
[ 5807.533] (II) LoadModule: "glx"
[ 5807.533] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 5807.540] (II) Module glx: vendor="NVIDIA Corporation"
[ 5807.540] compiled for 4.0.2, module version = 1.0.0
[ 5807.540] Module class: X.Org Server Extension
[ 5807.540] (II) NVIDIA GLX Module 325.08 Wed Jun 26 17:51:26 PDT 2013
[ 5807.540] Loading extension GLX
[ 5807.540] (II) LoadModule: "nvidia"
[ 5807.540] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 5807.541] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 5807.541] compiled for 4.0.2, module version = 1.0.0
[ 5807.541] Module class: X.Org Video Driver
[ 5807.541] (II) NVIDIA dlloader X Driver 325.08 Wed Jun 26 17:32:32 PDT 2013
[ 5807.541] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 5807.541] (++) using VT number 8

[ 5807.582] (II) Loading sub module "fb"
[ 5807.582] (II) LoadModule: "fb"
[ 5807.582] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 5807.582] (II) Module fb: vendor="X.Org Foundation"
[ 5807.582] compiled for 1.13.4, module version = 1.0.0
[ 5807.582] ABI class: X.Org ANSI C Emulation, version 0.4
[ 5807.582] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 5807.582] (II) Loading sub module "wfb"
[ 5807.582] (II) LoadModule: "wfb"
[ 5807.582] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 5807.583] (II) Module wfb: vendor="X.Org Foundation"
[ 5807.583] compiled for 1.13.4, module version = 1.0.0
[ 5807.583] ABI class: X.Org ANSI C Emulation, version 0.4
[ 5807.583] (II) Loading sub module "shadow"
[ 5807.583] (II) LoadModule: "shadow"
[ 5807.583] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 5807.583] (II) Module shadow: vendor="X.Org Foundation"
[ 5807.583] compiled for 1.13.4, module version = 1.1.0
[ 5807.583] ABI class: X.Org ANSI C Emulation, version 0.4
[ 5807.583] (II) Loading sub module "ramdac"
[ 5807.583] (II) LoadModule: "ramdac"
[ 5807.583] (II) Module "ramdac" already built-in
[ 5807.583] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[ 5807.583] (WW) NVIDIA: is an unsupported configuration. The driver will continue
[ 5807.583] (WW) NVIDIA: to load, but may behave strangely.
[ 5807.583] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[ 5807.583] (WW) NVIDIA: X server.
[ 5807.583] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 5807.583] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 5807.583] (==) NVIDIA(0): RGB weight 888
[ 5807.583] (==) NVIDIA(0): Default visual is TrueColor
[ 5807.583] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 5807.583] (**) NVIDIA(0): Option "MetaModes" "DFP-0: 1920x1080 +0+0"
[ 5807.583] (**) NVIDIA(1): Option "MetaModes" "DFP-2: 1920x1080 +0+0"
[ 5807.583] (**) NVIDIA(0): Enabling 2D acceleration
[ 5808.089] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-0)) does not support NVIDIA
[ 5808.089] (II) NVIDIA(GPU-0): 3D Vision stereo.
[ 5808.148] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-2)) does not support NVIDIA
[ 5808.148] (II) NVIDIA(GPU-0): 3D Vision stereo.
[ 5808.149] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 465 (GF100) at PCI:2:0:0 (GPU-0)
[ 5808.149] (--) NVIDIA(0): Memory: 1048576 kBytes
[ 5808.149] (--) NVIDIA(0): VideoBIOS: 70.00.35.00.60
[ 5808.149] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 5808.150] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 465 at PCI:2:0:0
[ 5808.150] (--) NVIDIA(0): CRT-0
[ 5808.150] (--) NVIDIA(0): CRT-1
[ 5808.150] (--) NVIDIA(0): Samsung SyncMaster (DFP-0) (boot, connected)
[ 5808.150] (--) NVIDIA(0): DFP-1
[ 5808.150] (--) NVIDIA(0): Samsung SyncMaster (DFP-2) (connected)
[ 5808.150] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[ 5808.150] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[ 5808.150] (--) NVIDIA(0): Samsung SyncMaster (DFP-0): 330.0 MHz maximum pixel clock
[ 5808.150] (--) NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Dual Link TMDS
[ 5808.150] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[ 5808.150] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[ 5808.150] (--) NVIDIA(0): Samsung SyncMaster (DFP-2): 330.0 MHz maximum pixel clock
[ 5808.150] (--) NVIDIA(0): Samsung SyncMaster (DFP-2): Internal Dual Link TMDS
[ 5808.150] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 5808.150] (**) NVIDIA(0): device Samsung SyncMaster (DFP-0) (Using EDID frequencies
[ 5808.150] (**) NVIDIA(0): has been enabled on all display devices.)
[ 5808.151] (II) NVIDIA(0): Validated MetaModes:
[ 5808.151] (II) NVIDIA(0): "DFP-0:1920x1080+0+0"
[ 5808.151] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 5808.174] (--) NVIDIA(0): DPI set to (95, 94); computed from "UseEdidDpi" X config
[ 5808.174] (--) NVIDIA(0): option
[ 5808.174] (WW) NVIDIA(0): 32-bit ARGB GLX visuals are not currently supported with the
[ 5808.174] (WW) NVIDIA(0): Xinerama extension.
[ 5808.174] (WW) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
[ 5808.174] (**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
[ 5808.174] (==) NVIDIA(1): RGB weight 888
[ 5808.174] (==) NVIDIA(1): Default visual is TrueColor
[ 5808.174] (==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
[ 5808.174] (II) NVIDIA(1): NVIDIA GPU GeForce GTX 465 (GF100) at PCI:2:0:0 (GPU-0)
[ 5808.174] (--) NVIDIA(1): Memory: 1048576 kBytes
[ 5808.174] (--) NVIDIA(1): VideoBIOS: 70.00.35.00.60
[ 5808.174] (II) NVIDIA(1): Detected PCI Express Link width: 16X
[ 5808.176] (--) NVIDIA(1): Valid display device(s) on GeForce GTX 465 at PCI:2:0:0
[ 5808.176] (--) NVIDIA(1): CRT-0
[ 5808.176] (--) NVIDIA(1): CRT-1
[ 5808.176] (--) NVIDIA(1): Samsung SyncMaster (DFP-0) (boot, connected)
[ 5808.176] (--) NVIDIA(1): DFP-1
[ 5808.176] (--) NVIDIA(1): Samsung SyncMaster (DFP-2) (connected)
[ 5808.176] (--) NVIDIA(1): CRT-0: 400.0 MHz maximum pixel clock
[ 5808.176] (--) NVIDIA(1): CRT-1: 400.0 MHz maximum pixel clock
[ 5808.176] (--) NVIDIA(1): Samsung SyncMaster (DFP-0): 330.0 MHz maximum pixel clock
[ 5808.176] (--) NVIDIA(1): Samsung SyncMaster (DFP-0): Internal Dual Link TMDS
[ 5808.176] (--) NVIDIA(1): DFP-1: 165.0 MHz maximum pixel clock
[ 5808.176] (--) NVIDIA(1): DFP-1: Internal Single Link TMDS
[ 5808.176] (--) NVIDIA(1): Samsung SyncMaster (DFP-2): 330.0 MHz maximum pixel clock
[ 5808.176] (--) NVIDIA(1): Samsung SyncMaster (DFP-2): Internal Dual Link TMDS
[ 5808.176] (**) NVIDIA(1): Using HorizSync/VertRefresh ranges from the EDID for display
[ 5808.176] (**) NVIDIA(1): device Samsung SyncMaster (DFP-2) (Using EDID frequencies
[ 5808.176] (**) NVIDIA(1): has been enabled on all display devices.)
[ 5808.176] (WW) NVIDIA(GPU-0): The EDID for Samsung SyncMaster (DFP-2) contradicts itself:
[ 5808.176] (WW) NVIDIA(GPU-0): mode "1920x1080" is specified in the EDID; however, the
[ 5808.176] (WW) NVIDIA(GPU-0): EDID's valid VertRefresh range (56.000-61.000 Hz) would
[ 5808.176] (WW) NVIDIA(GPU-0): exclude this mode's VertRefresh (50.0 Hz); ignoring
[ 5808.176] (WW) NVIDIA(GPU-0): VertRefresh check for mode "1920x1080".
[ 5808.176] (WW) NVIDIA(GPU-0): The EDID for Samsung SyncMaster (DFP-2) contradicts itself:
[ 5808.176] (WW) NVIDIA(GPU-0): mode "1280x720" is specified in the EDID; however, the
[ 5808.176] (WW) NVIDIA(GPU-0): EDID's valid VertRefresh range (56.000-61.000 Hz) would
[ 5808.176] (WW) NVIDIA(GPU-0): exclude this mode's VertRefresh (50.0 Hz); ignoring
[ 5808.176] (WW) NVIDIA(GPU-0): VertRefresh check for mode "1280x720".
[ 5808.176] (WW) NVIDIA(GPU-0): The EDID for Samsung SyncMaster (DFP-2) contradicts itself:
[ 5808.176] (WW) NVIDIA(GPU-0): mode "720x576" is specified in the EDID; however, the
[ 5808.176] (WW) NVIDIA(GPU-0): EDID's valid VertRefresh range (56.000-61.000 Hz) would
[ 5808.176] (WW) NVIDIA(GPU-0): exclude this mode's VertRefresh (50.0 Hz); ignoring
[ 5808.176] (WW) NVIDIA(GPU-0): VertRefresh check for mode "720x576".
[ 5808.177] (II) NVIDIA(1): Validated MetaModes:
[ 5808.177] (II) NVIDIA(1): "DFP-2:1920x1080+0+0"
[ 5808.177] (II) NVIDIA(1): Virtual screen size determined to be 1920 x 1080
[ 5808.179] (--) NVIDIA(1): DPI set to (95, 94); computed from "UseEdidDpi" X config
[ 5808.179] (--) NVIDIA(1): option
[ 5808.179] (WW) NVIDIA(1): 32-bit ARGB GLX visuals are not currently supported with the
[ 5808.179] (WW) NVIDIA(1): Xinerama extension.
[ 5808.179] (WW) NVIDIA(1): Disabling 32-bit ARGB GLX visuals.
[ 5808.179] (**) NVIDIA(2): Depth 24, (--) framebuffer bpp 32
[ 5808.179] (==) NVIDIA(2): RGB weight 888
[ 5808.179] (==) NVIDIA(2): Default visual is TrueColor
[ 5808.179] (==) NVIDIA(2): Using gamma correction (1.0, 1.0, 1.0)
[ 5808.179] (**) NVIDIA(2): Option "MetaModes" "1280x1024 +0+0"
[ 5808.179] (**) NVIDIA(2): Enabling 2D acceleration
[ 5808.484] (II) NVIDIA(GPU-1): Display (Samsung SyncMaster (CRT-1)) does not support NVIDIA
[ 5808.484] (II) NVIDIA(GPU-1): 3D Vision stereo.
[ 5808.484] (II) NVIDIA(2): NVIDIA GPU GeForce 8400GS (GT218) at PCI:4:0:0 (GPU-1)
[ 5808.484] (--) NVIDIA(2): Memory: 524288 kBytes
[ 5808.484] (--) NVIDIA(2): VideoBIOS: 70.18.5f.00.00
[ 5808.484] (II) NVIDIA(2): Detected PCI Express Link width: 16X
[ 5808.492] (--) NVIDIA(2): Valid display device(s) on GeForce 8400GS at PCI:4:0:0
[ 5808.492] (--) NVIDIA(2): CRT-0
[ 5808.492] (--) NVIDIA(2): Samsung SyncMaster (CRT-1) (boot, connected)
[ 5808.492] (--) NVIDIA(2): DFP-0
[ 5808.492] (--) NVIDIA(2): DFP-1
[ 5808.492] (--) NVIDIA(2): CRT-0: 400.0 MHz maximum pixel clock
[ 5808.492] (--) NVIDIA(2): Samsung SyncMaster (CRT-1): 400.0 MHz maximum pixel clock
[ 5808.492] (--) NVIDIA(2): DFP-0: 330.0 MHz maximum pixel clock
[ 5808.492] (--) NVIDIA(2): DFP-0: Internal Single Link TMDS
[ 5808.492] (--) NVIDIA(2): DFP-1: 165.0 MHz maximum pixel clock
[ 5808.492] (--) NVIDIA(2): DFP-1: Internal Single Link TMDS
[ 5808.492] (**) NVIDIA(2): Using HorizSync/VertRefresh ranges from the EDID for display
[ 5808.492] (**) NVIDIA(2): device Samsung SyncMaster (CRT-1) (Using EDID frequencies
[ 5808.492] (**) NVIDIA(2): has been enabled on all display devices.)
[ 5808.496] (II) NVIDIA(2): Validated MetaModes:
[ 5808.496] (II) NVIDIA(2): "1280x1024+0+0"
[ 5808.496] (II) NVIDIA(2): Virtual screen size determined to be 1280 x 1024
[ 5808.505] (--) NVIDIA(2): DPI set to (95, 96); computed from "UseEdidDpi" X config
[ 5808.505] (--) NVIDIA(2): option
[ 5808.505] (WW) NVIDIA(2): 32-bit ARGB GLX visuals are not currently supported with the
[ 5808.505] (WW) NVIDIA(2): Xinerama extension.
[ 5808.505] (WW) NVIDIA(2): Disabling 32-bit ARGB GLX visuals.
[ 5808.505] (--) Depth 24 pixmap format is 32 bpp
[ 5808.505] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 5808.505] (II) NVIDIA: access.
[ 5808.513] (II) NVIDIA(0): Setting mode "DFP-0:1920x1080+0+0"
[ 5808.549] Loading extension NV-GLX
[ 5808.601] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 5808.601] (==) NVIDIA(0): Backing store disabled
[ 5808.602] (==) NVIDIA(0): Silken mouse enabled
[ 5808.602] (==) NVIDIA(0): DPMS enabled
[ 5808.602] Loading extension NV-CONTROL
[ 5808.602] (WW) NVIDIA(0): Option "TwinView" is not used
[ 5808.602] (II) Loading sub module "dri2"
[ 5808.602] (II) LoadModule: "dri2"
[ 5808.602] (II) Module "dri2" already built-in
[ 5808.602] (II) NVIDIA(0): [DRI2] Setup complete
[ 5808.602] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 5808.602] (WW) NVIDIA(0): Not registering RandR
[ 5808.602] (==) RandR enabled
[ 5808.607] (II) NVIDIA(1): Setting mode "DFP-2:1920x1080+0+0"
[ 5808.733] (==) NVIDIA(1): Disabling shared memory pixmaps
[ 5808.733] (==) NVIDIA(1): Backing store disabled
[ 5808.733] (==) NVIDIA(1): Silken mouse enabled
[ 5808.734] (==) NVIDIA(1): DPMS enabled
[ 5808.734] (WW) NVIDIA(1): Option "TwinView" is not used
[ 5808.734] (II) Loading sub module "dri2"
[ 5808.734] (II) LoadModule: "dri2"
[ 5808.734] (II) Module "dri2" already built-in
[ 5808.734] (II) NVIDIA(1): [DRI2] Setup complete
[ 5808.734] (II) NVIDIA(1): [DRI2] VDPAU driver: nvidia
[ 5808.734] (WW) NVIDIA(1): Not registering RandR
[ 5808.734] (==) RandR enabled
[ 5808.749] (II) NVIDIA(2): Setting mode "1280x1024+0+0"
[ 5808.787] (WW) NVIDIA(2): The GPU driving screen 2 is incompatible with the rest of the
[ 5808.787] (WW) NVIDIA(2): GPUs composing the desktop. OpenGL rendering will be
[ 5808.787] (WW) NVIDIA(2): disabled on screen 2.
[ 5808.800] (==) NVIDIA(2): Disabling shared memory pixmaps
[ 5808.801] (==) NVIDIA(2): Backing store disabled
[ 5808.801] (==) NVIDIA(2): Silken mouse enabled
[ 5808.801] (==) NVIDIA(2): DPMS enabled
[ 5808.801] (WW) NVIDIA(2): Option "TwinView" is not used
[ 5808.801] (II) Loading sub module "dri2"
[ 5808.801] (II) LoadModule: "dri2"
[ 5808.801] (II) Module "dri2" already built-in
[ 5808.801] (II) NVIDIA(2): [DRI2] Setup complete
[ 5808.801] (II) NVIDIA(2): [DRI2] VDPAU driver: nvidia
[ 5808.801] (WW) NVIDIA(2): Not registering RandR
[ 5808.801] (==) RandR enabled
[ 5808.804] (II) Initializing extension GLX
[ 5808.855] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 5808.855] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 5808.855] (II) LoadModule: "evdev"
[ 5808.855] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 5808.855] (II) Module evdev: vendor="X.Org Foundation"
[ 5808.855] compiled for 1.13.4, module version = 2.7.3
[ 5808.855] Module class: X.Org XInput Driver
[ 5808.855] ABI class: X.Org XInput driver, version 18.0
[ 5808.855] (II) Using input driver 'evdev' for 'Power Button'
[ 5808.855] (**) Power Button: always reports core events
[ 5808.855] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 5808.856] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 5808.856] (--) evdev: Power Button: Found keys
[ 5808.856] (II) evdev: Power Button: Configuring as keyboard
[ 5808.856] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[ 5808.856] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 5808.856] (**) Option "xkb_rules" "evdev"
[ 5808.856] (**) Option "xkb_model" "evdev"
[ 5808.856] (**) Option "xkb_layout" "us"
[ 5808.870] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 5808.870] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 5808.870] (II) Using input driver 'evdev' for 'Power Button'
[ 5808.870] (**) Power Button: always reports core events
[ 5808.870] (**) evdev: Power Button: Device: "/dev/input/event0"
[ 5808.870] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 5808.870] (--) evdev: Power Button: Found keys
[ 5808.870] (II) evdev: Power Button: Configuring as keyboard
[ 5808.870] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[ 5808.870] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 5808.870] (**) Option "xkb_rules" "evdev"
[ 5808.870] (**) Option "xkb_model" "evdev"
[ 5808.870] (**) Option "xkb_layout" "us"
[ 5808.870] (II) config/udev: Adding input device Microsoft Microsoft 5-Button Mouse with IntelliEye(TM) (/dev/input/event3)
[ 5808.870] (**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Applying InputClass "evdev pointer catchall"
[ 5808.870] (II) Using input driver 'evdev' for 'Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)'
[ 5808.870] (**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): always reports core events
[ 5808.870] (**) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Device: "/dev/input/event3"
[ 5808.870] (--) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Vendor 0x45e Product 0x39
[ 5808.870] (--) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Found 9 mouse buttons
[ 5808.870] (--) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Found scroll wheel(s)
[ 5808.870] (--) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Found relative axes
[ 5808.870] (--) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Found x and y relative axes
[ 5808.870] (II) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Configuring as mouse
[ 5808.870] (II) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Adding scrollwheel support
[ 5808.870] (**) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): YAxisMapping: buttons 4 and 5
[ 5808.870] (**) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 5808.870] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-2/5-2:1.0/input/input3/event3"
[ 5808.870] (II) XINPUT: Adding extended input device "Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)" (type: MOUSE, id 8)
[ 5808.870] (II) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): initialized for relative axes.
[ 5808.870] (**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): (accel) keeping acceleration scheme 1
[ 5808.870] (**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): (accel) acceleration profile 0
[ 5808.870] (**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): (accel) acceleration factor: 2.000
[ 5808.870] (**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): (accel) acceleration threshold: 4
[ 5808.870] (II) config/udev: Adding input device Microsoft Microsoft 5-Button Mouse with IntelliEye(TM) (/dev/input/mouse0)
[ 5808.870] (II) No input driver specified, ignoring this device.
[ 5808.870] (II) This device may have been added with another device file.
[ 5808.871] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[ 5808.871] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 5808.871] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 5808.871] (**) AT Translated Set 2 keyboard: always reports core events
[ 5808.871] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[ 5808.871] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 5808.871] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 5808.871] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 5808.871] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input2/event2"
[ 5808.871] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[ 5808.871] (**) Option "xkb_rules" "evdev"
[ 5808.871] (**) Option "xkb_model" "evdev"
[ 5808.871] (**) Option "xkb_layout" "us"
[ 5808.871] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event4)
[ 5808.871] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[ 5808.871] (II) Using input driver 'evdev' for 'PS/2 Generic Mouse'
[ 5808.871] (**) PS/2 Generic Mouse: always reports core events
[ 5808.871] (**) evdev: PS/2 Generic Mouse: Device: "/dev/input/event4"
[ 5808.871] (--) evdev: PS/2 Generic Mouse: Vendor 0x2 Product 0x1
[ 5808.871] (--) evdev: PS/2 Generic Mouse: Found 3 mouse buttons
[ 5808.871] (--) evdev: PS/2 Generic Mouse: Found relative axes
[ 5808.871] (--) evdev: PS/2 Generic Mouse: Found x and y relative axes
[ 5808.871] (II) evdev: PS/2 Generic Mouse: Configuring as mouse
[ 5808.871] (**) evdev: PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[ 5808.871] (**) evdev: PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 5808.871] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input4/event4"
[ 5808.871] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE, id 10)
[ 5808.871] (II) evdev: PS/2 Generic Mouse: initialized for relative axes.
[ 5808.871] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[ 5808.871] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[ 5808.871] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[ 5808.871] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[ 5808.871] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse1)
[ 5808.871] (II) No input driver specified, ignoring this device.
[ 5808.871] (II) This device may have been added with another device file.
[ 5809.038] (II) evdev: PS/2 Generic Mouse: Close
[ 5809.038] (II) UnloadModule: "evdev"
[ 5809.038] (II) evdev: AT Translated Set 2 keyboard: Close
[ 5809.038] (II) UnloadModule: "evdev"
[ 5809.038] (II) evdev: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Close
[ 5809.038] (II) UnloadModule: "evdev"
[ 5809.038] (II) evdev: Power Button: Close
[ 5809.038] (II) UnloadModule: "evdev"
[ 5809.038] (II) evdev: Power Button: Close
[ 5809.038] (II) UnloadModule: "evdev"
[ 5809.451] (II) NVIDIA(GPU-1): Deleting GPU-1
[ 5809.451] (II) NVIDIA(GPU-0): Deleting GPU-0
[ 5809.492] Server terminated successfully (0). Closing log file.
c2RAID6 ~ #


Doing just a simple visual scan there are some differences early on:

Working:
Quote:

[ 32.619] (II) NVIDIA dlloader X Driver 313.30 Wed Mar 27 15:33:21 PDT 2013
[ 32.619] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 32.619] (++) using VT number 7

[ 32.660] (II) Loading sub module "wfb"
[ 32.660] (II) LoadModule: "wfb"
[ 32.660] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 32.685] (II) Module wfb: vendor="X.Org Foundation"
[ 32.685] compiled for 1.13.4, module version = 1.0.0
[ 32.685] ABI class: X.Org ANSI C Emulation, version 0.4
[ 32.685] (II) Loading sub module "ramdac"
[ 32.685] (II) LoadModule: "ramdac"
[ 32.685] (II) Module "ramdac" already built-in
[ 32.685] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[ 32.685] (WW) NVIDIA: is an unsupported configuration. The driver will continue
[ 32.685] (WW) NVIDIA: to load, but may behave strangely.
[ 32.685] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[ 32.685] (WW) NVIDIA: X server.
[ 32.685] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support


Failing - the message "Unresolved symbol: fbGetGCPrivateKey" is troubling...

Quote:

[ 5807.541] (II) NVIDIA dlloader X Driver 325.08 Wed Jun 26 17:32:32 PDT 2013
[ 5807.541] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 5807.541] (++) using VT number 8

[ 5807.582] (II) Loading sub module "fb"
[ 5807.582] (II) LoadModule: "fb"
[ 5807.582] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 5807.582] (II) Module fb: vendor="X.Org Foundation"
[ 5807.582] compiled for 1.13.4, module version = 1.0.0
[ 5807.582] ABI class: X.Org ANSI C Emulation, version 0.4
[ 5807.582] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 5807.582] (II) Loading sub module "wfb"
[ 5807.582] (II) LoadModule: "wfb"
[ 5807.582] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 5807.583] (II) Module wfb: vendor="X.Org Foundation"
[ 5807.583] compiled for 1.13.4, module version = 1.0.0
[ 5807.583] ABI class: X.Org ANSI C Emulation, version 0.4
[ 5807.583] (II) Loading sub module "shadow"
[ 5807.583] (II) LoadModule: "shadow"
[ 5807.583] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 5807.583] (II) Module shadow: vendor="X.Org Foundation"
[ 5807.583] compiled for 1.13.4, module version = 1.1.0
[ 5807.583] ABI class: X.Org ANSI C Emulation, version 0.4
[ 5807.583] (II) Loading sub module "ramdac"
[ 5807.583] (II) LoadModule: "ramdac"
[ 5807.583] (II) Module "ramdac" already built-in
[ 5807.583] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[ 5807.583] (WW) NVIDIA: is an unsupported configuration. The driver will continue
[ 5807.583] (WW) NVIDIA: to load, but may behave strangely.
[ 5807.583] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[ 5807.583] (WW) NVIDIA: X server.
[ 5807.583] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Aug 04, 2013 5:29 pm    Post subject: Reply with quote

Composite can be disabled in xorg.conf:

Code:
Section "Extensions"
    Option      "Composite"     "False"
EndSection


Or can be compiled out from xorg-server, with the ./configure option:
Code:
--disable-composite
Back to top
View user's profile Send private message
Mark Knecht
n00b
n00b


Joined: 16 Sep 2003
Posts: 63

PostPosted: Sun Aug 04, 2013 6:57 pm    Post subject: Reply with quote

PaulBredbury wrote:
Composite can be disabled in xorg.conf:

Code:
Section "Extensions"
    Option      "Composite"     "False"
EndSection


Or can be compiled out from xorg-server, with the ./configure option:
Code:
--disable-composite


Thanks for that. I used the Section "Extensions" version and indeed the warning is now gone.

Unfortunately that change didn't solve the larger issue of X not working with the newest stable or ~amd64 versions of nvidia-drivers, and somewhat disappointingly the machine is apparently developing a new issue. It now takes about 2 minutes from the time I enter my password until the KDE desktop comes up. The machine just sits with the KDM login graphics on the screen and nothing else until finally about 2 minutes later the KDE shows it is starting and finally the desktop comes up.

As some of the messages looked to be possibly framebuffer related I tried booting without the grub framebuffer options but that didn't fix anything.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Sun Aug 04, 2013 7:28 pm    Post subject: Reply with quote

There is currently no working nvidia-driver for kernels above 3.10

Solution: stick with 3.9.xx till nvidia can cope with kernel development speed :roll:

Rüdiger
Back to top
View user's profile Send private message
Mark Knecht
n00b
n00b


Joined: 16 Sep 2003
Posts: 63

PostPosted: Sun Aug 04, 2013 8:13 pm    Post subject: Reply with quote

Wallsandfences wrote:
There is currently no working nvidia-driver for kernels above 3.10

Solution: stick with 3.9.xx till nvidia can cope with kernel development speed :roll:

Rüdiger


I'm running 3.8.13 so I wouldn't think that's the problem, although maybe the newer nvidia drivers only work with 3.9 or something?

mark@c2RAID6 ~ $ uname -a
Linux c2RAID6 3.8.13-gentoo #5 SMP PREEMPT Fri Jul 19 10:28:53 PDT 2013 x86_64 Intel(R) Core(TM) i7 CPU X 980 @ 3.33GHz GenuineIntel GNU/Linux
mark@c2RAID6 ~ $
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1225
Location: 42.68n 85.41w

PostPosted: Sun Aug 04, 2013 9:47 pm    Post subject: Reply with quote

solution, boycott, and get everyone you know to boycott them too. 9600 gt you are my last nvidia card, unless they open their sources.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
http://ecx.images-amazon.com/images/I/81Ku-vxIb3L._SL1500_.jpg
http://wiki.gentoo.org/wiki/Special:Contributions/666threesixes666
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Sun Aug 04, 2013 10:40 pm    Post subject: Reply with quote

I have it not at hand, but the driver versions are known to work only within a specific kernel version number range. It should spill out a message during emerge, if it finds an unsupported kernel in /usr/src/linux, though.

Rüdiger
Back to top
View user's profile Send private message
Mark Knecht
n00b
n00b


Joined: 16 Sep 2003
Posts: 63

PostPosted: Wed Aug 07, 2013 10:37 pm    Post subject: Reply with quote

Wallsandfences wrote:
I have it not at hand, but the driver versions are known to work only within a specific kernel version number range. It should spill out a message during emerge, if it finds an unsupported kernel in /usr/src/linux, though.

Rüdiger


I wondered about that but it appears to me that NVidia at least intends to support what's on my system. I typically look at this page:

http://www.geforce.com/drivers

and then do a search for the version I'm considering for emerge vs my card (GTX 465). Currently the two revisions that don't work for me (319.32 & 325.08) have these comments in the release notes:

For 319.32:
Nothing I can see

For 325.08:
Removed support for Linux 2.4 kernels. The NVIDIA Linux driver now requires Linux 2.6.9 or later.

So that at least seems reasonably forgiving.

I guess at this point I'm at a loss as to where to go. Looking in the Gentoo Bugzilla there aren't very many nvidia reports. Maybe I'll find some help in the NVidia forums somewhere.

Anyway, that's for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum