Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Backlight control not working in X/KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
XmainframeX
n00b
n00b


Joined: 27 Dec 2004
Posts: 33

PostPosted: Tue Aug 06, 2013 8:28 am    Post subject: [SOLVED] Backlight control not working in X/KDE Reply with quote

Hi,

since a recent BIOS update I have problems with my display backlight in KDE.
I'm using an ASUS N56VZ laptop with an onchip Intel GPU plus a NVIDIA GeForce 650M via Bumblebee.

The problem seems to be that X picks the wrong backlight folder from /sys/class/backlight/. The folder looks like this:
Code:
acpi_video0  acpi_video1  intel_backlight

When I echo numbers to intel_backlight/brightness, the brightness changes. The same thing does however not work in the acpi_video* folders. The Xorg.0.log says
Code:
[     9.468] (--) intel(0): found backlight control interface /sys/class/backlight/acpi_video1

, so I assume that X / the intel driver picks the wrong backlight.

Some things I tampered with:

  • Getting rid of the /sys/class/backlight/acpi_video* folders by the acpi_backlight=vendor kernel parameter.
    This replaced the acpi_video* folders with asus specific folders which do not work as well but are also picked in favour of the working intel_backlight folder by X.
  • Trying to disable the acpi_video* folders with the acpi.brightness_switch_enabled=0 kernel parameter:
    This has no effect on the folders and seems to be intended for something else.
  • Disabling the video.ko module which provides the acpi_video* folders:
    This is not an option since it would disable features like retrieving EDID information
  • Telling X to use another backlight: The only way to do this seems to be to add
    Code:
    Option "Backlight" "intel_backlight"

    to the intel driver section in xorg.conf. Unfortunately, I only have InputClass sections in my xorg.conf. Displays are nicely autoconfigured and working with bumblebee. I didn't manage to adapt the xorg.conf code snippets I found on the web which address this problem to my configuration. It seems like I would have to specify device, screen, monitor and server layout which introduces a lot of redundancy given that the automatic configuration works quite well currently.


Does anybody have other suggestions about what to try next? I'd prefer getting rid of the acpi_video* folders or forcing X/intel driver to use another backlight in an easy way.


Last edited by XmainframeX on Thu Aug 08, 2013 8:22 am; edited 1 time in total
Back to top
View user's profile Send private message
XmainframeX
n00b
n00b


Joined: 27 Dec 2004
Posts: 33

PostPosted: Thu Aug 08, 2013 8:22 am    Post subject: Solved... Reply with quote

Finally figured it out by myself.

What I did:

  • Create a directory /etc/X11/xorg.conf.d
  • Move my /etc/X11/xorg.conf which contains only input specific stuff to /etc/X11/xorg.conf.d/00-input.conf
  • Create a file /etc/X11/xorg.conf.d/20-intel.conf with the following content:
    Code:
    Section "Device"
            Identifier      "HD 4000"
            Driver  "Intel"
            Option "Backlight" "intel_backlight"
    EndSection


Now the only remaining problem is that the backlight brightness during login is zero and kdm cannot change it, so I have to type my password blindly. However, I can live with that.
As mentioned, I also tried putting the content of the 20-intel.conf file to my original xorg.conf file which did not work - but I'm not certain if this was caused by some other stupid thing I did :-) One might want to give that a try as well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum