Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dvd help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
gjbnh
n00b
n00b


Joined: 28 Jun 2002
Posts: 5

PostPosted: Thu Jul 11, 2002 1:41 pm    Post subject: Dvd help Reply with quote

After several days of trying to get my dvd working, I'm still tuck. I've emerged all the xine files, gentoo "sees" my dvd, but all I get when I try to play one is this:
"there is no imput plugin availbe to handle 'dvd//VTS_01_.1.VOB
Maybe MRL syntax is wrong or file/stream source does not exist"

Could some one point me in the right direction?

And yes I've searched the forums and tried to implement everything I've read...sigh

I think we need a tutorial on this too!
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Thu Jul 11, 2002 2:09 pm    Post subject: Reply with quote

With Xine (if I recall correctly) you should not mount the DVD-ROM, xine will access it from /dev/dvd and then it has raw access. You might give that a go. Also you might look into other DVD tools/players such as Ogle. Info on Ogle can be found here
------>http://www.dtek.chalmers.se/groups/dvd/

And YES there is an ebuild for ogle which works quite well. Also are you sure you compiled UDF support into your kernel in the File Systems area (well on second thought if you have successfully mounted a DVD-ROM then I would guess you have UDF support--Nevermind on that front)

Give that a go and let us know how things look!

Regards,
BonezTheGoon
_________________
mcgruff wrote:
I can't promise to be civil.


pjp wrote:
The greater evil is voting for the "lesser evil."
Back to top
View user's profile Send private message
cesman
n00b
n00b


Joined: 29 Jun 2002
Posts: 24

PostPosted: Thu Jul 11, 2002 2:36 pm    Post subject: encrypted? Reply with quote

Sounds like you are trying to view an encrypted DVD. You'll need to use a plugin to Xine that enable the viewing of encrypted DVDs. emerge --pretend dvd-nav, I think I got that right. Sorry, I'm not at my Gentto box at the moment :(

cesman
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Tue Jul 16, 2002 5:29 pm    Post subject: Whats up?? Reply with quote

gjbnh did you ever get your DVD's working as desired?? Please post your results and what you did so that others may benefit from your work!!

Regards,
BonezTheGoon
_________________
mcgruff wrote:
I can't promise to be civil.


pjp wrote:
The greater evil is voting for the "lesser evil."
Back to top
View user's profile Send private message
gjbnh
n00b
n00b


Joined: 28 Jun 2002
Posts: 5

PostPosted: Wed Jul 17, 2002 3:41 am    Post subject: sigh... Reply with quote

No I've not gotten it going yet, I've been tied up wiht a few other projcets, and there really wasn't a good respsone for me to try so far. Thanks for asking tho.

Like I said, someone need to to a tutorial on the process for newbies.
Back to top
View user's profile Send private message
nsadhal
n00b
n00b


Joined: 12 Jul 2002
Posts: 34
Location: Berkeley, CA

PostPosted: Thu Jul 18, 2002 5:45 am    Post subject: Reply with quote

well, i got xine to play dvds after emerging every package that started w/ xine.... xine-d4d, d5d, dvd-nav, etc etc...
look at the packages list... i didn't really bother to see which ones i might or might not need tho...
xine played dvds, but the sound was skippy.
i use ogle now... it plays em too, but the video skips...
it's more watchable this way though.
this is on my athlon 1800, btw...

anyway, i can't stand xine's interface... the skin that it comes with anyway... to me it's one of the biggest interface design failures ever... it forces a real world metaphor onto the screen... so you have silly things like a jog dial... which requires unnatural movement just to change the volume...
_________________
It makes me so mad I wanna grab my sawed off, and get some bodies hauled.
Back to top
View user's profile Send private message
Huw in Nice
n00b
n00b


Joined: 06 Jun 2002
Posts: 7
Location: Nice France

PostPosted: Thu Jul 18, 2002 7:21 am    Post subject: Reply with quote

Try hdparm -d1 /dev/dvd to ensure DMA is enabled
Back to top
View user's profile Send private message
craftyc
Guru
Guru


Joined: 23 May 2002
Posts: 443
Location: Behind You.

PostPosted: Thu Jul 18, 2002 11:05 am    Post subject: Reply with quote

Huw in Nice wrote:
Try hdparm -d1 /dev/dvd to ensure DMA is enabled


Yes this will definately cure the problem.
_________________
Postcount ++
Back to top
View user's profile Send private message
cphax
n00b
n00b


Joined: 13 Jul 2002
Posts: 7

PostPosted: Thu Jul 18, 2002 11:11 am    Post subject: xine skins Reply with quote

Quote:
anyway, i can't stand xine's interface... the skin that it comes with anyway... to me it's one of the biggest interface design failures ever... it forces a real world metaphor onto the screen... so you have silly things like a jog dial... which requires unnatural movement just to change the volume...


check out the Xine skins page for a bit more usable skins. I personally use the xinetic-skin, 'cause that comes with the freshrpm's build of xine, so i'm used to it.

I agree with you though, xine's skins are horrible, and the one that is gentoo's default is the worst. What happened to simple and usable skins, ie. the default skin of noatun (kde's mediaplayer)?
Back to top
View user's profile Send private message
whansard
n00b
n00b


Joined: 19 Jul 2002
Posts: 4

PostPosted: Fri Jul 19, 2002 2:11 am    Post subject: dvd playing Reply with quote

i emerge rsync
recently
and i was able to get mplayer and xine to play dvd's after
adding dvd to my /etc/make.conf ( i think that was the name)
i started installing gentoo last thursday, and downloaded everything
on a 28.8 connection. 500 megs of downloads in a week. yuck.
xine needed the d4d-something plugin, and i had to emerge -C the old
stuff first. ogle worked right off the bat, and mplayer needed the
dvd added to the use section of /etc/make.conf, then rebuilt mplayer.
i just got xine working today. i got mplayer working last night.
for mplayer its like mplayer -dvd 1 to play the first title of a dvd.
Back to top
View user's profile Send private message
abombss
n00b
n00b


Joined: 20 Jun 2002
Posts: 12
Location: Chicago, IL

PostPosted: Thu Jul 25, 2002 6:13 am    Post subject: Reply with quote

I have been having trouble getting my DVD to work also, I think it is a video issue with my radeon. But anyway, I tested both /dev/cdroms/cdrom0 ( Cd-Rw ) and /dev/cdroms/cdrom1 ( Dvd ), and neither had DMA enabled.

How can I enable DMA?

My HD is using DMA???

peace...

abombss
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Thu Jul 25, 2002 1:07 pm    Post subject: Reply with quote

For information specific to DMA you should check this other (very extensive) thread that covers DMA specifically and gives many good tips and lots of good info.

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
abombss
n00b
n00b


Joined: 20 Jun 2002
Posts: 12
Location: Chicago, IL

PostPosted: Fri Jul 26, 2002 12:11 am    Post subject: Reply with quote

My fault, I accidentally had compiled an option into the kernel to disable DMA for my cdroms.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum