Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem Tracking VLC bug [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 4:45 am    Post subject: Problem Tracking VLC bug [Solved] Reply with quote

After my last update, vlc stopped working. I tried rolling back the vlc version as well as the updated packages. It still sigfaults on startup. I also removed a few KDE components, (kate, okular, ark, kdelibs) and their dependencies, however vlc wasn't built with USE=kde and didn't depend on any of the removed packages. I have vlc built like so:
Code:
[ebuild   R    ] media-video/vlc-2.0.7  USE="X a52 aac alsa avcodec avformat bidi cdda dbus debug* dts dvbpsi dvd encode ffmpeg flac gcrypt gnutls httpd libnotify live lua matroska mmx mp3 mpeg ncurses ogg opengl png postproc qt4 sdl sse svg swscale theora truetype v4l vaapi vlm vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bluray -cddb -dc1394 -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig -gme -gnome -growl -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libproxy -libsamplerate -libtar -libtiger -linsys -lirc (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pulseaudio -pvr -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -twolame -udev -upnp -vcdx (-waveout) (-wingdi) -wma-fixed -xosd -zvbi"
The error from the terminal is
Code:
VLC media player 2.0.7 Twoflower (revision 2.0.6-54-g7dd7e4d)
Segmentation fault
The only log entry I can find is in /var/log/messages and it reads
Code:
1191718 Aug  2 21:31:26 Apollo kernel: [38144.849807] vlc-cache-gen[7408]: segfault at 7f32bc96099a ip 00007f32c37605a6 sp 00007fff482a5b28 error 4 in libc-2.17.so[7f32c3635000+1a1000]
1191719 Aug  2 21:32:13 Apollo kernel: [38191.456351] vlc[7473]: segfault at 7f4a032a999a ip 00007f4a09c885a6 sp 00007fff687e4038 error 4 in libc-2.17.so[7f4a09b5d000+1a1000]


This looks like glibc is the culprit, but it doesn't look like it was updated in the past month.

I have tried rebuilding glibc, vlc, and I even tried emerge -e vlc. It still sigfaults. Can anyone tell me what I can do to trouble shoot, or better yet, get VLC working?


EIDT: Found workaround (USE="-svg") and filed bug report
_________________
First things first, but not necessarily in that order.


Last edited by The Doctor on Sat Aug 03, 2013 7:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sat Aug 03, 2013 4:52 am    Post subject: Reply with quote

mine works :D this is my setup

vanilla-sources 3.9.8

mkultra@mksrv [ ~ ]$ vlc --version
VLC media player 2.0.7 Twoflower (revision 2.0.6-54-g7dd7e4d)

USE="X a52 aac alsa avahi avcodec avformat cdda cddb dbus dts dvbpsi dvd encode ffmpeg flac fluidsynth fontconfig gcrypt gnome jack libsamplerate mmx mp3 mpeg musepack ncurses ogg opengl png postproc pulseaudio qt4 samba sdl shout sse svg swscale taglib truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -bluray -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -kate -kde -libass -libcaca -libnotify -libproxy -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pvr -rtsp -run-as-root -schroedinger -sdl-image -shine -sid -skins -speex -sqlite -switcher -theora -twolame -upnp -vaapi -vcdx -vlm -v4l (-waveout) (-wingdi) -wma-fixed -xosd -zvbi"


these are the use flags you have that i don't
Code:

theora matroska libnotify live lua httpd gnutls bidi debug*


if it still doesnt work, revdep-rebuild....
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 5:06 am    Post subject: Reply with quote

There don't appear to be any major differences other than I am using -gnome and -udev. Since my build is crashing on startup before it can even do simple things like --version or --help, I seriously doubt that support for different features and codecs is used in the code and therefore the source of the sigfault.

However, I don't think that use flags are going to change anything. VLC was working for months and then stopped. I can't even run vlc --version anymore. I suspect either a bug somewhere and I would like to be able to make a report that doesn't waste everyones time.

However, I did manage to get some more useful output. Maybe someone sees something?

Code:
user@Apollo ~ $ vlc -vvvv
VLC media player 2.0.7 Twoflower (revision 2.0.6-54-g7dd7e4d)
[0x22a3358] main libvlc debug: VLC media player - 2.0.7 Twoflower
[0x22a3358] main libvlc debug: Copyright �� 1996-2013 VLC authors and VideoLAN
[0x22a3358] main libvlc debug: revision 2.0.6-54-g7dd7e4d
[0x22a3358] main libvlc debug: configured with ./configure  '--prefix=/usr' '--build=x86_64-pc-linux-gnu' '--host=x86_64-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--libdir=/usr/lib64' '--disable-silent-rules' '--disable-dependency-tracking' '--docdir=/usr/share/doc/vlc-2.0.7' '--enable-a52' '--disable-aa' '--enable-faad' '--enable-alsa' '--disable-altivec' '--disable-atmo' '--disable-audioqueue' '--disable-bonjour' '--enable-avcodec' '--enable-avformat' '--enable-fribidi' '--disable-bluray' '--enable-vcd' '--disable-libcddb' '--enable-dbus' '--enable-dbus-control' '--disable-dirac' '--disable-direct2d' '--disable-directfb' '--disable-directx' '--disable-dc1394' '--enable-debug' '--disable-dshow' '--enable-dca' '--enable-dvbpsi' '--enable-dvdread' '--enable-dvdnav' '--disable-dxva2' '--disable-egl' '--enable-sout' '--disable-fbosd' '--enable-flac' '--disable-fluidsynth' '--disable-fontconfig' '--enable-libgcrypt' '--disable-gme' '--disable-gnomevfs' '--enable-gnutls' '--disable-growl' '--enable-httpd' '--disable-dv' '--disable-ios-vout' '--disable-jack' '--disable-kate' '--without-kde-solid' '--disable-libass' '--disable-caca' '--enable-notify' '--disable-libproxy' '--disable-samplerate' '--disable-libtar' '--disable-tiger' '--disable-linsys' '--disable-lirc' '--enable-live555' '--enable-lua' '--disable-macosx-audio' '--disable-macosx-dialog-provider' '--disable-macosx-eyetv' '--disable-macosx-qtkit' '--disable-macosx-quartztext' '--disable-macosx-vout' '--enable-mkv' '--disable-media-library' '--enable-mmx' '--disable-mod' '--enable-mad' '--enable-libmpeg2' '--disable-mtp' '--disable-mpc' '--enable-ncurses' '--disable-neon' '--enable-ogg' '--enable-mux_ogg' '--disable-omxil' '--enable-glx' '--disable-opus' '--disable-optimize-memory' '--disable-oss' '--enable-png' '--disable-portaudio' '--enable-postproc' '--disable-projectm' '--disable-pulse' '--disable-pvr' '--enable-qt4' '--disable-realrtsp' '--disable-run-as-root' '--disable-smb' '--disable-schroedinger' '--enable-sdl' '--disable-sdl-image' '--disable-shine' '--disable-sid' '--disable-shout' '--disable-skins2' '--disable-speex' '--disable-sqlite' '--enable-sse' '--enable-svg' '--disable-switcher' '--enable-swscale' '--disable-taglib' '--enable-theora' '--enable-freetype' '--disable-twolame' '--disable-udev' '--disable-upnp' '--enable-v4l2' '--enable-libva' '--disable-vcdx' '--enable-vlm' '--enable-vorbis' '--disable-waveout' '--disable-wingdi' '--disable-wma-fixed' '--with-x' '--enable-x264' '--enable-xcb' '--enable-libxml2' '--disable-xosd' '--enable-xvideo' '--disable-zvbi' '--enable-telx' '--disable-loader' '--disable-optimizations' '--without-tuning' '--enable-fast-install' 'build_alias=x86_64-pc-linux-gnu' 'host_alias=x86_64-pc-linux-gnu' 'CC=gcc' 'CFLAGS=-march=native  -O2 -pipe' 'LDFLAGS=-Wl,-O1 -Wl,--as-needed' 'CXX=g++' 'CXXFLAGS=-march=native  -O2 -pipe' 'PKG_CONFIG_PATH=/usr/lib64/pkgconfig'
[0x22a3358] main libvlc debug: searching plug-in modules
[0x22a3358] main libvlc debug: loading plugins cache file /usr/lib64/vlc/plugins/plugins.dat
[0x22a3358] main libvlc warning: cannot read /usr/lib64/vlc/plugins/plugins.dat (No such file or directory)
[0x22a3358] main libvlc debug: recursively browsing `/usr/lib64/vlc/plugins'
Segmentation fault

_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sat Aug 03, 2013 5:14 am    Post subject: Reply with quote

i have this file, you dont....
[0x22a3358] main libvlc warning: cannot read /usr/lib64/vlc/plugins/plugins.dat (No such file or directory)
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 5:23 am    Post subject: Reply with quote

Yes there does seem to be a problem there. My laptop with a practically identical setup has that directory and file. I thought it was a simple check for plugins and a warning that it didn't find any.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 5:28 am    Post subject: Reply with quote

It isn't the problem. I copied the file from my laptop and it still sigfaults.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sat Aug 03, 2013 5:43 am    Post subject: Reply with quote

try testing compiling out the uses i don't have

Code:

echo "media-video/vlc -theora -matroska -libnotify -live -lua -httpd -gnutls -bidi -debug" >> /etc/portage/package.use
emerge -av vlc


(and if it fails u can easily remove the last line of your /etc/portage/package.use file and rebuild it as it was)

mines built from "Compiler: gcc version 4.7.3 (Gentoo 4.7.3 p1.0, pie-0.5.5)" if that makes any difference though it shouldn't


Last edited by 666threesixes666 on Sat Aug 03, 2013 5:46 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4191
Location: Irgendwo im Nirgendwo

PostPosted: Sat Aug 03, 2013 5:44 am    Post subject: Reply with quote

1) read your emerge output!
Code:
pkg_postinst() {
        if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
                einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
                "/usr/$(get_libdir)/vlc/vlc-cache-gen" -f "/usr/$(get_libdir)/vlc/plugins/"
        else
                ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
                ewarn "Please run /usr/$(get_libdir)/vlc/vlc-cache-gen manually"
                ewarn "If you do not do it, vlc will take a long time to load."
        fi
}


2) If it doesn't help run gdb:
Code:
$ gdb vlc
[... quite some output while gdb loads debug info ...]
(gdb) run
[... vlc starts running ...]
[... and hopefully crashes ...]
[... then type: ...]
(gdb) bt

That will give a hopefully helpful backtrace. You might want to store "thread apply all bt full" for later use.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 6:10 am    Post subject: Reply with quote

Portage didn't give me any messages after updating vlc. Running clx-cache-gen didn't help, unfortunately.

Thanks for pointing me to gdb. I had no idea it existed. Here is what I got

Code:
 gdb vlc
GNU gdb (Gentoo 7.6 p2) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/vlc...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/vlc
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
VLC media player 2.0.7 Twoflower (revision 2.0.6-54-g7dd7e4d)

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff72425a6 in ?? () from /lib64/libc.so.6
(gdb) bt
#0  0x00007ffff72425a6 in ?? () from /lib64/libc.so.6
#1  0x00007ffff3f2a9c9 in g_str_equal () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ffff3f2a0ff in g_hash_table_lookup () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ffff3f4938f in g_quark_from_static_string () from /usr/lib64/libglib-2.0.so.0
#4  0x00007ffff0e2af4c in ?? () from /usr/lib64/libgobject-2.0.so.0
#5  0x00007ffff7de9b46 in ?? () from /lib64/ld-linux-x86-64.so.2
#6  0x00007ffff7de9c2a in ?? () from /lib64/ld-linux-x86-64.so.2
#7  0x00007ffff7dedcd9 in ?? () from /lib64/ld-linux-x86-64.so.2
#8  0x00007ffff7de9986 in ?? () from /lib64/ld-linux-x86-64.so.2
#9  0x00007ffff7ded509 in ?? () from /lib64/ld-linux-x86-64.so.2
#10 0x00007ffff74c31e6 in ?? () from /lib64/libdl.so.2
#11 0x00007ffff7de9986 in ?? () from /lib64/ld-linux-x86-64.so.2
#12 0x00007ffff74c378c in ?? () from /lib64/libdl.so.2
#13 0x00007ffff74c3281 in dlopen () from /lib64/libdl.so.2
#14 0x00007ffff79780fd in ?? () from /usr/lib64/libvlccore.so.5
#15 0x00007ffff7962027 in ?? () from /usr/lib64/libvlccore.so.5
#16 0x00007ffff7962313 in ?? () from /usr/lib64/libvlccore.so.5
#17 0x00007ffff79623c2 in ?? () from /usr/lib64/libvlccore.so.5
#18 0x00007ffff7962541 in ?? () from /usr/lib64/libvlccore.so.5
#19 0x00007ffff7962ab7 in ?? () from /usr/lib64/libvlccore.so.5
#20 0x00007ffff79037df in libvlc_InternalInit () from /usr/lib64/libvlccore.so.5
#21 0x00007ffff7bc7ecd in libvlc_new () from /usr/lib64/libvlc.so.5
#22 0x0000000000401547 in ?? ()
#23 0x00007ffff713bbf5 in __libc_start_main () from /lib64/libc.so.6
#24 0x0000000000401721 in ?? ()
thread apply all bt full didn't give anything particularly useful, so I am not posting it.

EDIT: I am rebuilding glibc with USE=debug. Since that seems to be where the problem is, it seems like a good thing to try.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4191
Location: Irgendwo im Nirgendwo

PostPosted: Sat Aug 03, 2013 6:39 am    Post subject: Reply with quote

Code:
 $ quse -D debug
 global:debug: Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml

After changing CFLAGS/CXXFLAGS according to the provided link rebuild glib (libglib), glibc (/lib64/ld-linux-x86-64.so.2) and vlc, then run gdb, again.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 7:38 am    Post subject: Reply with quote

OK, that is better. I'll make sure this hasn't already been reported and post the bug tomorrow. I'm too tired to do it right now.

Code:
#0  __strcmp_ssse3 () at ../sysdeps/x86_64/multiarch/../strcmp.S:289
#1  0x00007ffff3f2aab9 in g_str_equal (v1=<optimized out>, v2=<optimized out>) at ghash.c:1706
#2  0x00007ffff3f2a1ef in g_hash_table_lookup_node (hash_return=<synthetic pointer>, key=0x7ffff0e5efba, hash_table=0x729c00) at ghash.c:386
#3  g_hash_table_lookup (hash_table=0x729c00, key=key@entry=0x7ffff0e5efba) at ghash.c:1076
#4  0x00007ffff3f494ef in quark_from_string (duplicate=0, string=0x7ffff0e5efba "-g-type-private--GTypeFlags") at gquark.c:173
#5  g_quark_from_static_string (string=string@entry=0x7ffff0e5efba "-g-type-private--GTypeFlags") at gquark.c:239
#6  0x00007ffff0e28fdc in gobject_init_ctor () at gtype.c:4365
#7  0x00007ffff7de9b46 in call_init (env=0x604200, argv=0x7fffffffe098, argc=1, l=<optimized out>) at dl-init.c:84
#8  call_init (l=<optimized out>, argc=1, argv=0x7fffffffe098, env=0x604200) at dl-init.c:34
#9  0x00007ffff7de9c2a in _dl_init (main_map=main_map@entry=0x719ed0, argc=1, argv=0x7fffffffe098, env=0x604200) at dl-init.c:133
#10 0x00007ffff7dedcd9 in dl_open_worker (a=a@entry=0x7fffffffd588) at dl-open.c:566
#11 0x00007ffff7de9986 in _dl_catch_error (objname=objname@entry=0x7fffffffd578, errstring=errstring@entry=0x7fffffffd580, mallocedp=mallocedp@entry=0x7fffffffd577, operate=operate@entry=0x7ffff7ded960 <dl_open_worker>,
    args=args@entry=0x7fffffffd588) at dl-error.c:177
#12 0x00007ffff7ded509 in _dl_open (file=0x717fc0 "/usr/lib64/vlc/plugins/text_renderer/libsvg_plugin.so", mode=-2147483647, caller_dlopen=<optimized out>, nsid=-2, argc=1, argv=0x7fffffffe098, env=0x604200) at dl-open.c:656
#13 0x00007ffff74c31e6 in dlopen_doit (a=a@entry=0x7fffffffd790) at dlopen.c:66
#14 0x00007ffff7de9986 in _dl_catch_error (objname=0x604020, errstring=0x604028, mallocedp=0x604018, operate=0x7ffff74c3180 <dlopen_doit>, args=0x7fffffffd790) at dl-error.c:177
#15 0x00007ffff74c378c in _dlerror_run (operate=operate@entry=0x7ffff74c3180 <dlopen_doit>, args=args@entry=0x7fffffffd790) at dlerror.c:163
#16 0x00007ffff74c3281 in __dlopen (file=<optimized out>, mode=<optimized out>) at dlopen.c:87
#17 0x00007ffff79780fd in module_Load (p_this=p_this@entry=0x604418, psz_file=psz_file@entry=0x717fc0 "/usr/lib64/vlc/plugins/text_renderer/libsvg_plugin.so", p_handle=p_handle@entry=0x7fffffffd7f8, lazy=<optimized out>)
    at posix/plugin.c:62
#18 0x00007ffff7962027 in module_InitDynamic (obj=0x604418, path=0x717fc0 "/usr/lib64/vlc/plugins/text_renderer/libsvg_plugin.so", fast=<optimized out>) at modules/bank.c:536
#19 0x00007ffff7962313 in AllocatePluginFile (st=<optimized out>, relpath=<optimized out>, abspath=<optimized out>, bank=<optimized out>) at modules/bank.c:479
#20 AllocatePluginDir (bank=0x7fffffffda30, maxdepth=4041600944, absdir=0xffff <Address 0xffff out of bounds>, reldir=0x618bb0 "text_renderer") at modules/bank.c:440
#21 0x00007ffff79623c2 in AllocatePluginDir (bank=0x7fffffffda30, maxdepth=4041600944, maxdepth@entry=5, absdir=0xffff <Address 0xffff out of bounds>, absdir@entry=0x6190c0 "/usr/lib64/vlc/plugins", reldir=0x0) at modules/bank.c:444
#22 0x00007ffff7962541 in AllocatePluginPath (p_this=p_this@entry=0x604418, path=0x6190c0 "/usr/lib64/vlc/plugins", mode=mode@entry=CACHE_USE) at modules/bank.c:353
#23 0x00007ffff7962ab7 in AllocateAllPlugins (p_this=0x604418) at modules/bank.c:282
#24 module_LoadPlugins (obj=obj@entry=0x604418) at modules/bank.c:189
#25 0x00007ffff79037df in libvlc_InternalInit (p_libvlc=p_libvlc@entry=0x604418, i_argc=i_argc@entry=3, ppsz_argv=ppsz_argv@entry=0x7fffffffddc0) at libvlc.c:247
#26 0x00007ffff7bc7ecd in libvlc_new (argc=argc@entry=2, argv=argv@entry=0x7fffffffde20) at core.c:59
#27 0x0000000000401547 in main (i_argc=<optimized out>, ppsz_argv=0x7fffffffe098) at vlc.c:217

_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4191
Location: Irgendwo im Nirgendwo

PostPosted: Sat Aug 03, 2013 8:20 am    Post subject: Reply with quote

So it segfaults in hand-written ASM...
Which version of glibc do you use? Which USE-Flags? CFLAGS? (emerge --info would be nice) What about your processor? (cat /proc/cupinfo)
Also the last emerged packages would be nice (qlop -l -> qlop comes with portage-utils), from the point you are sure vlc still worked fine (better more then less).

Did you already try running /usr/lib64/vlc/vlc-cache-gen yourself?
Does it fix the issue?
Probably the error is in this one specific plugin, so does USE="-svg" emerge vlc fix the issue? (Of course, if it does NOT crash anymore after running vlc-cache-gen and you want to check if it is only that plugin, remove plugins.dat, again)
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 7:31 pm    Post subject: Reply with quote

I used sys-libs/glibc-2.17:2.2 USE="debug (multilib) suid -gd (-hardened) -nscd -profile (-selinux) -systemtap -vanilla"

my emerge --info


CPU (X4)
Code:
processor   : 0
vendor_id   : GenuineIntel
cpu family   : 6
model      : 23
model name   : Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz
stepping   : 10
microcode   : 0xa07
cpu MHz      : 2670.000
cache size   : 2048 KB
physical id   : 0
siblings   : 4
core id      : 0
cpu cores   : 4
apicid      : 0
initial apicid   : 0
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips   : 5321.50
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:


The most recent packages. This also includes trying to roll back the packages that seemed have potential to be the problem.

I did try running /usr/lib64/vlc/vlc-cache-gen. It creates the file but it does not solve the issue.

USE="-svg" emerge vlc did fix the problem.

Filed bug report

EDIT: I am marking the thread as solved since the problem has been isolated enough to file a concise bug report. Thank you for your help.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sat Aug 03, 2013 8:13 pm    Post subject: Reply with quote

strange my svg works, and yours is giving you problems.... here are my useflags for librsvg

Use flags settings: +gtk, +introspection, -tools, -vala
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 9:01 pm    Post subject: Reply with quote

From what franzf said, it sounds like someone tried to hand code some assembly. This may produced efficient code, but it doesn't seem to agree with my processors.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Sat Aug 03, 2013 9:34 pm    Post subject: Reply with quote

This sounds a lot like this bug. On my system, I too, can cleanly emerge vlc 2.0.7 by removing the SVG USE flag, but I'll get a segmentation fault when starting vlc. If I remove both the libnotify and svg USE flags, vlc 2.0.7 will emerge cleanly, and start, but when I select a video to play, it then segfaults, as I described in the bug report comment section. I can only use vlc 2.0.7 now, by removing the qt4 USE flag, (of course that means no GUI). In this instance vlc 2.0.7 emerges cleanly, and will actually play a video file using the command line version, cvlc, only. Note this is with both libnotify and svg USE flags enabled.

Good Luck..
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1774

PostPosted: Sat Aug 03, 2013 11:08 pm    Post subject: Reply with quote

Interesting. In my case removing svg results in a perfectly usable build. It looks like we may have been hit by two sides of the same bug, although in my case vlc-cache-gen didn't sigfault.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4191
Location: Irgendwo im Nirgendwo

PostPosted: Sun Aug 04, 2013 7:13 am    Post subject: Reply with quote

Whom of you did build qtcore/qtgui with USE="glib"? Anyone qtgui with USE="gtkstyle"?
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Sun Aug 04, 2013 12:23 pm    Post subject: Reply with quote

USE glib yes, gtkstyle no.
Code:
emerge -pqv qtcore qtgui
[ebuild   R   ] dev-qt/qtcore-4.8.5  USE="exceptions glib iconv icu qt3support ssl (-aqua) -c++0x -debug -pch"
[ebuild   R   ] dev-qt/qtgui-4.8.5  USE="accessibility cups egl exceptions glib mng qt3support tiff xinerama xv (-aqua) -c++0x -debug -gtkstyle -nas -nis -pch -trace"
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4191
Location: Irgendwo im Nirgendwo

PostPosted: Mon Aug 05, 2013 4:49 pm    Post subject: Reply with quote

Aiii, seems to boil down to an issue with glib >(=)2.35...:
https://bugs.gentoo.org/show_bug.cgi?id=405173#c32
As USE="-qt4" emerge vlc fixed at least vlc-cache-gen, probably the malicious part is inside qt4's glib support.
So just for a quick test, could you reemerge qtcore + qtgui with USE="-glib"? It might cry if you run kde or qtwebkit[+gstreamer], but for the sake of this issue it would be great if you could test this.

For the record:
Just installed vlc-2.0.7[svg, libnotify]. I am running the "malicious" glib-2.36.3-r1. vlc does NOT crash.

[edit] probably it is enough to rebuild qtcore+qtgui (+qtdbus?) after the glib update 2.34->2.36? [/edit]
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Mon Aug 05, 2013 7:08 pm    Post subject: Reply with quote

Thank you for trying to sort this out Franz..

Based on your research and suggestions, this is the results of what I've tried;

    1) rebuild all of installed packages from dev/qt against the currently installed dev-libs/glib-2.36.3
    2) emerge media-video/vlc-2.0.7 with my normal USE flags;
    Code:
    media-video/vlc-2.0.7  USE="X a52 aac alsa avcodec avformat bluray cdda cddb dbus dts dvbpsi dvd egl encode ffmpeg flac fluidsynth fontconfig gcrypt kde libass libnotify matroska mmx mp3 mpeg mtp ncurses ogg opengl opus png postproc projectm qt4 rtsp samba schroedinger sdl skins speex sse svg swscale theora truetype twolame udev v4l vorbis x264 xcb xml xv

    3) results with same segmentation fault error emerging media-video/vlc-2.0.7, as reported in the bug report, 405173

    1) unmask and emerge dev-libs/glib-2.36.3-r1
    2) emerge media-video/vlc-2.0.7 with my normal USE flags
    3) results with same segmentation fault error emerging media-video/vlc-2.0.7, as reported in the bug report, 405173

    1) with dev-libs/glib-2.36.3-r1 installed, emerge media-video/vlc-2.0.7 with my normal USE flags, except -svg
    2) media-video/vlc-2.0.7 emerges cleanly
    3) running vlc from the GUI or command line crashes the program, with an immediate segmentation fault

    1) with dev-libs/glib-2.36.3-r1 installed, force a re-emerge of dev-qt/qtcore-4.8.5 and dev-qt/qtgui-4.8.5 without the glib USE flag
    2) emerge media-video/vlc-2.0.7 with my normal USE flags
    3) media-video/vlc-2.0.7 emerges cleanly
    4) running vlc from the GUI or command line, operates normally (finally)

As you may have expected, media-video/vlc-2.0.7 continued working correctly even after I downgraded back to dev-libs/glib-2.36.3. However, after re-emerging dev-qt/qtcore-4.8.5 and dev-qt/qtgui-4.8.5 with the glib USE flag enabled, media-video/vlc-2.0.7 continues working normally. Weird huh?

Thanks again. You're certainly closing in on the problem. It looks like it's a complicated bug, (or perhaps series of bugs), this time.

Jason
Back to top
View user's profile Send private message
derbrain
Apprentice
Apprentice


Joined: 09 Apr 2005
Posts: 176

PostPosted: Thu Aug 15, 2013 2:17 pm    Post subject: Reply with quote

jasn wrote:
    1) with dev-libs/glib-2.36.3-r1 installed, force a re-emerge of dev-qt/qtcore-4.8.5 and dev-qt/qtgui-4.8.5 without the glib USE flag
    2) emerge media-video/vlc-2.0.7 with my normal USE flags
    3) media-video/vlc-2.0.7 emerges cleanly
    4) running vlc from the GUI or command line, operates normally (finally)

As you may have expected, media-video/vlc-2.0.7 continued working correctly even after I downgraded back to dev-libs/glib-2.36.3. However, after re-emerging dev-qt/qtcore-4.8.5 and dev-qt/qtgui-4.8.5 with the glib USE flag enabled, media-video/vlc-2.0.7 continues working normally. Weird huh?


I had the same problem, and I tried your last solution - but WITH the glib USE flag. It works, so that's probably why it continued to work for you too :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum