Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] - alpine c-client chappa USE flags issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
fefeh
n00b
n00b


Joined: 23 Nov 2004
Posts: 43

PostPosted: Wed Jul 31, 2013 4:21 pm    Post subject: [SOLVED] - alpine c-client chappa USE flags issue Reply with quote

Hi,

I need a text-based e-mail client so I found alpine since I used to use pine. There is some problem between c-client and alpine using the chappa flags. When I have alpine installed, it will not let me do an emerge world.

I start with a clean, updated system.

Code:

gentoo3281 ~ # emerge -DuavN world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No] y


When I go to install alpine, it says the chappa flags are incorrect.

Code:

gentoo3281 ~ # emerge -av alpine

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/c-client-2007f-r4[topal=,chappa=]".
!!! One of the following packages is required to complete your request:
- net-libs/c-client-2007f-r4::gentoo (Change USE: +chappa)
- mail-client/alpine-2.00-r5::gentoo (Change USE: -chappa)
(dependency required by "mail-client/alpine-2.00-r5" [ebuild])
(dependency required by "alpine" [argument])


I change it in /etc/portage/package.use as requested.

Code:

mail-client/alpine -chappa -ssl
net-libs/c-client chappa


It will then install alpine.

Code:

>>> mail-client/alpine-2.00-r5 merged.

>>> Recording mail-client/alpine in "world" favorites file...


Then, when I go to do the update world again, it gives an error that they need to be reversed.

Code:

gentoo3281 ~ # emerge -DuavN world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/c-client-2007f-r4[topal=,chappa=]".
!!! One of the following packages is required to complete your request:
- net-libs/c-client-2007f-r4::gentoo (Change USE: -chappa)
- mail-client/alpine-2.00-r5::gentoo (Change USE: +chappa)
(dependency required by "mail-client/alpine-2.00-r5" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


I comment out the lines in /etc/portage/package.use and try again and it wants them reversed again. :evil:

Code:

gentoo3281 ~ # emerge -DuavN world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/c-client-2007f-r4[topal=,chappa=]".
!!! One of the following packages is required to complete your request:
- net-libs/c-client-2007f-r4::gentoo (Change USE: +chappa)
- mail-client/alpine-2.00-r5::gentoo (Change USE: -chappa)
(dependency required by "mail-client/alpine-2.00-r5" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Last edited by fefeh on Thu Aug 01, 2013 1:48 pm; edited 2 times in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Wed Jul 31, 2013 6:14 pm    Post subject: Reply with quote

I just have

net-libs/c-client chappa

in package.use, and alpine seemed to merge fine...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
fefeh
n00b
n00b


Joined: 23 Nov 2004
Posts: 43

PostPosted: Wed Jul 31, 2013 8:03 pm    Post subject: Reply with quote

eccerr0r wrote:
I just have

net-libs/c-client chappa

in package.use, and alpine seemed to merge fine...


Can you do an emerge world afterwards?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Thu Aug 01, 2013 12:00 am    Post subject: Reply with quote

Emerging world hasn't been a problem.

Currently both c-client and alpine are USE=+chappa - I didn't set chappa for alpine as I think it's the default. You probably could do USE=-chappa for both, they just need to match AFAICT...

And the default is +chappa for alpine...
Back to top
View user's profile Send private message
fefeh
n00b
n00b


Joined: 23 Nov 2004
Posts: 43

PostPosted: Thu Aug 01, 2013 1:47 pm    Post subject: Reply with quote

ok, that was it. Both applications have to match. The emerge message was not clear to me.

I commented out the alpine package in /etc/portage/package.use and put +chappa on the c-client and it emerged world again.

Thanks! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum