Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Q] Gnome 3.8 + SystemD - Cannot set 12-hour (AM/PM Clock)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Jul 31, 2013 12:14 pm    Post subject: [Q] Gnome 3.8 + SystemD - Cannot set 12-hour (AM/PM Clock) Reply with quote

I have a bit of a problem with gnome 3.8 - seems to be my only remaining problem.

When I go ahead and switch the clock to AM/PM (12-hour) in the date & time settings. Nothing changes and the clock remains 24-hour. When I go further and restart gnome, gnome fails to start.

The problem is about identical to it is here (https://bbs.archlinux.org/viewtopic.php?pid=1281584)

The problem is, my locales are set correctly.

I enabled en_US.UTF-8 UTF-8 in locale.gen and ran locale-gen I also set LANG="en_US.UTF-8" in my bashrc.

The output of "locale -a" displays a "en_US.utf8" rather than "en_US.UTF-8" but changing the LANG variable to the lowercase utf8 doesn't make a difference.

Is there anybody else that has had this problem on 3.8? (On 3.6 it worked fine)

Thanks
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
erikm
l33t
l33t


Joined: 08 Feb 2005
Posts: 631

PostPosted: Thu Aug 01, 2013 10:00 am    Post subject: Reply with quote

The "en_US.utf8" locale defines a 12-hour AM/PM format through LC_TIME. Use the "en_DK.utf8" locale for LC_TIME instead, like so:

Code:
user@host ~ $ cat /etc/env.d/02locale
LANG="en_US.utf8"
LC_CTYPE="en_US.utf8"
LC_COLLATE="C"
LC_TIME="en_DK.utf8"
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Thu Aug 01, 2013 11:29 am    Post subject: Reply with quote

systemd:
/etc/locale.conf

But might be possible to link together these two files as they do not differ
_________________
fun2gen2
Back to top
View user's profile Send private message
doralsoral
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2004
Posts: 113

PostPosted: Fri Aug 02, 2013 11:20 pm    Post subject: Reply with quote

erikm wrote:
The "en_US.utf8" locale defines a 12-hour AM/PM format through LC_TIME. Use the "en_DK.utf8" locale for LC_TIME instead, like so:

Code:
user@host ~ $ cat /etc/env.d/02locale
LANG="en_US.utf8"
LC_CTYPE="en_US.utf8"
LC_COLLATE="C"
LC_TIME="en_DK.utf8"


This doesn't work for me. I still can't change the time to am/pm
Back to top
View user's profile Send private message
erikm
l33t
l33t


Joined: 08 Feb 2005
Posts: 631

PostPosted: Mon Aug 05, 2013 7:03 am    Post subject: Reply with quote

Ok. Did you try disabling seconds?

(From the forum thread you linked)

ewaller wrote:

I had the same problem when I tried to enable seconds on my clock.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum