Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless Issues on EEEPC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
arhenius
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2007
Posts: 81
Location: Portugal

PostPosted: Tue Jul 30, 2013 2:11 pm    Post subject: Wireless Issues on EEEPC Reply with quote

Dear All

I have been running gentoo on my eeepc 1000HE since -I brought it. Recently, I had to re-install gentoo on it, but now I can not put wicd to work properly. I can manage my wired connection from wicd without any trouble, but my wireless connection goes of right after authentication, with some dbus/python error messages. Also, if I turn my wireless card off and on again: it gets renamed from wlp1s0 to wlan0 (this may be an unrelated issue with udev).

This is what I have done so far. My wired interface is enp3s0 and my wireless card is wlp1s0.

  • My wired interface works fin either ising the init scrip or wicd

  • As root, my wireless interface works without problems using wpa_supplicant:
    Code:
    # wpa_supplicant -Dwext -iwlp1s0 -c/etc/wpa_supplicant.conf
    Trying to associate with 00:13:f7:99:4e:87 (SSID='Phi' freq=2462 MHz)
    ioctl[SIOCSIWFREQ]: Device or resource busy
    Association request to the driver failed
    Associated with 00:13:f7:99:4e:87
    WPA: Key negotiation completed with 00:13:f7:99:4e:87 [PTK=CCMP GTK=CCMP]
    CTRL-EVENT-CONNECTED - Connection to 00:13:f7:99:4e:87 completed (auth) [id=0 id_str=]


    And this is the content of /etc/wpa_supplicant.conf:

    Quote:
    network={
    ssid="Phi"
    scan_ssid=1
    proto=RSN
    pairwise=CCMP TKIP
    key_mgmt=WPA-PSK
    psk="MyCorrectPasswordIsHere"
    }


  • I created an encription template for wicd, based on my wpa_supplicant.conf, and activated it:
    Quote:
    name = WPA2-AES
    author = Filipe
    version = 1
    require apsk *Preshared_Key
    protected apsk *Preshared_Key
    -----
    ctrl_interface=/var/run/wpa_supplicant
    network={
    ssid="$_ESSID"
    scan_ssid=$_SCAN
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    psk="$_APSK"
    }


  • After starting wicd, I launched wicd-gtk as my normal user from the command line. The connection was configured to run with the WPA2-AES script and my password. The connection fails after Authentication, and this apears in the command line:
    Code:
    ERROR:dbus.connection:Exception in handler for D-Bus signal:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 230, in maybe_handle_message
        self._handler(*args, **kwargs)
      File "/usr/share/wicd/gtk/gui.py", line 253, in handle_connection_results
        error(self.window, language[results], block=False)
    KeyError: dbus.String(u'failed')


    This is my wicd log:
    Code:
    2013/07/30 12:49:15 :: wicd initializing...
    2013/07/30 12:49:15 :: ---------------------------
    2013/07/30 12:49:15 :: wicd is version 1.7.2.4 768
    2013/07/30 12:49:15 :: setting backend to external
    2013/07/30 12:49:15 :: trying to load backend external
    2013/07/30 12:49:15 :: successfully loaded backend external
    2013/07/30 12:49:15 :: trying to load backend external
    2013/07/30 12:49:15 :: successfully loaded backend external
    2013/07/30 12:49:15 :: Automatically detected wireless interface wlp1s0
    2013/07/30 12:49:15 :: setting wireless interface wlan0
    2013/07/30 12:49:15 :: automatically detected wired interface enp3s0
    2013/07/30 12:49:15 :: setting wired interface enp3s0
    2013/07/30 12:49:15 :: setting wpa driver ralink_legacy
    2013/07/30 12:49:15 :: setting use global dns to False
    2013/07/30 12:49:15 :: setting global dns
    2013/07/30 12:49:15 :: global dns servers are None None None
    2013/07/30 12:49:15 :: domain is None
    2013/07/30 12:49:15 :: search domain is None
    2013/07/30 12:49:15 :: setting automatically reconnect when connection drops True
    2013/07/30 12:49:15 :: Setting dhcp client to 2
    2013/07/30 12:49:15 :: Wireless configuration file found...
    2013/07/30 12:49:15 :: Wired configuration file found...
    2013/07/30 12:49:15 :: chmoding configuration files 0600...
    2013/07/30 12:49:15 :: chowning configuration files root:root...
    2013/07/30 12:49:15 :: Using wireless interface...wlp1s0
    2013/07/30 12:49:15 :: Using wired interface...enp3s0
    (Autoconnect tries...)
    2013/07/30 12:49:35 :: Unable to autoconnect, you'll have to manually connect
    2013/07/30 12:50:05 :: trying to load backend external
    2013/07/30 12:50:05 :: trying to load backend ioctl
    2013/07/30 12:50:05 :: WARNING: python-iwscan not found, falling back to using iwlist scan.
    2013/07/30 12:50:05 :: WARNING: python-wpactrl not found, falling back to using wpa_cli.
    2013/07/30 12:50:20 :: setting use global dns to 0
    2013/07/30 12:50:20 :: setting global dns
    2013/07/30 12:50:20 :: global dns servers are   
    2013/07/30 12:50:20 :: domain is
    2013/07/30 12:50:20 :: search domain is
    2013/07/30 12:50:20 :: setting wireless interface wlp1s0
    2013/07/30 12:50:20 :: setting wired interface enp3s0
    2013/07/30 12:50:20 :: setting wpa driver ralink_legacy
    2013/07/30 12:50:20 :: setting automatically reconnect when connection drops 1
    2013/07/30 12:50:20 :: setting backend to external
    2013/07/30 12:50:20 :: Setting dhcp client to 2
    2013/07/30 12:50:57 :: Connecting to wireless network Phi
    2013/07/30 12:50:57 :: Putting interface down
    2013/07/30 12:50:57 :: Releasing DHCP leases...
    2013/07/30 12:50:57 :: Setting false IP...
    2013/07/30 12:50:57 :: Stopping wpa_supplicant
    2013/07/30 12:50:57 :: Flushing the routing table...
    2013/07/30 12:50:57 :: Putting interface up...
    2013/07/30 12:50:59 :: Generating psk...
    2013/07/30 12:50:59 :: Attempting to authenticate...
    2013/07/30 12:50:59 :: Exception in thread Thread-4:
    2013/07/30 12:50:59 :: Traceback (most recent call last):
    2013/07/30 12:50:59 ::   File "/usr/lib/python2.7/threading.py", line 808, in __bootstrap_inner
    2013/07/30 12:50:59 ::     self.run()
    2013/07/30 12:50:59 ::   File "/usr/lib/python2.7/site-packages/wicd/networking.py", line 342, in run
    2013/07/30 12:50:59 ::     self._connect()
    2013/07/30 12:50:59 ::   File "/usr/lib/python2.7/site-packages/wicd/networking.py", line 920, in _connect
    2013/07/30 12:50:59 ::     if not wiface.ValidateAuthentication(time.time()):
    2013/07/30 12:50:59 ::   File "/usr/lib/python2.7/site-packages/wicd/wnettools.py", line 1371, in ValidateAuthentication
    2013/07/30 12:50:59 ::     result = misc.RunRegex(auth_pattern, output)
    2013/07/30 12:50:59 ::   File "/usr/lib/python2.7/site-packages/wicd/misc.py", line 204, in RunRegex
    2013/07/30 12:50:59 ::     m = regex.search(string)
    2013/07/30 12:50:59 :: RuntimeError: internal error in regular expression engine
    2013/07/30 12:50:59 ::
    2013/07/30 12:51:00 :: Sending connection attempt result failed


  • Relevant Information on dmesg:
    Code:
    dmesg | grep -i wlp1s0
    [    9.368333] systemd-udevd[1369]: renamed network interface wlan0 to wlp1s0
    [   16.682413] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [  234.858119] wlp1s0: authenticate with 00:13:f7:99:4e:87
    [  234.863243] wlp1s0: send auth to 00:13:f7:99:4e:87 (try 1/3)
    [  234.864635] wlp1s0: authenticated
    [  234.865100] wlp1s0: associate with 00:13:f7:99:4e:87 (try 1/3)
    [  234.873040] wlp1s0: RX AssocResp from 00:13:f7:99:4e:87 (capab=0x471 status=0 aid=1)
    [  234.874058] wlp1s0: associated
    [  234.874086] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
    [  269.410899] wlp1s0: deauthenticating from 00:13:f7:99:4e:87 by local choice (reason=3)
    [  291.100521] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [  292.221760] wlp1s0: authenticate with 00:13:f7:99:4e:87
    [  292.225522] wlp1s0: send auth to 00:13:f7:99:4e:87 (try 1/3)
    [  292.226899] wlp1s0: authenticated
    [  292.227084] wlp1s0: associate with 00:13:f7:99:4e:87 (try 1/3)
    [  292.235033] wlp1s0: RX AssocResp from 00:13:f7:99:4e:87 (capab=0x471 status=0 aid=1)
    [  292.235613] wlp1s0: associated
    [  292.235636] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
    [  310.547736] wlp1s0: deauthenticating from 00:13:f7:99:4e:87 by local choice (reason=3)
    [ 1428.291402] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [ 1459.896512] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [ 1460.105321] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [ 1462.780869] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [ 1646.963870] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [ 1647.158152] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    [ 1649.861668] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready




May this be a problem with python 2.7? A problem with DBUS? Or a problem with the unfortunate idea of changing the naming rules in udev (I can not recover my inteface as wlp1s0 after turning it down and up again, although wlan0 behave in the same way as wlp1s0)? I tried both the stable net-misc/wicd-1.7.2.4-r2 as well as the ~x86 version net-misc/wicd-1.7.2.4-r3 (which was the version used in these tests).

Thanks in advance for any help.
_________________
Filipe
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Wed Jul 31, 2013 3:06 am    Post subject: Re: Wireless Issues on EEEPC Reply with quote

arhenius wrote:
Code:
2013/07/30 12:49:15 :: setting wpa driver ralink_legacy

This is almost certainly wrong. The rt2x00 driver uses wext/nl80211.
Back to top
View user's profile Send private message
arhenius
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2007
Posts: 81
Location: Portugal

PostPosted: Wed Jul 31, 2013 8:58 pm    Post subject: Reply with quote

Thanks for the feedback, Ant P.

I changed the driver to wext (and also tried nl80211 and ralink) and still can not connect. However, a different kind of error was observed: as you can see in the log, for wext there is no python/dbus error, but the connections terminates instantly.

Here is my wicd log:

Code:
2013/07/31 21:38:03 :: No wired connection present, attempting to autoconnect to wireless network
2013/07/31 21:38:05 :: Unable to autoconnect, you'll have to manually connect
2013/07/31 21:38:12 :: trying to load backend external
2013/07/31 21:38:12 :: trying to load backend ioctl
2013/07/31 21:38:12 :: WARNING: python-iwscan not found, falling back to using iwlist scan.
2013/07/31 21:38:12 :: WARNING: python-wpactrl not found, falling back to using wpa_cli.
2013/07/31 21:38:23 :: setting use global dns to 0
2013/07/31 21:38:23 :: setting global dns
2013/07/31 21:38:23 :: global dns servers are   
2013/07/31 21:38:23 :: domain is
2013/07/31 21:38:23 :: search domain is
2013/07/31 21:38:23 :: setting wireless interface wlp1s0
2013/07/31 21:38:23 :: setting wired interface enp3s0
2013/07/31 21:38:23 :: setting wpa driver wext
2013/07/31 21:38:23 :: setting automatically reconnect when connection drops 1
2013/07/31 21:38:23 :: setting backend to external
2013/07/31 21:38:23 :: Setting dhcp client to 2
2013/07/31 21:38:32 :: Connecting to wireless network Phi
2013/07/31 21:38:33 :: Putting interface down
2013/07/31 21:38:33 :: Releasing DHCP leases...
2013/07/31 21:38:33 :: Setting false IP...
2013/07/31 21:38:33 :: Stopping wpa_supplicant
2013/07/31 21:38:33 :: Flushing the routing table...
2013/07/31 21:38:33 :: Putting interface up...
2013/07/31 21:38:35 :: Generating psk...
2013/07/31 21:38:35 :: Attempting to authenticate...
2013/07/31 21:38:37 :: Running DHCP with hostname darwin
2013/07/31 21:38:37 :: dhcpcd[2764]: sending commands to master dhcpcd process
2013/07/31 21:38:37 ::
2013/07/31 21:38:37 ::
2013/07/31 21:38:37 :: DHCP connection successful
2013/07/31 21:38:37 :: not verifying
2013/07/31 21:38:37 :: Connecting thread exiting.
2013/07/31 21:38:37 :: Sending connection attempt result success
2013/07/31 21:38:49 :: setting use global dns to 0
2013/07/31 21:38:49 :: setting global dns
2013/07/31 21:38:49 :: global dns servers are   
2013/07/31 21:38:49 :: domain is
2013/07/31 21:38:49 :: search domain is
2013/07/31 21:38:49 :: setting wireless interface wlp1s0
2013/07/31 21:38:49 :: setting wired interface enp3s0
2013/07/31 21:38:49 :: setting wpa driver nl80211
2013/07/31 21:38:49 :: setting automatically reconnect when connection drops 1
2013/07/31 21:38:49 :: setting backend to external
2013/07/31 21:38:49 :: Setting dhcp client to 2
2013/07/31 21:38:51 :: Connecting to wireless network Phi
2013/07/31 21:38:52 :: Putting interface down
2013/07/31 21:38:52 :: Releasing DHCP leases...
2013/07/31 21:38:52 :: Setting false IP...
2013/07/31 21:38:52 :: Stopping wpa_supplicant
2013/07/31 21:38:52 :: Flushing the routing table...
2013/07/31 21:38:52 :: Putting interface up...
2013/07/31 21:38:54 :: Generating psk...
2013/07/31 21:38:54 :: Attempting to authenticate...
2013/07/31 21:39:29 :: wpa_supplicant authentication may have failed.
2013/07/31 21:39:29 :: connect result is failed
2013/07/31 21:39:29 :: exiting connection thread
2013/07/31 21:39:29 :: Sending connection attempt result bad_pass
2013/07/31 21:39:45 :: setting use global dns to 0
2013/07/31 21:39:45 :: setting global dns
2013/07/31 21:39:45 :: global dns servers are   
2013/07/31 21:39:45 :: domain is
2013/07/31 21:39:45 :: search domain is
2013/07/31 21:39:45 :: setting wireless interface wlp1s0
2013/07/31 21:39:45 :: setting wired interface enp3s0
07/31 21:39:45 :: setting wpa driver ralink
07/31 21:39:45 :: setting automatically reconnect when connection drops 1
07/31 21:39:45 :: setting backend to external
07/31 21:39:45 :: Setting dhcp client to 2
07/31 21:39:48 :: Connecting to wireless network Phi
07/31 21:39:48 :: Putting interface down
07/31 21:39:48 :: Releasing DHCP leases...
07/31 21:39:48 :: Setting false IP...
07/31 21:39:48 :: Stopping wpa_supplicant
07/31 21:39:48 :: Flushing the routing table...
07/31 21:39:48 :: Putting interface up...
07/31 21:39:50 :: Generating psk...
07/31 21:39:50 :: Attempting to authenticate...
07/31 21:39:50 :: Exception in thread Thread-5:
07/31 21:39:50 :: Traceback (most recent call last):
07/31 21:39:50 ::   File "/usr/lib/python2.7/threading.py", line 808, in __bootstr
07/31 21:39:50 ::     self.run()
07/31 21:39:50 ::   File "/usr/lib/python2.7/site-packages/wicd/networking.py", li
07/31 21:39:50 ::     self._connect()
07/31 21:39:50 ::   File "/usr/lib/python2.7/site-packages/wicd/networking.py", li
07/31 21:39:50 ::     if not wiface.ValidateAuthentication(time.time()):
07/31 21:39:50 ::   File "/usr/lib/python2.7/site-packages/wicd/wnettools.py", lin
07/31 21:39:50 ::     result = misc.RunRegex(auth_pattern, output)
07/31 21:39:50 ::   File "/usr/lib/python2.7/site-packages/wicd/misc.py", line 204
07/31 21:39:50 ::     m = regex.search(string)
07/31 21:39:50 :: RuntimeError: internal error in regular expression engine
07/31 21:39:50 ::
07/31 21:39:51 :: Sending connection attempt result failed


Cheers
Filipe
_________________
Filipe
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum