Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Understanding slot conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
chias
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2009
Posts: 77
Location: everywhere

PostPosted: Wed Dec 04, 2013 9:28 am    Post subject: Understanding slot conflicts Reply with quote

I'm faced with the following:


Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.4::gentoo, ebuild scheduled for merge) pulled in by
    <=x11-base/xorg-server-1.14.49[-minimal] required by (x11-drivers/ati-drivers-13.11_beta6::gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.14.99.903::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-input-synaptics-1.7.1::gentoo, installed)
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-video-intel-2.99.906::gentoo, installed)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.1.1::gentoo, installed)

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-lang/python:2.7

  (dev-lang/python-2.7.5-r4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-2.7.5-r4::gentoo, installed) pulled in by
    dev-lang/python:2.7[sqlite] required by (net-analyzer/nmap-6.25::gentoo, installed)

virtual/udev:0

  (virtual/udev-208::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/udev-208::gentoo, installed) pulled in by
    >=virtual/udev-200[static-libs?] required by (sys-fs/lvm2-2.02.104::gentoo, installed)


Lets start at the top: xorg-server. Okay, ati-drivers want xorg-server to be below a certain threshold, and some drivers I have installed require a particular version.

Question 1: what's up with xf86-input-synaptics-1.7.1 etc requiring that specific version of xorg-server? Looking at the ebuild, I see ">=x11-base/xorg-server-1.12". Surely org-server-1.13.4-r1 satisfies this constraint? Why do the xf86- packages think they need xorg-server-1.14.99.903?

Next, zlib, python and udev:

Question 2: what exactly is the problem here? This all looks fine to me. Why isn't it installing zlib-1.2.8-r1, python-2.7.5-r4 and udev-208?

Thank you
Back to top
View user's profile Send private message
chias
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2009
Posts: 77
Location: everywhere

PostPosted: Wed Dec 04, 2013 9:47 am    Post subject: Reply with quote

So I got portage to get past the xorg-server conflict by just installing the four packages manually:

emerge -av1 xorg-server xf86-input-synaptics xf86-input-evdev xf86-video-intel ati-drivers

It complained a little bit about holding an update back, but continued on nonetheless. Now, trying to perform a general update yields the same conflicts for zlib, python and udev but the xorg ones look like this:

Code:
x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.99.903::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.14.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.4= required by (x11-drivers/xf86-input-synaptics-1.7.1::gentoo, installed)
    x11-base/xorg-server:0/1.14.4= required by (x11-drivers/xf86-video-intel-2.99.906::gentoo, installed)
    <=x11-base/xorg-server-1.14.49[-minimal] required by (x11-drivers/ati-drivers-13.11_beta6::gentoo, installed)
    x11-base/xorg-server:0/1.14.4= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)


Why is it so hell-bent on trying to install xorg-server-1.14.99.903?
Back to top
View user's profile Send private message
Lori
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 266
Location: Barcelona, Spain

PostPosted: Wed Dec 04, 2013 10:07 am    Post subject: Reply with quote

Try running emerge world by adding the -t switch. Thant will show you which package is trying to pull in whatever it is that's being upgraded.
_________________
"The hunt is sweeter then the kill."
Registered Linux User #176911
Back to top
View user's profile Send private message
chias
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2009
Posts: 77
Location: everywhere

PostPosted: Wed Dec 04, 2013 4:28 pm    Post subject: Reply with quote

Thanks for the response! The result of adding -t:

Code:
human ~ # emerge -avDNut @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] www-plugins/google-talkplugin-4.9.1.0  USE="libnotify -system-libCg" LINGUAS="-ar -bg -bn -ca -cs -da -de -el -en -es -et -fa -fi -fil -fr -gu -hi -hr -hu -id -is -it -ja -kn -ko -lt -lv -ml -mr -ms -nl -no -or -pl -ro -ru -sk -sl -sr -sv -ta -te -th -tl -tr -uk -ur -vi" VIDEO_CARDS="fglrx* -radeon" 0 kB
[ebuild     U  ] x11-base/xorg-server-1.14.99.903:0/1.14.99.903 [1.14.4:0/1.14.4] USE="ipv6 nptl suid tslib udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -xnest -xvfb" 0 kB
[ebuild   R    ]  virtual/udev-208  USE="gudev introspection kmod (-selinux) -static-libs*" ABI_X86="(64) -32 (-x32)" 0 kB
[ebuild  NS    ]  sys-devel/automake-1.13.4:1.13 [1.12.6:1.12, 1.14:1.14] 0 kB
[nomerge       ] media-video/mkvtoolnix-6.5.0  USE="wxwidgets -debug -pch -qt4"
[nomerge       ]  dev-libs/boost-1.53.0:0/1.53  USE="nls python threads -debug -doc -icu -mpi -static-libs -tools" PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_3"
[ebuild   R    ]   dev-lang/python-2.7.5-r4:2.7  USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened -sqlite* -tk -wininst" 0 kB
[nomerge       ] x11-base/xorg-server-1.14.99.903:0/1.14.99.903 [1.14.4:0/1.14.4] USE="ipv6 nptl suid tslib udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -xnest -xvfb"
[ebuild   R    ]  x11-base/xorg-drivers-1.15  INPUT_DEVICES="evdev synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -mouse -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="fglrx* intel -apm -ast -chips -cirrus -dummy -epson -fbdev (-freedreno) (-geode) -glint -i128 (-i740) -mach64 -mga -modesetting -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo)" 0 kB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1  USE="-minizip* -static-libs" ABI_X86="(64) -32 (-x32)" 0 kB

Total: 7 packages (1 upgrade, 1 in new slot, 5 reinstalls), Size of downloads: 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.99.903::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.14.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.4= required by (x11-drivers/xf86-input-synaptics-1.7.1::gentoo, installed)
    x11-base/xorg-server:0/1.14.4= required by (x11-drivers/xf86-video-intel-2.99.906::gentoo, installed)
    <=x11-base/xorg-server-1.14.49[-minimal] required by (x11-drivers/ati-drivers-13.11_beta6::gentoo, installed)
    x11-base/xorg-server:0/1.14.4= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (media-video/vlc-2.1.1::gentoo, installed)

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-lang/python:2.7

  (dev-lang/python-2.7.5-r4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-2.7.5-r4::gentoo, installed) pulled in by
    dev-lang/python:2.7[sqlite] required by (net-analyzer/nmap-6.25::gentoo, installed)

virtual/udev:0

  (virtual/udev-208::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/udev-208::gentoo, installed) pulled in by
    >=virtual/udev-200[static-libs?] required by (sys-fs/lvm2-2.02.104::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


I don't really see anymuch to go on. What does "no parents that aren't satisfied by other packages in this slot" actually mean? To me, that sounds like that means that conflict is not necessary, which I don't understand.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1054

PostPosted: Wed Dec 04, 2013 5:14 pm    Post subject: Reply with quote

you should enable the useflags, that are required: minizip for zlib, sqlite for python2.7 and static-libs for udev
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Wed Dec 04, 2013 6:15 pm    Post subject: Reply with quote

As per people working on Portage in #gentoo-portage-dev on IRC, the way forward is to follow this:

Quote:
You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.


While changing USE flags may preliminary fix three of them, I doubt if it will fix the fourth; therefore further backtracking might be needed.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1054

PostPosted: Wed Dec 04, 2013 7:02 pm    Post subject: Reply with quote

the fourth (xorg-server) shouldn't be a problem, portage just notes that it won't be updated to x11-base/xorg-server-1.14.99.903 because of ati-drivers. As far as i understand the output
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum