Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Login screen on primary monitor
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Xonak
n00b
n00b


Joined: 18 Mar 2013
Posts: 18

PostPosted: Fri Jul 26, 2013 11:55 am    Post subject: Login screen on primary monitor Reply with quote

Hi!

I have finally decided to emerge xf86-video-intel-2.21.12 and now it no longer crashes at login screen with dual monitor.

But now that login screen of SLIM is displayed on 'wrong' monitor(TV), same with console output.

Tried with xorg.conf although it is really desirable to run without any special configuration if possible

Code:
Section "Device"
        Identifier "Intel Graphics"
        Option     "Monitor-DP1"     "DP"
        Option     "Monitor-HDMI2"   "HDMI"
        Driver     "intel"
        Option     "AccelMethod"     "sna"
EndSection
Section "Monitor"
        Identifier "DP"
        Option     "Primary"         "true"
        Option     "PreferredMode"   "1920x1080"
EndSection
Section "Monitor"
        Identifier "HDMI"
        Option     "RightOf"         "DP"
EndSection

but DP monitor stays in standby even in enlightenment-0.17.3(almost always with segv'd). Every time to turn it on I need

Code:
xrandr --output DP1 --mode 1920x1080 --rate 60
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 210
Location: West Grove, PA

PostPosted: Wed Jul 31, 2013 1:59 pm    Post subject: Reply with quote

I've had this problem too. I solved it by switching the "primary" display in my BIOS. This swaps the displays.

You may have to adjust xorg.conf also to match the change.
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
Xonak
n00b
n00b


Joined: 18 Mar 2013
Posts: 18

PostPosted: Sun Aug 18, 2013 11:39 am    Post subject: Reply with quote

It appears that option option has no effect in my case.
Bios splash screen and Grub menu are displayed on both screens(1080p50), but not boot messages later.

Turning on TV will disconnect monitor again!
Back to top
View user's profile Send private message
Xonak
n00b
n00b


Joined: 18 Mar 2013
Posts: 18

PostPosted: Wed Oct 02, 2013 12:38 pm    Post subject: Reply with quote

I appears that updating to enlightenment-9999 solved it :!:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum