Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]quit/wlan signal weak in gentoo while strong in WIN7
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 119
Location: JiangSu,China

PostPosted: Wed Jul 24, 2013 2:49 am    Post subject: [Solved]quit/wlan signal weak in gentoo while strong in WIN7 Reply with quote

my laptop wlan0 device is realtek 8723ae

my modem and wireless AP is in a room about 10+ meters away from my bedroom, with two walls between them.

when I use ,WIN7 , in my bedroom ,the signal is about 4/5 grid/(lattice),and Network Quality is just enough to use.

but in gentoo , I have selected CONFIG_realtek 8723ae in kernel drivers CONFIG and copy rtlwifi/rtl8723_B.bin firmware to /lib/firmware.

the wifi can be used, but only in the wifi AP room , as long as I go out of that room, the wifi net won''t be connected , no matter I make the AP noEncryption or WPA-PSK Encryption

I have tried ndiswrapper to use windows driver ,but it print error ,says my kernel doesn't support WXET_PRIV and a lot other ERROR messages.

so , is that the drivers problem, or kernel CONFIG , or something others?

thank you.


Last edited by double_crane on Fri Jul 26, 2013 1:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 140
Location: Finland

PostPosted: Wed Jul 24, 2013 7:31 am    Post subject: Reply with quote

Try the following (txpower 15 is maximum for my card).
Code:
iwconfig wlan0 txpower 15
iwconfig wlan0 power off

_________________
https://github.com/defer-
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 119
Location: JiangSu,China

PostPosted: Wed Jul 24, 2013 7:51 am    Post subject: Reply with quote

defer- wrote:
Try the following (txpower 15 is maximum for my card).
Code:
iwconfig wlan0 txpower 15
iwconfig wlan0 power off


thank you

I had tried that yesterday night

my max txpower is 20;
it's the default value when boot.

the dBm is about the same in WIN7 and Gentoo.

what I doubt is that the lost package tolerance‘s difference。

in Gentoo
Code:

iwconfig
signal quality: [color=red]is about 40/70. dbm is about -50 ~~-70dbm[/color]


so the progress to authenticate and get valid ip address may be difficult .

while in win, the dBm is about the same, but I can connect to the AP correctly
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Wed Jul 24, 2013 11:01 am    Post subject: Reply with quote

1st: txpower doensn't help much, don't bother with that, neither touch other settings
2st: I dont know where u get firmware, just do make firmware_install in kernel dir
3st: some drivers are just crappy under linux, but some are crappy under windows
4st: use wpa_supplicant, idk how its possible but it works much better than anything else,

killall network managers first and dhcXXX and anything uses wlanX

start it manually for now (/etc/init.d/wpa_supplicant start) , then run dhcpcd wlanX

run wpa_cli, check if its disconnects, if yes then ... { continue searching help :D,
u could test other kernel or try another firmware eg from package linux-firmware }

if no, then add services to start

5)sample wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel

network={
ssid="network"
scan_ssid=1
key_mgmt=WPA-PSK
psk="password"
}

6) remeber that wifi signal can pass barely 3 walls ( probably with not much signal left )
7) u can use wavemon (its just nice utility) to monitor if u r connected and check signal
8) dont compare link quality and signal level between other cards, some cards cheat, or show different results, some cars can connect and dont loose signal with few pW, and other could fail when showing signal in some mW )
9) if there is a lot other neworks on the same channel + neigbourhood channels, try switching to some empty channel

10) and last : if u have enabled wps in router, disable it, and change password for security reasons

last thing -> u can check ultimately if your driver could connect in good manner
emerge aircrack-ng
disable your card, by ifconfig wlanX down

run airmon-ng -c X ( where X is your channel number), check RX, or RXQ(dont remeber exactly) column at your router , if its below 100 or at least 90 , it would mean that u will have connection problems,
if its 100, u should connect

( but not all cards could work with airmon-ng, card must support monitor mode)
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 119
Location: JiangSu,China

PostPosted: Thu Jul 25, 2013 3:29 pm    Post subject: Reply with quote

thank you

I am using wpa-supplicant as Gentoo install doc recommend.

I use wavemon to see the signal quality when dhcp, it is from 26dBm (70/70,no lost) to -80dBm(about 20/70) ,about -68dBm in average.

I use some software in windows to see the wifi signal quality , it's about the same too.

but in win I can connect the AP, though the speed of surfing the Internet may be much lower than in the AP room.
while I can never connect to the AP in linux,not only Gentoo but also ubuntu livecd .

the dBm is about the same ,will it still be the drivers difference?

Or will it be the kernel or filesystem's problem ? But the ubuntu(offical kerne) and gentoo are also unable to connect to the AP

So , what may be the reason lead to this mostly?

I just quit making wifi work in Gentoo as it does in win7, but I'm a bit confused
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Fri Jul 26, 2013 1:23 pm    Post subject: Reply with quote

Linux driver might be bad, or maybe u should configure WEXT in kernel (at least to get ndiswrapper working, but maybe that the issue?)

I couldnt find in make xconfig any WEXT or CONFIG_WEXT

but its definitily there ( maybe u must trigger something like CFG80211, enable it and u will see CONFIG_CFG80211_WEXT, maybe rest will appear ? )

my config says it:

CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_WEXT_PRIV=y
CONFIG_CFG80211_WEXT=y
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 119
Location: JiangSu,China

PostPosted: Fri Jul 26, 2013 1:42 pm    Post subject: Reply with quote

mir3x wrote:
my config says it:

CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_WEXT_PRIV=y
CONFIG_CFG80211_WEXT=y


what 's the kernel version of yours?

mine is gentoo-sources-3.8.13

and WEXT_CORE PROC is there ,I can select them.

I had checked the Kconfig file in that dictrory.

below WEXT_PRIV this no source code to be compile. only a word binary(what's the word, means two value,I can't remember clearly.)

thank you all the same

may be I should mark this post as solved I quit
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Mon Jul 29, 2013 7:18 pm    Post subject: Reply with quote

>> what 's the kernel version of yours?

3.10.x-pf (pf doesnt have anything wireless related, other than in standard)

Anyway, maybe simplest way to get wifi working will be to put smartphone near doors and working as second access point :D ( smartphones have usually poor signal sending, but receiving is decent )
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum