Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Torrent clients don't connect to trackers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
fpspiter
n00b
n00b


Joined: 23 Jul 2013
Posts: 4

PostPosted: Tue Jul 23, 2013 7:04 pm    Post subject: [SOLVED] Torrent clients don't connect to trackers Reply with quote

Till now I easily managed to find solutions of my problems just by googling and reading the forums without bothering you...
I need to write my first post...
so hello everyone! :)

I guess I missed sth simple, but I'm struggling with it for a while.
None of my torrent clients is able to connect to any of udp and http trackers.

I'm running:
Code:
piter-pc piter # uname -a
Linux piter-pc 3.8.13-gentoo #1 SMP Fri Jul 19 22:24:34 CEST 2013 x86_64 Intel(R) Pentium(R) Dual CPU E2180 @ 2.00GHz GenuineIntel GNU/Linux



Here is detailed output of transmission 2.77:
Code:
Gtk-Message: Failed to load module "gnomesegvhandler"
* Adding handle: conn: 0x7f41d4022ed0
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 0 (0x7f41d4022ed0) send_pipe: 1, recv_pipe: 0
* About to connect() to torrent.fedoraproject.org port 6969 (#0)
*   Trying 152.19.134.148...
* Connected to torrent.fedoraproject.org (152.19.134.148) port 6969 (#0)
> GET /announce?info_hash=%40%f4%3a%8a%b9%d2L%8d%ce%14B%e8m%1d%98%e8%9e%09%df%8f&peer_id=-TR2770-iiq6pw8unuhj&port=54102&uploaded=0&downloaded=0&left=920650813&numwant=80&key=284f1a13&compact=1&supportcrypto=1&event=started HTTP/1.1
User-Agent: Transmission/2.77
Host: torrent.fedoraproject.org:6969
Accept: */*
Accept-Encoding: gzip;q=1.0, deflate, identity

* Empty reply from server
* Connection #0 to host torrent.fedoraproject.org left intact
* Found bundle for host torrent.fedoraproject.org: 0x7f41d4023830
* Connection 0 seems to be dead!
* Closing connection 0
* Adding handle: conn: 0x7f41d4023e50
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 1 (0x7f41d4023e50) send_pipe: 1, recv_pipe: 0
* About to connect() to torrent.fedoraproject.org port 6969 (#1)
*   Trying 152.19.134.148...
* Connected to torrent.fedoraproject.org (152.19.134.148) port 6969 (#1)
> GET /scrape?info_hash=%40%f4%3a%8a%b9%d2L%8d%ce%14B%e8m%1d%98%e8%9e%09%df%8f HTTP/1.1
User-Agent: Transmission/2.77
Host: torrent.fedoraproject.org:6969
Accept: */*
Accept-Encoding: gzip;q=1.0, deflate, identity

* Operation timed out after 30001 milliseconds with 0 out of -1 bytes received
* Closing connection 1
** Message: Got signal 2; trying to shut down cleanly. Do it again if it gets stuck.

As you see I've tried to download latest fedora, downloading starts immediately on windows 7 which is my second system.

qBittorrent finally manages to download a file, but without use of trackers. DHT and probably sth else makes it possible, you know better than me :)

I don't use iptables(it's not even installed).
I did not try rtorrent, because afaik it does not support UPnP, and normally my ports are blocked by local isp.

I know that my post lacks of data, but I don't know what else should I post here...
As you see English is not my native language, hopefully we will understand each other.

I will be very grateful for any hints! :)

Did I forget about some USE flags?




Edit. I've just checked how it works under ubuntu 13.04 livecd.
Everything behaves exactly the same...
Is there any know bug or a problem with amd64 architecture?

I would start to think it's my routers configuration fault, but under windows@bittorrent everything works flawlessly...


Last edited by fpspiter on Sat Sep 14, 2013 4:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 594
Location: east coast USA

PostPosted: Fri Jul 26, 2013 4:32 am    Post subject: Reply with quote

Did you follow these instructions?


* Since µTP is enabled by default, transmission needs large kernel buffers for
* the UDP socket. You can append following lines into /etc/sysctl.conf:
* net.core.rmem_max = 4194304
* net.core.wmem_max = 1048576
* and run sysctl -p
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.
patrick-hp-d fail2ban # nano -w /etc/sysctl.
sysctl.conf sysctl.d/
patrick-hp-d fail2ban # nano -w /etc/sysctl.conf
patrick-hp-d fail2ban # sysctl -p
net.ipv4.ip_forward = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.core.rmem_max = 4194304
net.core.wmem_max = 1048576
patrick-hp-d fail2ban #
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 594
Location: east coast USA

PostPosted: Fri Jul 26, 2013 10:01 am    Post subject: Reply with quote

Also, go into preferences and 'test' your selected port to see if it is open or closed.
I suspect your router config.
Back to top
View user's profile Send private message
fpspiter
n00b
n00b


Joined: 23 Jul 2013
Posts: 4

PostPosted: Fri Jul 26, 2013 2:15 pm    Post subject: Reply with quote

Thanks for the reply.

I have applied your settings.

Code:

piter-pc piter # sysctl -p
net.ipv4.ip_forward = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.core.rmem_max = 4194304
net.core.wmem_max = 1048576


But it didnt help... Nothing has changed.


thoughtform wrote:
Also, go into preferences and 'test' your selected port to see if it is open or closed.
I suspect your router config.


My connection looks as follows:
I receive signal via wifi from my isp to tplink router which serves as receiver. There is also my router connected to its builtin switch and I use its switch, radio, qos. Both of them have upnp enabled, but transmission reports port as closed. I have also one port forwarded for ssh on both routers, if I use it transmission says its open, so now I'm using it for testing. For a while I was connected just to my isp's tplink, but it did not changed anything.
Anyway in both cases result is always the same.

I was even messing with net-misc/curl USE flags for a while, still no result.

It's a bit werid... I would also say that's sth with my router is wrong,
but on windows everything works perfectly, on latest ubuntu livecd situation was the same as on gentoo.

Edit. Maybe there is everything ok with the connection?

Code:

 * Connected to torrent.fedoraproject.org (152.19.134.148) port 6969 (#0)


Code:

Accept-Encoding: gzip;q=1.0, deflate, identity


And then:
Code:

* Empty reply from server


What if it wasn't empty,but just decoding went wrong?
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 594
Location: east coast USA

PostPosted: Sun Jul 28, 2013 2:23 pm    Post subject: Reply with quote

please paste the output of:
emerge --info

thanks
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 594
Location: east coast USA

PostPosted: Sun Jul 28, 2013 3:42 pm    Post subject: Reply with quote

also what router do you have?
Back to top
View user's profile Send private message
fpspiter
n00b
n00b


Joined: 23 Jul 2013
Posts: 4

PostPosted: Sun Jul 28, 2013 3:55 pm    Post subject: Reply with quote

thoughtform wrote:
please paste the output of:
emerge --info

thanks

Code:

piter-pc piter # emerge --info
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo x86_64)
=================================================================
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Pentium-R-_Dual_CPU_E2180_@_2.00GHz-with-gentoo-2.2
KiB Mem:     6114896 total,   1657264 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of tree: Sat, 27 Jul 2013 08:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.5.4-r5, 2.7.5, 3.2.5-r1
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo steam-overlay gamerlay games chtekk-apps
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl http://gentoo.mirror.pw.edu.pl/"
LANG="pl_PL.utf8@euro"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/steam /var/lib/layman/gamerlay /var/lib/layman/games /var/lib/layman/chtekk-apps"
SYNC="rsync://rsync.pl.gentoo.org/gentoo-portage"
USE="32bit 3dnow 64bit X a52 aac aacplus aacs aalib acl acpi adns alsa amd64 ansi applet aspell audioscrobbler automount banshee berkdb branding bzip2 cairo cdda cdr cleartype cli clipboard colord consolekit corefonts cracklib crypt cups curl curlwrappers custom-optimization cxx dbus dhcp dhcpcd djvu dri dts dvd dvdr ebook eds eix emboss encode evo exif fam ffmpeg firefox firefox-bookmarks flac fontconfig fortran g3dvl gadu game game-engine games gdbm gif gimp gmail gmp gnome gnome-keyring gnome-online-accounts gnome-print gnome-screensaver gnome-shell gnomecanvas gnomecards gnutls google gpm gpu grub gstreamer gtk gtk2-perl gtkhotkey gtkhtml gtkmm gtkspell gtkstyle gtp gui hddtemp hpcups hpijs html iconv idn image imagemagick introspection irc jpeg jpeg2k json kerberos lastfm lastfmfingerprint lastfmradio lastgenre lastseen lcms ldap libmpeg2 libnotify libsecret lm_sensors mad matroska metalink minizip mmx mng modules mono mouse mousewheel mozilla mp3 mp4 mpeg mudflap multilib mysql nautilus ncurses networkmanager nls nptl ntfs nvcontrol nvidia ocr octave ogg opengl openmp openssl pam pango pcre pda pdf png policykit postscript ppds pulseaudio pvr python qt3support qt4 readline rtmp scanner schematics scp scrobbler sdl semantic-desktop sensors session slang smbclient socialweb spell sqlite sse sse2 sse3 ssh ssl ssse3 startup-notification svg symlink tcpd tesseract threads thunderbird tiff tools tracker truetype tv tv_check tv_combiner tv_pick_cgi tvtime type1 udev udisks unicode upower usb vdpau video vmware_guest_windows vorbis webgl webkit win32 wxwidgets x264 xcb xinerama xml xps xv xvfb xvid xvmc youtube zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog cpu cpufreq disk hddtemp notify_desktop thermal" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en_US en pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I don't think you will find a problem there.

I have started to experience the same problem on windows now...
It turns out that my isp is not blocking anything but instead they are heavily limiting allowed number of connections (to 200).
They say their 2,4GHz wifi system has problem with larger number and suggested me to switch to 5GHz network (which ofc requires additional setup fee)
I see that windows generates less connections, therefore it was harder to observe the problem there.

Mb it's offtopic, but do you know how to easily track what services/daemons generate which connections?
I would like to keep this number as small as possible.


Edit. My router is tplink wr1043nd with gargoyle 1.5.10 on it.
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 594
Location: east coast USA

PostPosted: Sun Jul 28, 2013 4:03 pm    Post subject: Reply with quote

emerge -av jnettop

useage:

jnettop -i eth0
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 594
Location: east coast USA

PostPosted: Sun Jul 28, 2013 4:08 pm    Post subject: Reply with quote

http://youcantbehelped.com/gentoo/jnettop.png
Back to top
View user's profile Send private message
fpspiter
n00b
n00b


Joined: 23 Jul 2013
Posts: 4

PostPosted: Sun Jul 28, 2013 4:12 pm    Post subject: Reply with quote

thank you very much.

I will try it :)

Edit.
Switching to a connection with increased allowed number of connections solved the problem.

Thank you for all advices.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum