Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Little KDE desktop lag.
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 16 Jul 2013
Posts: 3

PostPosted: Tue Jul 16, 2013 9:59 pm    Post subject: Little KDE desktop lag. Reply with quote


I'm facing odd problem with KDE on my desktop for a long time and I've not found good solution elsewhere so I kindly ask for your help:) The problem is a little lag when I switch virtual desktops, move windows, nearly always. I'm not sure how to describe it, things are just not smooth. Recently, I've discovered that existence of lag is dependent on memory usage - but I'm not sure - it looks like when my system uses more than 1.8GB of available 8 it starts to occure. It is not connected with certain application - checked with many sets.
I'm using nvidia-driver-319.23 on my GTX580, my kernel config is triple checked, I use OpenGL. And I'm not sure what more I can say - I think it may be something with MTRR:

~|⇒ cat /proc/mtrr
reg00: base=0x000000000 (    0MB), size= 8192MB, count=1: write-back
reg01: base=0x200000000 ( 8192MB), size= 1024MB, count=1: write-back
reg02: base=0x0d0000000 ( 3328MB), size=  256MB, count=1: uncachable
reg03: base=0x0e0000000 ( 3584MB), size=  512MB, count=1: uncachable
reg04: base=0x22f800000 ( 8952MB), size=    8MB, count=1: uncachable
reg05: base=0x230000000 ( 8960MB), size=  256MB, count=1: uncachable

but I have similar output on my laptop - there is no problem. I tried to change setting of MTRR, but I was not able to find them in my UEFI - I've got AsRock P67 Extreme4. I know that it can be changed with some console magick, but I'm not familiar with it so I don't want to mess things up without being sure it will help.

I will greatly appreciate your help.
Best regards,

EDIT: My kernel version is 3.8.13.
Back to top
View user's profile Send private message

Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Jul 17, 2013 6:22 am    Post subject: Reply with quote

I am using the 319.23 driver as well and kde-4.9.5 + 4G

- I do experience lags when switching virtual desktops as well, but nothing really noticeable in other situations.

About the MTRRs :

1/ What does your boot command line says ?
2/ What does your system log says ? (The calculus should be very close the beginning)

About nvidia :

1/ What does lspci -v tells ?
2/ Did you try with the in-kernel driver ?
Back to top
View user's profile Send private message

Joined: 16 Jul 2013
Posts: 3

PostPosted: Tue Jul 23, 2013 7:29 pm    Post subject: Reply with quote


title Gentoo Linux 3.8.13
kernel /boot/3.8.13-gentoo root=/dev/sda3 real_root=/dev/sda3 video=uvesafb:1920x1080-32,mtrr:3,ywrap


[    0.000000] MTRR variable ranges enabled:
[    0.000000]   0 base 000000000 mask E00000000 write-back
[    0.000000]   1 base 200000000 mask FC0000000 write-back
[    0.000000]   2 base 0D0000000 mask FF0000000 uncachable
[    0.000000]   3 base 0E0000000 mask FE0000000 uncachable
[    0.000000]   4 base 22F800000 mask FFF800000 uncachable
[    0.000000]   5 base 230000000 mask FF0000000 uncachable
[    0.000000]   6 disabled
[    0.000000]   7 disabled
[    0.000000]   8 disabled
[    0.000000]   9 disabled
[    0.000000] x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
[    0.000000] e820: update [mem 0xd0000000-0xffffffff] usable ==> reserved
[    0.000000] e820: last_pfn = 0xcf800 max_arch_pfn = 0x400000000
[    0.000000] found SMP MP-table at [mem 0x000fd210-0x000fd21f] mapped at [ffff8800000fd210]
[    0.000000] initial memory mapped: [mem 0x00000000-0x1fffffff]
[    0.000000] Base memory trampoline at [ffff880000098000] 98000 size 24576
[    0.000000] init_memory_mapping: [mem 0x00000000-0xcf7fffff]
[    0.000000]  [mem 0x00000000-0xcf7fffff] page 2M
[    0.000000] kernel direct mapping tables up to 0xcf7fffff @ [mem 0x1fffb000-0x1fffffff]
[    0.000000] init_memory_mapping: [mem 0x100000000-0x22f7fffff]
[    0.000000]  [mem 0x100000000-0x22f7fffff] page 2M
[    0.000000] kernel direct mapping tables up to 0x22f7fffff @ [mem 0xcf7fa000-0xcf7fffff]


01:00.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 580] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 8385
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=128M]
        Memory at d8000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        [virtual] Expansion ROM at fb000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel driver in use: nvidia
        Kernel modules: nvidia

Yes, I've tried, but it was long time ago and then I was using Gnome3. It ran smooth. I wil try with kernel driver, maybe it will help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum