Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to install gnome 3.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aleixrocks
n00b
n00b


Joined: 22 Jul 2013
Posts: 11

PostPosted: Mon Jul 22, 2013 10:51 pm    Post subject: How to install gnome 3.6 Reply with quote

I'm totally a noob on gentoo. I have been searching but i'm not completly sure of what I'm doing. I want to install gnome 3.6 which is currently on testing. Does sombody know some guide to install it? I don't find any documentation and I get a little lost while trying to solve dependencies.
Back to top
View user's profile Send private message
aleixrocks
n00b
n00b


Joined: 22 Jul 2013
Posts: 11

PostPosted: Tue Jul 23, 2013 2:17 pm    Post subject: Reply with quote

The web page en.­gentoo-­wiki.­com/­wiki/­Gnome_3 seems to explain how to install it, but en.gentoo-wiki.com has been down for days. Does anyone know what can happen to it?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Jul 23, 2013 4:15 pm    Post subject: Reply with quote

aleixrocks wrote:
The web page en.­gentoo-­wiki.­com/­wiki/­Gnome_3 seems to explain how to install it, but en.gentoo-wiki.com has been down for days. Does anyone know what can happen to it?


Add ~ to ACCEPT_KEYWORDS in /etc/portage/make.conf if you feel you don't mind running not stabilized versions.

But if you do mind to run stable versions, and solely want Gnome 3.6 you might want to accept only the keywords for those packages; like so:
Quote:
# Backs up file.
mv /etc/portage/package.accept_keywords{,.bak}

# Creates directory.
mkdir /etc/portage/package.accept_keywords/

# Move file to directory.
mv /etc/portage/package.accept_keywords.bak /etc/portage/package.accept_keywords/accept_keywords

# Create Gnome 3.6 unmask file.
awk -vRS= '/Gnome 3.8 Mask/' /usr/portage/profiles/package.mask | sed 's/^>=/</' > /etc/portage/package.accept_keywords/Gnome3.6
Whenever you sync, you can run this last line again.

You'll probably note the 3.8 mask, this awk and sed magic rewrites that such that it accepts all versions that are not Gnome 3.8 or higher; effectively accepting keywords on Gnome 3.6.

PS: Yes, there is a intentional space after -vRS=.
Back to top
View user's profile Send private message
aleixrocks
n00b
n00b


Joined: 22 Jul 2013
Posts: 11

PostPosted: Tue Jul 23, 2013 6:03 pm    Post subject: Reply with quote

Instead of working with the entire unstable branch I would prefer to just use gnome of the unstable branch. So I added the metapackage "gnome-base/gnome" on /etc/portage/package.accept_keywords. Is this ok instead of adding ~ on the entire architecture?

Doing what you suggested, I'm still getting dependecy conflicts. To be precise, this is my standard error output when running "emerge gnome"

Code:



!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)

  (dev-libs/glib-2.34.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.34.3:2 required by (dev-util/gdbus-codegen-2.34.3::gentoo, ebuild scheduled for merge)
    (and 18 more with the same problem)

dev-libs/gobject-introspection:0

  (dev-libs/gobject-introspection-1.32.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-1.34.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

sys-auth/pambase:0

  (sys-auth/pambase-20120417-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge) pulled in by
    sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
    ~net-libs/libsoup-2.38.1[introspection?] required by (net-libs/libsoup-gnome-2.38.1::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-2.40.3::gentoo, ebuild scheduled for merge) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, ebuild scheduled for merge)
    >=net-libs/libsoup-2.40:2.4[introspection] required by (gnome-base/gnome-shell-3.6.3.1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problems)

net-libs/libsoup-gnome:2.4

  (net-libs/libsoup-gnome-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/libsoup-gnome-2.40.3::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-gnome-2.39.6:2.4 required by (www-client/epiphany-3.6.1::gentoo, ebuild scheduled for merge)

x11-libs/gdk-pixbuf:2

  (x11-libs/gdk-pixbuf-2.26.4::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gdk-pixbuf:2[jpeg,introspection?] required by (media-video/cheese-3.6.2::gentoo, ebuild scheduled for merge)
    x11-libs/gdk-pixbuf:2[jpeg?,tiff?] required by (media-gfx/eog-3.6.2::gentoo, ebuild scheduled for merge)

  (x11-libs/gdk-pixbuf-2.26.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gdk-pixbuf-2.28.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gdk-pixbuf:2[jpeg,introspection?] required by (media-video/cheese-3.6.2::gentoo, ebuild scheduled for merge)
    x11-libs/gdk-pixbuf:2[jpeg?,tiff?] required by (media-gfx/eog-3.6.2::gentoo, ebuild scheduled for merge)
    >=x11-libs/gdk-pixbuf-2.26.5:2 required by (gnome-base/gnome-core-libs-3.6.2::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problems)

media-libs/gst-plugins-good:1.0

  (media-libs/gst-plugins-good-1.0.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/gst-plugins-good-1.0.7::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/gst-plugins-good-1.0.7:1.0 required by (media-plugins/gst-plugins-vpx-1.0.7::gentoo, ebuild scheduled for merge)

sys-auth/consolekit:0

  (sys-auth/consolekit-0.4.5_p20120320-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-auth/consolekit-0.4.5_p2012[policykit] required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)

  (sys-auth/consolekit-0.4.6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-auth/consolekit-0.4.5_p20120320-r2[pam] required by (gnome-base/gdm-3.6.2-r1::gentoo, ebuild scheduled for merge)

x11-libs/pango:0

  (x11-libs/pango-1.30.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/pango-1.32.5::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/pango-1.32.2 required by (gnome-base/gnome-core-libs-3.6.2::gentoo, ebuild scheduled for merge)

x11-wm/metacity:0

  (x11-wm/metacity-2.34.13::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-wm/metacity-2.34.13 required by (gnome-base/gnome-fallback-3.6.2::gentoo, ebuild scheduled for merge)

  (x11-wm/metacity-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/vala-common:0

  (dev-libs/vala-common-0.18.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/vala-common-0.20.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/vala-common-0.20.1 required by (dev-lang/vala-0.20.1::gentoo, ebuild scheduled for merge)

virtual/udev:0

  (virtual/udev-197-r3::gentoo, ebuild scheduled for merge) pulled in by
    virtual/udev[gudev] required by (net-misc/networkmanager-0.9.6.4::gentoo, ebuild scheduled for merge)
    >=virtual/udev-197[gudev] required by (sys-power/upower-0.9.20-r2::gentoo, ebuild scheduled for merge)
    >=virtual/udev-197[gudev,hwdb] required by (sys-fs/udisks-2.1.0::gentoo, ebuild scheduled for merge)
    virtual/udev[gudev] required by (gnome-base/gnome-settings-daemon-3.6.4::gentoo, ebuild scheduled for merge)
    virtual/udev[gudev] required by (media-gfx/shotwell-0.14.1::gentoo, ebuild scheduled for merge)
    virtual/udev[gudev] required by (net-im/empathy-3.6.4::gentoo, ebuild scheduled for merge)
    virtual/udev:=[gudev] required by (x11-misc/colord-0.1.28::gentoo, ebuild scheduled for merge)
    virtual/udev[gudev] required by (dev-libs/libgusb-0.1.4::gentoo, ebuild scheduled for merge)
    >=virtual/udev-171:=[gudev] required by (media-video/cheese-3.6.2::gentoo, ebuild scheduled for merge)
    virtual/udev[gudev] required by (gnome-base/gvfs-1.14.2::gentoo, ebuild scheduled for merge)
    =virtual/udev-197-r3 required by (sys-auth/consolekit-0.4.5_p20120320-r1::gentoo, ebuild scheduled for merge)
    (and 9 more with the same problems)

  (virtual/udev-200::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/udev-200 required by (sys-auth/consolekit-0.4.6::gentoo, ebuild scheduled for merge)

dev-lang/python:2.7

  (dev-lang/python-2.7.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-2.7.5::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python:2.7[sqlite] required by (net-analyzer/nmap-6.25::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by gnome-extra/gnome-documents-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=dev-libs/libgdata-0.13.3 ~amd64
# required by gnome-base/gdm-3.6.2-r1[consolekit]
# required by gnome-base/gnome-shell-3.6.3.1
# required by gnome-extra/gnome-tweak-tool-3.6.1-r1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=sys-auth/consolekit-0.4.6 ~amd64
# required by media-video/totem-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=x11-libs/mx-1.4.7 ~amd64
# required by media-video/cheese-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=media-plugins/gst-plugins-vpx-1.0.7 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=media-sound/sound-juicer-3.5.1_pre20121231 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=gnome-extra/gnome-search-tool-3.6.0 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=gnome-extra/gnome-games-3.6.1-r1 ~amd64
# required by gnome-extra/evolution-data-server-3.6.4[gnome-online-accounts]
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=net-libs/liboauth-1.0.1 ~amd64
# required by gnome-base/gnome-core-libs-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=media-libs/gst-plugins-good-1.0.7 ~amd64
# required by gnome-base/gnome-control-center-3.6.3-r1[-systemd]
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=app-admin/openrc-settingsd-1.0.1 ~amd64
# required by dev-libs/libzeitgeist-0.3.18
# required by dev-libs/folks-0.8.0[telepathy]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-extra/zeitgeist-0.9.14 ~amd64
# required by gnome-base/gnome-shell-3.6.3.1
# required by gnome-extra/gnome-tweak-tool-3.6.1-r1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=app-accessibility/caribou-0.4.11 ~amd64
# required by dev-python/rdflib-4.0.1
# required by gnome-extra/zeitgeist-0.9.14
# required by dev-libs/libzeitgeist-0.3.18
# required by dev-libs/folks-0.8.0[telepathy]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-python/isodate-0.4.9-r1 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=app-dicts/gnome-dictionary-3.6.0 ~amd64
# required by app-misc/tracker-0.14.5[iso]
# required by gnome-base/gnome-extra-apps-3.6.2[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=sys-libs/libosinfo-0.2.7 ~amd64
# required by dev-cpp/gtkmm-3.6.0
# required by gnome-extra/gnome-system-monitor-3.6.1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=x11-libs/gdk-pixbuf-2.28.2 ~amd64
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=app-crypt/libsecret-0.15 ~amd64
# required by gnome-extra/evolution-data-server-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-util/fix-la-relink-command-0.1.1 ~amd64
# required by gnome-base/gnome-fallback-3.6.2
# required by gnome-base/gnome-3.6.2[fallback]
# required by gnome (argument)
=x11-misc/notification-daemon-0.7.6 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2[shotwell]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=media-gfx/shotwell-0.14.1 ~amd64
# required by gnome-base/gnome-3.6.2[fallback]
# required by gnome (argument)
=gnome-base/gnome-applets-3.6.0-r1 ~amd64
# required by media-gfx/shotwell-0.14.1
# required by gnome-base/gnome-extra-apps-3.6.2[shotwell]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=media-libs/gexiv2-0.6.0 ~amd64
# required by dev-lang/vala-0.20.1
# required by dev-libs/libgee-0.8.4
# required by app-misc/tracker-0.14.5[gtk]
# required by gnome-base/gnome-extra-apps-3.6.2[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=dev-libs/vala-common-0.20.1 ~amd64
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-extra/gnome-screensaver-3.6.1 ~amd64
# required by gnome-base/gnome-control-center-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-libs/libpwquality-1.2.0-r2 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=gnome-extra/gconf-editor-3.0.1-r1 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=games-board/aisleriot-3.2.3.2-r1 ~amd64
# required by dev-libs/folks-0.8.0[telepathy]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-libs/libzeitgeist-0.3.18 ~amd64
# required by gnome-base/gnome-control-center-3.6.3-r1[i18n]
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=app-i18n/ibus-1.5.2 ~amd64
# required by dev-python/rdflib-4.0.1
# required by gnome-extra/zeitgeist-0.9.14
# required by dev-libs/libzeitgeist-0.3.18
# required by dev-libs/folks-0.8.0[telepathy]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-python/html5lib-1.0_beta1 ~amd64
# required by gnome-base/gnome-3.6.2[fallback]
# required by gnome (argument)
=gnome-base/gnome-fallback-3.6.2 ~amd64
# required by dev-python/rdflib-4.0.1[berkdb]
# required by gnome-extra/zeitgeist-0.9.14
# required by dev-libs/libzeitgeist-0.3.18
# required by dev-libs/folks-0.8.0[telepathy]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-python/bsddb3-6.0.0 ~amd64
# required by gnome-base/gnome-fallback-3.6.2
# required by gnome-base/gnome-3.6.2[fallback]
# required by gnome (argument)
=x11-wm/metacity-2.34.13 ~amd64
# required by media-gfx/shotwell-0.14.1
# required by gnome-base/gnome-extra-apps-3.6.2[shotwell]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=dev-lang/vala-0.20.1 ~amd64
# required by net-im/empathy-3.6.4[geocode]
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=sci-geosciences/geocode-glib-0.99.0 ~amd64
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=gnome-extra/gcalctool-6.6.2 ~amd64
# required by sys-auth/consolekit-0.4.6[acl]
# required by gnome-base/gdm-3.6.2-r1[consolekit]
# required by gnome-base/gnome-shell-3.6.3.1
# required by gnome-extra/gnome-tweak-tool-3.6.1-r1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=virtual/udev-200 ~amd64
# required by gnome-extra/zeitgeist-0.9.14
# required by dev-libs/libzeitgeist-0.3.18
# required by dev-libs/folks-0.8.0[telepathy]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-python/rdflib-4.0.1 ~amd64
# required by gnome-base/gnome-core-libs-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-base/libgnomekbd-3.6.0 ~amd64
# required by net-libs/rest-0.7.12[gnome]
# required by net-libs/libzapojit-0.0.2
# required by gnome-extra/gnome-documents-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=net-libs/libsoup-gnome-2.40.3 ~amd64

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-misc/vinagre-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=net-libs/gtk-vnc-0.5.1 gtk3
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-base/gvfs-1.14.2 udisks cdda
# required by net-print/cups-1.6.2-r5
# required by gnome-base/gnome-control-center-3.6.3-r1[cups]
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=app-text/ghostscript-gpl-9.05-r1 cups
# required by sys-auth/polkit-0.110[-systemd]
# required by gnome-base/gnome-control-center-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=sys-auth/consolekit-0.4.5_p20120320-r1 policykit
# required by sys-auth/polkit-0.110[-systemd,pam]
# required by gnome-base/gnome-control-center-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
>=sys-auth/pambase-20120417-r2 consolekit
# required by app-text/evince-3.6.1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=app-text/poppler-0.22.2-r2 cairo
# required by dev-libs/folks-0.8.0[eds,vala]
# required by net-im/empathy-3.6.4
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-extra/evolution-data-server-3.6.4 vala
# required by app-misc/tracker-0.14.5
# required by gnome-base/gnome-extra-apps-3.6.2[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=media-gfx/imagemagick-6.7.8.7 png jpeg
# required by gnome-base/gnome-core-apps-3.6.2[networkmanager]
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-extra/nm-applet-0.9.6.4-r1 bluetooth
# required by virtual/udev-200
# required by sys-auth/consolekit-0.4.6[acl]
# required by gnome-base/gdm-3.6.2-r1[consolekit]
# required by gnome-base/gnome-shell-3.6.3.1
# required by gnome-extra/gnome-tweak-tool-3.6.1-r1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=sys-fs/udev-204 gudev hwdb
# required by gnome-extra/gnome-contacts-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=dev-libs/folks-0.8.0 eds vala
# required by media-gfx/eog-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=x11-libs/gdk-pixbuf-2.26.4 jpeg
# required by net-analyzer/nmap-6.25[gtk,-ndiff]
# required by net-analyzer/gnome-nettool-3.2.0
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=dev-lang/python-2.7.5 sqlite
# required by sys-fs/udisks-2.1.0
# required by gnome-base/gvfs-1.14.2[udisks]
# required by gnome-base/gnome-core-libs-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=virtual/udev-197-r3 gudev hwdb
# required by gnome-base/gnome-control-center-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=gnome-base/gnome-settings-daemon-3.6.4 policykit
# required by media-video/cheese-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
=media-libs/gst-plugins-base-1.0.5-r2 theora
# required by gnome-base/gnome-shell-3.6.3.1[i18n]
# required by gnome-extra/gnome-tweak-tool-3.6.1-r1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by gnome (argument)
>=app-i18n/ibus-1.5.2 dconf
# required by media-sound/pulseaudio-2.1-r1[udev]
# required by gnome-base/gnome-control-center-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
>=virtual/udev-200 hwdb
# required by media-gfx/eog-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
>=x11-libs/gdk-pixbuf-2.28.2 jpeg
# required by media-sound/pulseaudio-2.1-r1[alsa]
# required by gnome-base/gnome-control-center-3.6.3-r1
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by gnome (argument)
=media-plugins/alsa-plugins-1.0.26 pulseaudio



How can I know which package select for each slot?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Jul 23, 2013 6:15 pm    Post subject: Reply with quote

You'll need to remove any Gnome package you installed prior to this first, otherwise it will try to get Gnome 2 and Gnome 3 to be simultaneously on your system; that causes some unnecessary conflicts.

After doing it again, you need to add all the packages listed at the bottom of your output to /etc/portage/package.accept_keywords/accept_keywords (those with ~amd64) and /etc/portage/package.use (those with USE flags). After which you can emerge again.

If you don't want to manually copy them, you can add --autounmask-write to the end of the emerge command; then after it gives that output again, you can run `dispatch-conf` or `etc-update` which will help you update the config for you.

Mixing stable and ~ is a tricky thing to do, the dependency tree of Gnome pulls in a lot of packages into ~ and might conflict against some stable versions, and as far as I know nobody is maintaining a list of which packages to accept keywords for anymore; if you have too much problems with this, consider to go for the ACCEPT_KEYWORDS approach instead. If you do so, make sure to undo the above changes you did. A lot of people run this without much problems; I run ~ for a year, you're 30 days less stable but you're still on the same level of what upstream considers as stable. Problems are dealt with or masked, experimental code is not keyworded with anything; so, while it is 30 days less stable, it's not that you can't run it at all.

Agreed though, this shouldn't be necessary; I hope we can see stabilization of Gnome 3.* in the future. Maybe, as a Gnome user myself; I'll try to help them out in the near future, they seem undermanned.

Quote:
How can I know which package select for each slot?


The output above what you pasted does; always consider the full output, and not a part of it. The slot conflicts are not necessarily a problem.

On a side note, if you pass --tree --unordered-display to emerge you get a neat indented overview tree to see which packages depend on which ones.
Back to top
View user's profile Send private message
aleixrocks
n00b
n00b


Joined: 22 Jul 2013
Posts: 11

PostPosted: Tue Jul 23, 2013 6:47 pm    Post subject: Reply with quote

I'm on a fresh install of gentoo, so I don't have any desktop environment (sorry for the lack of information). Therefore, for solving the problem:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


What shoud I do? I should do something or just go ahead?

I understand now how to solve the USE and KEYWORD problems using --autounmask-write. Thank you!

I would try to use the unstable branch then. Thank you!
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Jul 23, 2013 7:22 pm    Post subject: Reply with quote

aleixrocks wrote:
I'm on a fresh install of gentoo, so I don't have any desktop environment (sorry for the lack of information). Therefore, for solving the problem:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


What shoud I do? I should do something or just go ahead?


Just go ahead and emerge; only if you are stuck, then feel free to paste the full emerge output. If the same thing is listed as a slot conflict for a very long time, as in more than two weeks; you might want to file a bug about the slot conflict, but usually those resolve themselves as versions get bumped or slot corrections get made...
Back to top
View user's profile Send private message
aleixrocks
n00b
n00b


Joined: 22 Jul 2013
Posts: 11

PostPosted: Mon Jul 29, 2013 2:56 pm    Post subject: Reply with quote

I finally installed gnome 3.6 using --backtrack=30. Without it, I couldn't emerge it due to slots conflict. It started normally, but one time each a couple of hours it breaks with a kernel panic message. So finally, I unmerged it, and installed gnome 2. Now gnome 2 seems stable.

Thank you anyway for all your help TomWij!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum