Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Neither eth0 nor wlan0 works
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
athena810
Apprentice
Apprentice


Joined: 23 Jun 2012
Posts: 176

PostPosted: Mon Jul 22, 2013 1:15 am    Post subject: Neither eth0 nor wlan0 works Reply with quote

Hey,
I recompiled my kernel a week ago after including r8169 or something. Then, neither eth0 nor wlan0 worked and ifconfig -a returns only gre0, lo, and sit0. I recompiled again and removed the r8169 module and still neither eth0 nor wlan0 worked. When I try to /etc/init.d/net.<et0/wlan0> start, I get a
Code:

ERROR: interface <wlan0/eth0> does not exist
Ensure that you have loaded the correct kernel module for your hardware.


I didn't change anything really so I'm pretty sure all my kernel modules are there. I'm also unable to modprobe my ethernet or wireless modules. I get a
Code:

FATAL: Error inserting rt2800pci: Unknown symbol in module or unknown parameter (see dmesg).


The end of dmesg says:
Code:

rt2800lib: Unknwon symbol crc_ccitt (err 0)
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6972
Location: Saint Amant, Acadiana

PostPosted: Mon Jul 22, 2013 1:41 am    Post subject: Reply with quote

Quote:
FATAL: Error inserting rt2800pci: Unknown symbol in module or unknown parameter (see dmesg)
You get this when you are trying to insert modules into a wrong kernel. You are supposed to run the same kernel the modules are compiled for.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
athena810
Apprentice
Apprentice


Joined: 23 Jun 2012
Posts: 176

PostPosted: Mon Jul 22, 2013 1:44 am    Post subject: Reply with quote

How can i fix this?
uname -r returns 3.3.8-gentoo
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6972
Location: Saint Amant, Acadiana

PostPosted: Mon Jul 22, 2013 1:49 am    Post subject: Reply with quote

Try uname -a and make sure the time and date are correct.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
athena810
Apprentice
Apprentice


Joined: 23 Jun 2012
Posts: 176

PostPosted: Mon Jul 22, 2013 2:50 am    Post subject: Reply with quote

I'm not sure about the date or uname -a.I chrooted then ran emerge --sync
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13511

PostPosted: Mon Jul 22, 2013 3:14 am    Post subject: Reply with quote

3.3.8-gentoo is very outdated. Are you sure that is the kernel you mean to be running?
Back to top
View user's profile Send private message
athena810
Apprentice
Apprentice


Joined: 23 Jun 2012
Posts: 176

PostPosted: Mon Jul 22, 2013 4:22 am    Post subject: Reply with quote

Yep, I'm sure.
I was told by a guy on the IRCs to run
emerge -ajv sys-kernel/gentoo-sources

I did, and I had a problem with two conflicting packages and it told me to use package.mask.
One of the packages is not required by anything so I think I should package.mask that one but I don't know how.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6972
Location: Saint Amant, Acadiana

PostPosted: Tue Jul 23, 2013 12:16 am    Post subject: Reply with quote

3.3.8 is even not in portage any more. You should bring your portage up to date and make sure nothing in your system is outdated. Gentoo is a rolling distro after all.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum