Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How do you test if NVIDIA Optimus switching? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
hfk22
n00b
n00b


Joined: 02 Dec 2013
Posts: 15

PostPosted: Fri Oct 24, 2014 7:50 pm    Post subject: How do you test if NVIDIA Optimus switching? [SOLVED] Reply with quote

Hi,
Following the wiki:

http://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops

and the forum post:

https://forums.gentoo.org/viewtopic-t-959568-postdays-0-postorder-asc-start-0.html

I now have graphics on my laptop. As a note, I need to add "intel nvidia modesetting" to VIDEO_CARDS in make.conf. At the same time, how do you test if the graphics cards switching between the NVIDIA and Intel card is working? When I run glxgears, I see about 17000-19000 FPS, so I figure the NVIDIA piece is working. But, again, how can I tell if the Intel piece turns on?


Last edited by hfk22 on Fri Oct 31, 2014 5:33 am; edited 1 time in total
Back to top
View user's profile Send private message
tw04l124
Veteran
Veteran


Joined: 03 Oct 2006
Posts: 1927
Location: A t z e l, lower austria

PostPosted: Wed Oct 29, 2014 8:07 am    Post subject: Reply with quote

i would not trust glxgears at all, afaik it runs at 60 fps if possible.

glxinfo ...

have you checked what nvidia-settings shows you?

if you really want to verfiy it you need to measure the power consumption of your hardware. you should see a difference but that needs external testing setup.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4816

PostPosted: Wed Oct 29, 2014 8:53 am    Post subject: Reply with quote

In theory : with 2D the intel is at work, and with 3D the nvidia is at work.
I don't know howto see the intel at work, but i know how to see the nvidia at work, so you can guess per default when the nvidia isn't working the intel is doing it.
You can see gpu utilization, memory and bus utilization of an nvidia card in nvidia settings GUI (something i suppose the command line can output too if you wish). Look at the GPU section to check them.
On desktop with composite enable, the nvidia should always be at work.
And you can also do glxgears -info that will output at first line the card name in use.

ps: glxgears doesn't run if possible at 60fps, but at your screen refresh rate and only if Sync to VBlank is enable.
Back to top
View user's profile Send private message
hfk22
n00b
n00b


Joined: 02 Dec 2013
Posts: 15

PostPosted: Fri Oct 31, 2014 5:32 am    Post subject: Reply with quote

Good call. Under nvidia-settings, there's a section titled:
Code:

GPU 0 (GeForce GTX 860M)


Under the Graphics Card Information, there's a piece labelled GPU Utilization. On simple window manager, this is 0%. When I run glxgears, it hits 93%. As such, it looks like it's switching back and forth. Thanks for the idea!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum