Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issues with rtorrentd starting
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 03 Aug 2012
Posts: 1

PostPosted: Fri Aug 03, 2012 8:29 pm    Post subject: Issues with rtorrentd starting Reply with quote

Just recently setup my Gentoo box and was going to use rtorrent + rutorrent as a torrenting solution however I seem to be running into some strange issues with rtorrent.

When I first emerged it I ran it as root to check it out and see how it worked, and it worked fine there, but then I read that the recommended practice is to run it under a non-root user so I created a user named rtorrentd, stopped rtorrent and moved my .rtorrent.rc file to the new user's directory. Then I edited my /etc/conf.d/rtorrentd file to specify the new user and then tried to restart the daemon. It restarted without displaying any errors but does not attach to any screen for me to access. If I try and restart the daemon it outputs the following:
 * Stopping rtorrent ...
 * start-stop-daemon: no matching processes found                                                                     [ ok ]
 * Starting rtorrent ...                                                                                                                [ ok ]

And still has no screen session to attach to. There's also no rtorrent process anywhere on my machine and switching the execution back to starting under root did not help either, it exhibits the same behavior.

Can anyone help me or at least offer some suggestions on where to start trying to troubleshoot these issues.
Back to top
View user's profile Send private message

Joined: 17 Jan 2004
Posts: 531
Location: Budapest/Hungary

PostPosted: Sun Aug 05, 2012 11:11 am    Post subject: Reply with quote

Not sure if this helps (feel free to tell me that it didn't ;-))
I gave up on running rtorrentd as a daemon back a while ago, using the following instead:
#su -c "screen -sDm rtorrent rtorrent" myuser

No trouble from this point on ;-)
Back to top
View user's profile Send private message

Joined: 04 Oct 2010
Posts: 6

PostPosted: Wed Jul 17, 2013 8:23 pm    Post subject: Solved! Reply with quote

Reviving this thread because it came up in google searches and wasn't any help.

I ran into this issue, rewriting the init script a bajillion times, thinking something must have changed in any of GNU Screen, rtorrent, and start-stop-daemon.

The embarrassing reality was that rtorrent was simply misconfigured for daemonizing. In .rtorrent.rc I had relative path names because the example path name was like the following:


# Default session directory. Make sure you don't run multiple instance
# of rtorrent using the same session directory. Perhaps using a
# relative path?
#session = ./session

rtorrent chokes because the working directory is not the home directory, and it could not find ~/session.

The cleanest fix for me was to change ./session to ~/session in rtorrent.rc. I was able to use the init script after that. I sure wish I didn't spend three hours trying to track this down.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum