Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No hadphone output with ALSA and no card shaing.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Jinx Adnix
n00b
n00b


Joined: 12 Apr 2015
Posts: 3

PostPosted: Mon Apr 13, 2015 1:01 am    Post subject: No hadphone output with ALSA and no card shaing. Reply with quote

OK... I don't know why but ALSA stopped having programs share my sound and now I can't get my headphones to output any sound.

And yes, I looked at the Wiki and did that it said.

Any ideas?

UPDATE: I removed Pulseaudio and it seems to have fixed the card sharing problem. Why do we even keep that project anyway?

UPDATE: I can get sound to play if I mute the speakers, but doing so has the speaker volume control my headphones and makes the sound super week.
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1523
Location: Switzerland (Romandie)

PostPosted: Mon Apr 13, 2015 7:16 pm    Post subject: Reply with quote

For pulseaudio, that's a long story. Some freedesktop.org guys are thinking the linux audio guys (on the LAD email list) are desktop haters, that when we almost all, if not all, are running some kind of desktop. Some are even running gnome or kde.

Anyway, pulseaudio is 1) much more complicated to manage than jack-audio-connection-kit, and 2) is unusable for pro audio because its latency is not constant and will augment at the first xrun. And 3) you can archive full duplex compatibility between the ALSA applications and JACK with the jack pcm plugin. That imply than, from my perspective as a musician using a linux desktop to make music, pulseaudio is unusable and at best a waste of time for the free desktop programmers. It would have been much better to improve ALSA, which was done by the ALSA guys with the JACK pcm plugin. But they seam to like pulseaudio, so that's not a problem for me: USE="-pulseaudio" in make.conf (I don't use gnome anyway, so I don't care).

For your sound issue, you must be much more specific and tell us things like what is your sound card, you sound config in the kernel, any dmesg sound related error message, etc. Also, if you have a ~/.asoundrc, it can be a good thing to rename it and try again. Last but not least, as you explain your issue, it look like your hardware/driver are working and this is a misconfigured mixer setting (you get sound but very low), it can be good to use alsamixer, it is not sexy but you are sure with it that the sound controls correspond to the hardware loaded by the kernel.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
Jinx Adnix
n00b
n00b


Joined: 12 Apr 2015
Posts: 3

PostPosted: Mon Apr 13, 2015 9:16 pm    Post subject: Reply with quote

I was be rhetorical but ya, that figures.

Anyway, I assume you need this file but I don't know where the others would be.

https://bpaste.net/show/9872a3d0ecfb

Also don't have a ~/.asoundrc file.
Back to top
View user's profile Send private message
Jinx Adnix
n00b
n00b


Joined: 12 Apr 2015
Posts: 3

PostPosted: Tue Apr 14, 2015 12:28 am    Post subject: Reply with quote

And now it's working... Turns out I just needed to disable Independent HP.

>_>
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum