Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mplayer, shortcut, change input.conf doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Fdhvdu
n00b
n00b


Joined: 03 Mar 2015
Posts: 10

PostPosted: Tue Apr 14, 2015 9:10 pm    Post subject: mplayer, shortcut, change input.conf doesn't work Reply with quote

Hi, I want to watch movie today.
However, I find the shortcut that I have modified doesn't work.

My /etc/mplayer/input.conf
Quote:
RIGHT seek +3
LEFT seek -3
DOWN volume -1
UP volume 1
m mute
ESC quit
SPACE pause
f vo_fullscreen
s screenshot

According to man page of mplayer, I copy this to ~/.mplayer/input.conf.
But when I use
Quote:
mplayer The\ Imitation\ Game.mkv

The seek time of RIGHT is 10 instead of 3.
(This is default setting.)

Ok. So, I use
Quote:
mplayer -input conf=$HOME/.mplayer/input.conf The\ Imitation\ Game.mkv

The seek time of RIGHT still remain 10.

What's going on?


Something another I need to say.
I watch movies last week, and I didn't copy /etc/mplayer/input.conf to ~/.mplayer/input.conf.
I merely use
Quote:
mplayer Taken\ 3.mkv

Everything is fine, include seek time with 3 seconds.
But I don't know why mplayer doesn't work properly, maybe the reason is I installed media-video/vlc?


Last edited by Fdhvdu on Thu Apr 16, 2015 1:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
EmaRsk
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2004
Posts: 101
Location: Italy

PostPosted: Wed Apr 15, 2015 3:20 pm    Post subject: Reply with quote

Please could you stop using silly colour/font formatting? It's annoying.

Now, re you saying that with one video seek is 3s and with another it's 10s? Then you already have the answer: the settings are read correctly, but the particular combination of encoding settings for that video doesn't allow the decoder to reliably jump less than 10s.
Vlc can't have anything to do with this, anyway.
Back to top
View user's profile Send private message
Fdhvdu
n00b
n00b


Joined: 03 Mar 2015
Posts: 10

PostPosted: Thu Apr 16, 2015 1:00 pm    Post subject: Reply with quote

Sorry about that, I just want to mark the points. :(

Also, the settings doesn't load correctly.
On 4/8, I didn't copy /etc/mplayer/input.conf to ~/.mplayer/input.conf.
I merely used /etc/mplayer/input.conf directly, and it worked pretty good when I watched movie.
At that time, the seek time was 3.
(Forget the two different movie, both of then have same seek time. Taken 3 has same behavior as The Imitation Game.)

Somehow, when I watched movie on 4/14, the seek time changed.
It become 10.
But I don't change /etc/mplayer/input.conf.

(Even though I make it empty, the seek time is 10. 10 is default seek time in mplayer.
Not only seek time but also full of other settings work in default.)

According to man page, I
Quote:
cp /etc/mplayer/input.conf $HOME/.mplayer/input.conf

It is still not working.

So I come here to ask the question, hope someone could help me.
Back to top
View user's profile Send private message
EmaRsk
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2004
Posts: 101
Location: Italy

PostPosted: Thu Apr 16, 2015 6:48 pm    Post subject: Reply with quote

Try to set it bigger and see if it works. For me, setting it to 2 gives me skips of 5s, but setting it to 20 gives skips of 20s as it should.

From my understanding (which could be utterly wrong) I think that mplayer can only seek to a keyframe. If in your videos you have a keyframe every 10s, that is the minimum seek time.
Back to top
View user's profile Send private message
EmaRsk
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2004
Posts: 101
Location: Italy

PostPosted: Thu Apr 16, 2015 6:54 pm    Post subject: Reply with quote

It's the same with mpv, but mpv has a "--hr-seek=yes" option to enable more precise inter-keyframe seeking.
I don't think mplayer has a similar option, I didn't find any in the manual.
Back to top
View user's profile Send private message
Fdhvdu
n00b
n00b


Joined: 03 Mar 2015
Posts: 10

PostPosted: Thu Apr 16, 2015 11:06 pm    Post subject: Reply with quote

It's like what you say, if I change the seek time higher than 10, it will work correctly.
But it's strange..., why do I could have 3 seek time on 4/8?
(Even though I watch that movie with 3 seek time now, it still work in 10.
But with higher seek time than 10, it works great.
Something must changed, but I don't know what is that.)

Thank you for replying. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum