Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[closed]backing up a version
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jk121960
n00b
n00b


Joined: 25 Jan 2010
Posts: 74
Location: Palos Hills, Illinois

PostPosted: Tue Jul 02, 2013 11:28 pm    Post subject: [closed]backing up a version Reply with quote

Hi, I need to rollback a version of dev-libs/uci to dev-libs/icu-50.1.2 I went up to the site and matched the package version but it keeps telling me it is not a valid package atom?

The code I am executing is:
emerge -aqv dev-libs/icu-50.1.2

I get back:

dev-libs/icu-50.1.2' is not a valid package atom.

Can someone tell me what I am doing wrong?

thanks for any help

--jerry


Last edited by jk121960 on Mon Aug 12, 2013 8:26 am; edited 1 time in total
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1266

PostPosted: Tue Jul 02, 2013 11:35 pm    Post subject: Reply with quote

Your missing the equals sign. Use emerge -aqv =dev-libs/icu-50.1.2
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7403
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Jul 02, 2013 11:35 pm    Post subject: Reply with quote

Yep. With emerge, a versioned package atom must be preceded by a comparison operator, like so:
Code:
emerge -aqv =dev-libs/icu-50.1.2
Edit: Too slow. ;)

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
jk121960
n00b
n00b


Joined: 25 Jan 2010
Posts: 74
Location: Palos Hills, Illinois

PostPosted: Wed Jul 03, 2013 12:28 am    Post subject: Reply with quote

Ok tht worked to get me to a point, but now it iswailing about deps. Just to fill you in I need to do this to get vmware-layer working according to the posts. So now it is telling me this:
[ebuild UD] dev-libs/icu-50.1.2 [51.1] USE="-debug -doc -examples -static-libs"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

(dev-libs/icu-51.1::gentoo, installed) pulled in by
dev-libs/icu:0/51.1= required by (dev-libs/libxml2-2.9.0-r2::gentoo, installed)
>=dev-libs/icu-49.1.1-r1:0/51.1= required by (www-client/chromium-27.0.1453.110::gentoo, installed)
dev-libs/icu:0/51.1= required by (media-libs/harfbuzz-0.9.12::gentoo, installed)

(dev-libs/icu-50.1.2::gentoo, ebuild scheduled for merge) pulled in by
=dev-libs/icu-50.1.2

what would be the best way to go about continuing this. Can I force it, we are only talking about a minor version difference.?

I appreciate you help

--jerry
Back to top
View user's profile Send private message
jk121960
n00b
n00b


Joined: 25 Jan 2010
Posts: 74
Location: Palos Hills, Illinois

PostPosted: Mon Aug 12, 2013 8:28 am    Post subject: Reply with quote

Never got this fixed, I can only use windows vm's that are UTF-8, -> windows 8 and server 2012
Back to top
View user's profile Send private message
Freeky
n00b
n00b


Joined: 11 Mar 2011
Posts: 63
Location: Novosibirsk, Russia

PostPosted: Mon Aug 12, 2013 1:09 pm    Post subject: Reply with quote

You have some packages which require old dev-libs/icu.
Updating of dev-libs/icu is impossible without upgrading other packages.
It should help you
Code:
emerge -1av dev-libs/icu dev-libs/libxml2 www-client/chromium media-libs/harfbuzz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum