Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Questions about UVD [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
rudregues
Apprentice
Apprentice


Joined: 29 Jan 2013
Posts: 192

PostPosted: Tue Jul 02, 2013 8:29 pm    Post subject: Questions about UVD [SOLVED] Reply with quote

Hey guys, I've just installed kernel 3.9.2 in gentoo-sources and now I've the uvd firmwares in my /lib64/firmware/radeon directory. Then, I installed radeon-ucode but I don't know if uvd is set or not. But I have some questions:

1) The wiki doesn't explain how to enable uvd or if it comes by default just installing radeon driver http://wiki.gentoo.org/wiki/Radeon

2) I have a 6310m radeon card, so I suppose my UVD will be UVD 3, it really has the features listed in wikipedia? http://en.wikipedia.org/wiki/Unified_Video_Decoder

3) When it says "UVD is compatible with MPEG2/H.264/VC-1 DivX and Xvid" means that I can use that feature with which type of videos? (.avi, .flv, .mpg, .mp4 etc)

4) If UVD is enabled in my system, I must set some special configuration to mplayer, vlc, firefox etc to use this?

It would be good to put some material in the wiki or gentoo docs about UVD (using it with radeon, compile programs with support etc).
_________________
Emerging en gentoo


Last edited by rudregues on Thu Jul 04, 2013 11:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4895

PostPosted: Wed Jul 03, 2013 5:53 am    Post subject: Re: Questions about UVD Reply with quote

rudregues wrote:
Hey guys, I've just installed kernel 3.9.2 in gentoo-sources and now I've the uvd firmwares in my /lib64/firmware/radeon directory. Then, I installed radeon-ucode but I don't know if uvd is set or not. But I have some questions:

1) The wiki doesn't explain how to enable uvd or if it comes by default just installing radeon driver http://wiki.gentoo.org/wiki/Radeon

2) I have a 6310m radeon card, so I suppose my UVD will be UVD 3, it really has the features listed in wikipedia? http://en.wikipedia.org/wiki/Unified_Video_Decoder

3) When it says "UVD is compatible with MPEG2/H.264/VC-1 DivX and Xvid" means that I can use that feature with which type of videos? (.avi, .flv, .mpg, .mp4 etc)

4) If UVD is enabled in my system, I must set some special configuration to mplayer, vlc, firefox etc to use this?

It would be good to put some material in the wiki or gentoo docs about UVD (using it with radeon, compile programs with support etc).


for uvd you need 2 things, kernel support and userspace suport, I cannot find 3.9.2 anywhere so I cannot say if it includes the uvd patch, the latest 3.9.x should support uvd.
assuming you have the fw files, you need the right version of mesa (9.2_pre20130404). assuming you have that, you need to enable the vdpau flag, rebuild all pkgs and uvd should be
supported.

anyway, just check this page (simple google search)
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
rudregues
Apprentice
Apprentice


Joined: 29 Jan 2013
Posts: 192

PostPosted: Wed Jul 03, 2013 7:58 pm    Post subject: Reply with quote

Thanks DaggyStyle, with your explanation and the link you posted now I have UVD enabled (dmesg | grep UVD shows it after reboot).


But one question remains: about which type/format of videos UVD can take advantage (.avi, .flv, .mpg, .mp4, .rmvb, html5 etc) ?
_________________
Emerging en gentoo
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1561
Location: Berlin, Germany

PostPosted: Wed Jul 03, 2013 11:34 pm    Post subject: Reply with quote

You need the package.mask'ed mesa-9.2 snapshots built with USE=vdpau in order to use UVD.
vdpauinfo will then list the supported video codecs:
Code:
$ vdpauinfo

Decoder capabilities:

name               level macbs width height
-------------------------------------------
MPEG1                16  9216  2048  1152
MPEG2_SIMPLE         16  9216  2048  1152
MPEG2_MAIN           16  9216  2048  1152
H264_BASELINE        16  9216  2048  1152
H264_MAIN            16  9216  2048  1152
H264_HIGH            16  9216  2048  1152
VC1_SIMPLE           16  9216  2048  1152
VC1_MAIN             16  9216  2048  1152
VC1_ADVANCED         16  9216  2048  1152
MPEG4_PART2_SP       16  9216  2048  1152
MPEG4_PART2_ASP      16  9216  2048  1152
Back to top
View user's profile Send private message
rudregues
Apprentice
Apprentice


Joined: 29 Jan 2013
Posts: 192

PostPosted: Thu Jul 04, 2013 11:09 pm    Post subject: Reply with quote

It seems that firefox adds just fglrx and nvidia driver to it`s whitelist, so to activate the hardware accelaration in the browser it`s needed to force some parameters in about:config source: https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_X11

Well, now I have accelaration in my system and in my browser. Solved.
_________________
Emerging en gentoo
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1561
Location: Berlin, Germany

PostPosted: Fri Jul 05, 2013 1:14 am    Post subject: Reply with quote

That is only for OpenGL acceleration, not video decode acceleration.
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Fri Jul 05, 2013 2:54 am    Post subject: Reply with quote

Also the open source radeon driver is supported in Firefox with WebGL. It's whitelisted as a Mesa driver since 7.10.3, and it's enabled by selecting, "Use hardware acceleration when available", under Preferences -> Advanced. I tested this at this site and it's working on my system without any config tweaks.

And while WebGL is enabled, I did notice that GL layers acceleration isn't enabled yet. So after testing my current FPS at this site, I noticed I could slightly improve the FPS rate, by enabling GL layers acceleration by setting layers.acceleration.force-enabled=true in about:config.

Good Luck..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum