Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solved)X crashes when changing to tty or terminating Xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
chessmaster
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2013
Posts: 75

PostPosted: Mon Jul 01, 2013 6:24 pm    Post subject: (Solved)X crashes when changing to tty or terminating Xorg Reply with quote

I have the fglrx drivers installed with my xorg-x11 and I'm getting black screens when switching to a tty terminal or when terminating my session to return to my non-interactive shell.
_________________
http://www.morphos.de/


Last edited by chessmaster on Mon Jul 01, 2013 7:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
chessmaster
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2013
Posts: 75

PostPosted: Mon Jul 01, 2013 6:28 pm    Post subject: Re: X crashes when changing to tty or terminating Xorg Reply with quote

chessmaster wrote:
I have the fglrx drivers installed with my xorg-x11 and I'm getting black screens when switching to a tty terminal or when terminating my session to return to my non-interactive shell.

I have also disabled nomodeset at kernel line

Code:

[   114.892]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[   114.893] X Protocol Version 11, Revision 0
[   114.893] Build Operating System: Linux 3.9.8-gentoo x86_64 Gentoo
[   114.893] Current Operating System: Linux Neptune 3.9.8-gentoo #22 SMP Mon Jul 1 12:36:09 EDT 2013 x86_64
[   114.893] Kernel command line: BOOT_IMAGE=/vmlinuz-3.9.8 root=/dev/sdb2 ro splash quiet nomodeset
[   114.893] Build Date: 01 July 2013  12:14:45AM
[   114.893] 
[   114.893] Current version of pixman: 0.28.0
[   114.894]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   114.894] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   114.895] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  1 14:21:35 2013
[   114.922] (==) Using config file: "/etc/X11/xorg.conf"
[   114.922] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   114.942] (==) ServerLayout "aticonfig Layout"
[   114.942] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   114.942] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   114.942] (**) |   |-->Device "aticonfig-Device[0]-0"
[   114.942] (==) Automatically adding devices
[   114.942] (==) Automatically enabling devices
[   114.942] (==) Automatically adding GPU devices
[   114.972] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/OTF/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
[   114.972] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   114.972] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   114.976] (II) Loader magic: 0x80cbe0
[   114.976] (II) Module ABI versions:
[   114.976]    X.Org ANSI C Emulation: 0.4
[   114.976]    X.Org Video Driver: 13.1
[   114.976]    X.Org XInput driver : 18.0
[   114.976]    X.Org Server Extension : 7.0
[   114.976] (--) PCI:*(0:1:0:0) 1002:683d:1462:2710 rev 0, Mem @ 0xd0000000/268435456, 0xfeb80000/262144, I/O @ 0x0000d000/256, BIOS @ 0x????????/131072
[   114.976] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   114.977] Initializing built-in extension Generic Event Extension
[   114.977] Initializing built-in extension SHAPE
[   114.977] Initializing built-in extension MIT-SHM
[   114.977] Initializing built-in extension XInputExtension
[   114.977] Initializing built-in extension XTEST
[   114.977] Initializing built-in extension BIG-REQUESTS
[   114.977] Initializing built-in extension SYNC
[   114.977] Initializing built-in extension XKEYBOARD
[   114.978] Initializing built-in extension XC-MISC
[   114.978] Initializing built-in extension XINERAMA

_________________
http://www.morphos.de/
Back to top
View user's profile Send private message
chessmaster
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2013
Posts: 75

PostPosted: Mon Jul 01, 2013 7:24 pm    Post subject: Reply with quote

enabling

Code:
options fglrx modeset=0

fix the problem but the module is not reloaded when X is restarted doing a lsmod it's missing

going to submit a bug on this
_________________
http://www.morphos.de/
Back to top
View user's profile Send private message
chessmaster
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2013
Posts: 75

PostPosted: Tue Jul 02, 2013 11:58 pm    Post subject: Reply with quote

Switching from X session to TTYs gives blank screen

Workaround for this "feature", which appeared in catalyst 13.2 betas, is to use vga= kernel option, like vga=792. You can get the list of supported resolutions with

hwinfo --framebuffer

command. Pick up the one from the very bottom, and copy-paste it into kernel line of your bootloader, so it could look like ie. vga=0x03d4

Worked for me as well.
_________________
http://www.morphos.de/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum