Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solved)ATI SB7x0/SB8x0/SB9x0 IDE controller
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Sat Jun 29, 2013 12:08 pm    Post subject: (Solved)ATI SB7x0/SB8x0/SB9x0 IDE controller Reply with quote

:D


I have a hard drive the one mention in subject that will not boot up all night. lspci -k gives me back:
Code:

PATA_ATIIXP
PATA_ACPI
ATA_GENERIC

Code:
00:11.0 IDE interface: Advance Micro Device[AMD] /SB7x0/SB8x0/SB9x0 SATA Controller [IDE Controller]
 Now it's in IDE mode which I have tryed both AHCI and IDE with my hard drive bios. enabling the loaded drivers comes up with nothing but failed attempts with the kernel panics with the "unable to mount root fs 8,18 message"
Anyone has this hard drive and had any success with it.


Is there a IDE controller .config I'm missing?


Last edited by chessmaster on Tue Jul 02, 2013 11:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
j_c_p
Apprentice
Apprentice


Joined: 30 Aug 2003
Posts: 296
Location: France - Colmar

PostPosted: Sat Jun 29, 2013 12:16 pm    Post subject: Reply with quote

Code:
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD780 Host Bridge
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] RD780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RX780/RD790 PCI to PCI bridge (external gfx0 port A)
        Kernel driver in use: pcieport
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD790 PCI to PCI bridge (PCI express gpp port F)
        Kernel driver in use: pcieport
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
        Subsystem: Gigabyte Technology Co., Ltd Device b002
        Kernel driver in use: ahci
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ohci_hcd
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ohci_hcd
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ehci-pci
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ohci_hcd
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ohci_hcd
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ehci-pci
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3a)
        Subsystem: Gigabyte Technology Co., Ltd GA-MA770-DS3rev2.0 Motherboard
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5002
        Kernel driver in use: pata_atiixp
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
        Subsystem: Gigabyte Technology Co., Ltd Device 5004
        Kernel driver in use: ohci_hcd                                                                                                                                   
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration                                                               
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: NVIDIA Corporation GT200 [GeForce GTX 260] (rev a1)
        Subsystem: Micro-Star International Co., Ltd. Device 1771
        Kernel driver in use: nvidia
        Kernel modules: nvidia
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 02)
        Subsystem: Gigabyte Technology Co., Ltd Motherboard
        Kernel driver in use: r8169
03:06.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
        Subsystem: VIA Technologies Inc. M-Audio Delta Audiophile 2496
        Kernel driver in use: snd_ice1712
        Kernel modules: snd_ice1712
03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
        Subsystem: Gigabyte Technology Co., Ltd Motherboard

_________________
Lian Li PC60 - AMD Phenom II X6 1100T BE - Asrock 990FX EXTREME9 - MSI 260GTX+ - M-Audio Delta Audiophile 24/96
Kernel 3.12.5 KDE 4.11.4 GCC 4.8.2 x86_64 12/14/2013
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31341
Location: 56N 3W

PostPosted: Sat Jun 29, 2013 12:23 pm    Post subject: Reply with quote

chessmaster,

Its PATA_ATIXP you need and its not affected by your BIOS IDE/AHCI setting.

As your panic includes 8,18, which is sdb2, is that really your root fs ?

If your HDD is SATA, not PATA ... connected with a narrow cable, not a 40/80 wire ribbon, set your BIOS to AHCI mode and enable AHCI and Platform AHCI in the kernel.
Its also possible that the filesystem driver for your root filesystem is missing from your kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
j_c_p
Apprentice
Apprentice


Joined: 30 Aug 2003
Posts: 296
Location: France - Colmar

PostPosted: Sat Jun 29, 2013 12:44 pm    Post subject: Reply with quote

Here is my 3.9.8 kernel .config if it can help -> http://www.sendspace.com/file/qjz388
_________________
Lian Li PC60 - AMD Phenom II X6 1100T BE - Asrock 990FX EXTREME9 - MSI 260GTX+ - M-Audio Delta Audiophile 24/96
Kernel 3.12.5 KDE 4.11.4 GCC 4.8.2 x86_64 12/14/2013
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Sat Jun 29, 2013 6:26 pm    Post subject: Reply with quote

NeddySeagoon wrote:
chessmaster,

Its PATA_ATIXP you need and its not affected by your BIOS IDE/AHCI setting.

As your panic includes 8,18, which is sdb2, is that really your root fs ?

If your HDD is SATA, not PATA ... connected with a narrow cable, not a 40/80 wire ribbon, set your BIOS to AHCI mode and enable AHCI and Platform AHCI in the kernel.
Its also possible that the filesystem driver for your root filesystem is missing from your kernel.


here is my

lspci
http://pastebin.com/WUcf8tHB

.config
http://pastebin.com/J2ckQp2Y


I was up all night doing this just to test to see if it works I activated everything in my .config previous to this one in the SATA section and SCSI and it booted up.
Code:

00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller
        Subsystem: ASUSTeK Computer Inc. Device 8389
        Kernel driver in use: pata_atiixp


Code:

CONFIG_PATA_ATIIXP=y



Very confusing as I have everything enabled
Code:

CONFIG_SATA_AHCI=y


Last edited by chessmaster on Sat Jun 29, 2013 7:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Sat Jun 29, 2013 6:29 pm    Post subject: Reply with quote

j_c_p wrote:
Here is my 3.9.8 kernel .config if it can help -> http://www.sendspace.com/file/qjz388


Thank you for sharing your .config I will try to see if I'm missing something.....
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Sat Jun 29, 2013 7:15 pm    Post subject: Reply with quote

Code:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown -block(8,18)
[quote][/quote]
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Sat Jun 29, 2013 9:16 pm    Post subject: Reply with quote

I have config all the lsmod drivers for my hard drive. Running out of options.......
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Sat Jun 29, 2013 10:10 pm    Post subject: Reply with quote

well now I got my stuff all mess up now and got a start a new install I have read



Quote:
I had to shut AHCI off and use IDE emulation. WD1002FAEX hard drive. The problem might be my Gigabyte motherboard BIOS. Try IDE emulation and see if it boots.

Another idea: boot the system rescue disk and then check with lspci etc to see what's loaded.


From here: https://forums.gentoo.org/viewtopic-t-933012-start-0.html

Will give that a try
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Tue Jul 02, 2013 11:05 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-963210-highlight-.html
Solved here
_________________
GCC 4.7 is available with support for AMD Opteron™ 6200 series and AMD FX series processors
http://developer.amd.com/community/blog/gcc-4-7-is-available-with-support-for-amd-opteron-6200-series-and-amd-fx-series-processors/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum