Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio crashes/mutes/goes havok - how restart alsa ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Jun 27, 2013 8:07 pm    Post subject: pulseaudio crashes/mutes/goes havok - how restart alsa ? Reply with quote

Hi,


what happens ?

pulseaudio stops working and it gives no output anymore - audio players usually show an irregular timer behavior (it doesn't count - second to second, I mean: when 5 seconds pass - the intervals between the seconds
of the music/song/etc. aren't equally long - seconds jump "go faster" and/or go slower)


what triggers it ?

usually large backup jobs via rsync when I backup several folders

my rsync backup scheme goes like this:

1) - several smaller folders (but still up to 400-500 GiB) which frequently change content [several subsequent rsync jobs lauched on after another via a bash script]
2) - whole partition again with 2-3 folders omitted ( --exclude " foo " )

the most often times the breaking occurs during transitioning from step 1 to step 2

where as manual "sync" command was included [now I commented that out and see whether it reduced the probability for this to happen]



but it also happens sporadically



what triggers it (Pt2, cont'd) ?

having pavucontrol open and changing volumes between programs that run while heavy i/o is going on (especially when a big rsync backup job is coming to an end)






so my only "fix" so far is to reboot my computer to be able to play back any sound again


I believe that restarting and/or un-loading and loading the alsa modules would help

but I couldn't figure out so far how to do it


wasn't there are way in the past to alsa reload or something similar ?


anyone else experienced this ?


additional information

this afaik happened with pulseaudio 2.x -> 3.x -> 4.0 (perhaps also 0.9.x)




Many thanks in advance ! :)


edit: added triggers (Pt2)
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D


Last edited by kernelOfTruth on Fri Jun 28, 2013 9:56 am; edited 1 time in total
Back to top
View user's profile Send private message
Caze
n00b
n00b


Joined: 16 Apr 2013
Posts: 8

PostPosted: Fri Jun 28, 2013 5:59 am    Post subject: Reply with quote

I was having this a lot, and another USB issue which I mistook for something else. (I use a USB DAC/AMP) Both were fixed after turning off legacy usb emulation and some *HCI handoff settings n my BIOS.

Pulseaudio still stopped outputting sound occasionally if I switched devices and was generally doing what a lot of people bash pulseaudio for. I just run htop, find these two little processes of pulseaudio running and kill them, worked everytime, it was always the same two processes of pulseaudio running that was messing things up. pkill pulseaudio doesn't work for me.

I have no clue if it's the same problem, just sharing what worked for me.

By the way, I think restarting alsa is just running /etc/init.d/alsasound restart .
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5611
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 28, 2013 10:01 am    Post subject: Reply with quote

thanks Caze !

the problem could be related,


however - each time this happened I killed pulseaudio (either via killall pulseaudio or killall -9 pulseaudio) but

setting audio output via alsamixer while pulseaudio is running again (e.g. autostart or having launched it manually again) or leaving it unloaded

didn't lead to any output anymore and the "weird" behavior with clocks running irregularly of the audio programs

/etc/init.d/alsasound afaik didn't help in the past but I'll give it a try again if it (hopefully not !) again happens




I also tried to unload and load again the snd modules but each time it fails due to a module being in use:

Code:
rmmod snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd


Code:
modprobe -r snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd



e.g. snd_hda_codec_realtek


if I remember correctly this wasn't as complicated in the past and it flawlessly unloaded & loaded the modules (I could be wrong though)
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Fri Jun 28, 2013 10:48 am    Post subject: Reply with quote

<trolling>
Out of curiosity, kOT, does this problem you are experiencing also impact on the line spacing in your posts ? :wink:
</trolling>

OK, I do not use pulse, so the following observation can be completely unrelated.
Anyway!

- I periodically use rsync between two different disks on two different controllers. One being significantly quicker than the other.
- I have noticed, almost systematically, after a certain time, an impact on my timers.

launching top during an rsync process told me several things :

a/ The rcu_preempt process was at the top of the list displaying an unusually big TIME. (>3.40)
b/ Running a ck-sources, TIME for top was equal to -1.

Then I realized that my setting for CONFIG_RCU_BOOST_PRIO was very wrong.
I had set it to 80 but all my irqs were left to their default realtime priority of 50.
I dropped CONFIG_RCU_BOOST_PRIO down to 40, rebuilt the kernel and... Pfwiewt! Never experienced this trouble any more.
_________________
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1122

PostPosted: Fri Jun 28, 2013 11:22 am    Post subject: Reply with quote

aCOSwt wrote:
Then I realized that my setting for CONFIG_RCU_BOOST_PRIO was very wrong.
I had set it to 80 but all my irqs were left to their default realtime priority of 50.
I dropped CONFIG_RCU_BOOST_PRIO down to 40, rebuilt the kernel and... Pfwiewt! Never experienced this trouble any more.
I ever did say this (ck-hack.blogspot):
CONFIG_RCU_BOOST_PRIO should be higher than default but less than irq 50
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum