Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hybrid intel hd 4000 and ati 7670m problem?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 15

PostPosted: Thu Jun 27, 2013 4:01 pm    Post subject: hybrid intel hd 4000 and ati 7670m problem? Reply with quote

i have a hp laptop,it has two graph cards,one inside is intel hd 4000,the other is ati hd 7670m.
i follow the address here:https://forums.gentoo.org/viewtopic-t-909802-start-0.htmlandhttp://gentoo-en.vfose.ru/wiki/Fglrx-hybrid-graphics,both didn't not work for me.i use xf86-video-intel-video-2.20.2 with use="sna dri udev xvmc",someone said u want use the "sna",you must use the version 2.20.2.and ati-driver-13.1,so i use the Xorg -configure,the x worked fine with one intel card,u cann't see the ati one worked or not.the xorg.conf here:
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "AccelMethod"           # <str>
        #Option     "DRI"                   # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
        #Option     "Throttle"              # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "DelayedFlush"          # [<bool>]
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

and when i follow the method:https://forums.gentoo.org/viewtopic-t-909802-start-0.html,
Code:
eselect opengl set ati

Code:
aticonfig --initial
,which would create a new /etc/X11/xorg.conf, backing up the old one. This can be replaced with the one shown:
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "Throttle"              # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "DelayedFlush"          # [<bool>]
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

you can't go the gnome seesion or any graph seesion;
the xorg.0.log:
Code:
[   163.880]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[   163.881] X Protocol Version 11, Revision 0
[   163.881] Build Operating System: Linux 3.8.13-gentoo x86_64 Gentoo
[   163.882] Current Operating System: Linux localhost 3.8.13-gentoo #8 SMP Wed Jun 19 16:38:58 CST 2013 x86_64
[   163.882] Kernel command line: root=/dev/sda8 video=uvesafb:mtrr:3,ywrap,1366x768-32@60
[   163.882] Build Date: 17 June 2013  04:56:35PM
[   163.883] 
[   163.883] Current version of pixman: 0.28.0
[   163.884]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   163.884] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   163.886] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 20 17:25:57 2013
[   163.917] (==) Using config file: "/etc/X11/xorg.conf"
[   163.918] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   163.926] (==) ServerLayout "X.org Configured"
[   163.926] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   163.926] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   163.941] (**) |   |-->Device "aticonfig-Device[0]-0"
[   163.941] (**) |-->Input Device "Mouse0"
[   163.941] (**) |-->Input Device "Keyboard0"
[   163.941] (==) Automatically adding devices
[   163.941] (==) Automatically enabling devices
[   163.941] (==) Automatically adding GPU devices
[   163.987] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   163.987]    Entry deleted from font path.
[   163.998] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   163.998]    Entry deleted from font path.
[   163.998] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[   163.998] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   163.998] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   163.998] (WW) Disabling Mouse0
[   163.998] (WW) Disabling Keyboard0
[   164.012] (II) Loader magic: 0x806be0
[   164.012] (II) Module ABI versions:
[   164.012]    X.Org ANSI C Emulation: 0.4
[   164.012]    X.Org Video Driver: 13.1
[   164.012]    X.Org XInput driver : 18.0
[   164.012]    X.Org Server Extension : 7.0
[   164.012] (II) config/udev: Adding drm device (/dev/dri/card0)
[   164.014] (--) PCI:*(0:0:2:0) 8086:0166:103c:183e rev 9, Mem @ 0x63000000/4194304, 0x50000000/268435456, I/O @ 0x00005000/64
[   164.014] (--) PCI: (0:1:0:0) 1002:6840:103c:183e rev 0, Mem @ 0x40000000/268435456, 0x62000000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[   164.014] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   164.014] Initializing built-in extension Generic Event Extension
[   164.015] Initializing built-in extension SHAPE
[   164.015] Initializing built-in extension MIT-SHM
[   164.016] Initializing built-in extension XInputExtension
[   164.016] Initializing built-in extension XTEST
[   164.017] Initializing built-in extension BIG-REQUESTS
[   164.017] Initializing built-in extension SYNC
[   164.018] Initializing built-in extension XKEYBOARD
[   164.018] Initializing built-in extension XC-MISC
[   164.019] Initializing built-in extension XINERAMA
[   164.019] Initializing built-in extension XFIXES
[   164.020] Initializing built-in extension RENDER
[   164.020] Initializing built-in extension RANDR
[   164.020] Initializing built-in extension COMPOSITE
[   164.021] Initializing built-in extension DAMAGE
[   164.021] Initializing built-in extension MIT-SCREEN-SAVER
[   164.022] Initializing built-in extension DOUBLE-BUFFER
[   164.022] Initializing built-in extension RECORD
[   164.023] Initializing built-in extension DPMS
[   164.023] Initializing built-in extension X-Resource
[   164.024] Initializing built-in extension XVideo
[   164.024] Initializing built-in extension XVideo-MotionCompensation
[   164.024] Initializing built-in extension XFree86-VidModeExtension
[   164.025] Initializing built-in extension XFree86-DGA
[   164.025] Initializing built-in extension XFree86-DRI
[   164.026] Initializing built-in extension DRI2
[   164.026] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   164.026] (II) LoadModule: "glx"
[   164.045] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   164.075] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[   164.075]    compiled for 6.9.0, module version = 1.0.0
[   164.076] Loading extension GLX
[   164.076] (II) LoadModule: "fglrx"
[   164.076] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[   164.280] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[   164.280]    compiled for 1.4.99.906, module version = 9.1.11
[   164.280]    Module class: X.Org Video Driver
[   164.280] (II) Loading sub module "fglrxdrm"
[   164.280] (II) LoadModule: "fglrxdrm"
[   164.280] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[   164.309] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   164.309]    compiled for 1.4.99.906, module version = 9.1.11
[   164.309] (II) AMD Proprietary Linux Driver Version Identifier:9.01.11
[   164.309] (II) AMD Proprietary Linux Driver Release Identifier: 9.012                               
[   164.309] (II) AMD Proprietary Linux Driver Build Date: Dec 19 2012 14:41:10
[   164.309] (--) using VT number 7

[   164.311] (WW) Falling back to old probe method for fglrx
[   164.343] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[   164.345] ukiDynamicMajor: found major device number 248
[   164.345] ukiDynamicMajor: found major device number 248
[   164.345] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   164.345] ukiOpenDevice: node name is /dev/ati/card0
[   164.345] ukiOpenDevice: open result is 9, (OK)
[   165.555] ukiOpenByBusid: ukiOpenMinor returns 9
[   165.555] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   165.595] (--) Chipset Supported AMD Graphics Processor (0x6840) found
[   165.596] (II) fglrx: intel VGA device detected, load intel driver.
[   165.596] (II) LoadModule: "intel"
[   165.596] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   165.645] (II) Module intel: vendor="X.Org Foundation"
[   165.645]    compiled for 1.13.4, module version = 2.20.2
[   165.645]    Module class: X.Org Video Driver
[   165.645]    ABI class: X.Org Video Driver, version 13.1
[   165.645] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[   165.660] (II) AMD Video driver is signed
[   165.660] (II) fglrx(0): pEnt->device->identifier=0x2753d70
[   165.662] (II) intel(1): pEnt->device->identifier=(nil)
[   165.662] (EE) Screen 1 deleted because of no matching config section.
[   165.662] (II) UnloadModule: "intel"
[   165.662] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
[   165.662] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
[   165.720] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[   165.720] (==) fglrx(0): RGB weight 888
[   165.720] (==) fglrx(0): Default visual is TrueColor
[   165.720] (**) fglrx(0): Option "Tiling" "off"
[   165.720] (**) fglrx(0): Option "LinearFramebuffer" "on"
[   165.720] (**) fglrx(0): ChipID override: 0x0166
[   165.720] (**) fglrx(0): Integrated Graphics Chipset: Intel(R) Ivybridge Mobile (GT2)
[   165.720] (**) fglrx(0): Relaxed fencing enabled
[   165.720] (**) fglrx(0): Wait on SwapBuffers? enabled
[   165.720] (**) fglrx(0): Triple buffering? enabled
[   165.720] (**) fglrx(0): Framebuffer linear
[   165.720] (**) fglrx(0): Pixmaps linear
[   165.720] (**) fglrx(0): 3D buffers tiled
[   165.720] (**) fglrx(0): SwapBuffers wait enabled
[   165.720] (==) fglrx(0): video overlay key set to 0x101fe
[   165.721] (II) fglrx(0): Output LVDS1 using monitor section aticonfig-Monitor[0]-0
[   165.721] (II) fglrx(0): found backlight control interface /sys/class/backlight/acpi_video1
[   165.725] (II) fglrx(0): Output VGA1 has no monitor section
[   165.729] (II) fglrx(0): Output HDMI1 has no monitor section
[   165.753] (II) fglrx(0): Output DP1 has no monitor section
[   165.753] (II) fglrx(0): EDID for output LVDS1
[   165.753] (II) fglrx(0): Manufacturer: CMO  Model: 15a2  Serial#: 0
[   165.753] (II) fglrx(0): Year: 2011  Week: 44
[   165.753] (II) fglrx(0): EDID Version: 1.4
[   165.753] (II) fglrx(0): Digital Display Input
[   165.753] (II) fglrx(0): 6 bits per channel
[   165.753] (II) fglrx(0): Digital interface is undefined
[   165.753] (II) fglrx(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[   165.753] (II) fglrx(0): Gamma: 2.20
[   165.753] (II) fglrx(0): No DPMS capabilities specified
[   165.753] (II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[   165.753] (II) fglrx(0): First detailed timing is preferred mode
[   165.753] (II) fglrx(0): Preferred mode is native pixel format and refresh rate
[   165.753] (II) fglrx(0): redX: 0.617 redY: 0.340   greenX: 0.320 greenY: 0.598
[   165.753] (II) fglrx(0): blueX: 0.160 blueY: 0.084   whiteX: 0.313 whiteY: 0.329
[   165.753] (II) fglrx(0): Manufacturer's mask: 0
[   165.753] (II) fglrx(0): Supported detailed timing:
[   165.753] (II) fglrx(0): clock: 76.4 MHz   Image Size:  344 x 193 mm
[   165.753] (II) fglrx(0): h_active: 1366  h_sync: 1433  h_sync_end 1478 h_blank_end 1589 h_border: 0
[   165.753] (II) fglrx(0): v_active: 768  v_sync: 772  v_sync_end 780 v_blanking: 801 v_border: 0
[   165.753] (II) fglrx(0): Supported detailed timing:
[   165.753] (II) fglrx(0): clock: 50.9 MHz   Image Size:  344 x 193 mm
[   165.753] (II) fglrx(0): h_active: 1366  h_sync: 1433  h_sync_end 1478 h_blank_end 1589 h_border: 0
[   165.753] (II) fglrx(0): v_active: 768  v_sync: 772  v_sync_end 780 v_blanking: 801 v_border: 0
[   165.753] (II) fglrx(0): Unknown vendor-specific block 2
[   165.753] (II) fglrx(0): EDID (in hex):
[   165.753] (II) fglrx(0):    00ffffffffffff000dafa21500000000
[   165.753] (II) fglrx(0):    2c150104902213780a00259e57529929
[   165.753] (II) fglrx(0):    15505400000001010101010101010101
[   165.753] (II) fglrx(0):    010101010101d81d56df50002130432d
[   165.753] (II) fglrx(0):    480058c11000001ae41356df50002130
[   165.753] (II) fglrx(0):    432d480058c11000001a000000000000
[   165.753] (II) fglrx(0):    00000000000000000000000000000002
[   165.753] (II) fglrx(0):    000c45ff0b3c6e15192d6e00000000b1
[   165.753] (II) fglrx(0): Not using default mode "320x240" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "400x300" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "400x300" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "512x384" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "640x480" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "640x512" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "800x600" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "896x672" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "928x696" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "960x720" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "700x525" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Not using default mode "1024x768" (doublescan mode not supported)
[   165.753] (II) fglrx(0): Printing probed modes for output LVDS1
[   165.753] (II) fglrx(0): Modeline "1366x768"x60.0   76.40  1366 1433 1478 1589  768 772 780 801 +hsync -vsync (48.1 kHz eP)
[   165.753] (II) fglrx(0): Modeline "1366x768"x40.0   50.92  1366 1433 1478 1589  768 772 780 801 +hsync -vsync (32.0 kHz e)
[   165.753] (II) fglrx(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[   165.753] (II) fglrx(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[   165.753] (II) fglrx(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[   165.753] (II) fglrx(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[   165.757] (II) fglrx(0): EDID for output VGA1
[   165.761] (II) fglrx(0): EDID for output HDMI1
[   165.785] (II) fglrx(0): EDID for output DP1
[   165.785] (II) fglrx(0): Output LVDS1 connected
[   165.785] (II) fglrx(0): Output VGA1 disconnected
[   165.785] (II) fglrx(0): Output HDMI1 disconnected
[   165.785] (II) fglrx(0): Output DP1 disconnected
[   165.785] (II) fglrx(0): Using exact sizes for initial modes
[   165.785] (II) fglrx(0): Output LVDS1 using initial mode 1366x768
[   165.785] (II) fglrx(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[   165.785] (II) fglrx(0): Kernel page flipping support detected, enabling
[   165.785] (==) fglrx(0): DPI set to (96, 96)
[   165.785] (II) Loading sub module "fb"
[   165.785] (II) LoadModule: "fb"
[   165.785] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   165.792] (II) Module fb: vendor="X.Org Foundation"
[   165.792]    compiled for 1.13.4, module version = 1.0.0
[   165.792]    ABI class: X.Org ANSI C Emulation, version 0.4
[   165.792] (II) Loading sub module "dri2"
[   165.792] (II) LoadModule: "dri2"
[   165.792] (II) Module "dri2" already built-in
[   165.792] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[   165.792] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   165.792] (==) fglrx(0): Default visual is TrueColor
[   165.792] (**) fglrx(0): Option "DPMS" "true"
[   165.792] (==) fglrx(0): RGB weight 888
[   165.792] (II) fglrx(0): Using 8 bits per RGB
[   165.792] (==) fglrx(0): Buffer Tiling is ON
[   165.792] (II) Loading sub module "fglrxdrm"
[   165.792] (II) LoadModule: "fglrxdrm"
[   165.792] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[   165.792] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   165.792]    compiled for 1.4.99.906, module version = 9.1.11
[   165.793] ukiDynamicMajor: found major device number 248
[   165.793] ukiDynamicMajor: found major device number 248
[   165.793] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   165.793] ukiOpenDevice: node name is /dev/ati/card0
[   165.793] ukiOpenDevice: open result is 14, (OK)
[   165.793] ukiOpenByBusid: ukiOpenMinor returns 14
[   165.793] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   165.793] (**) fglrx(0): NoAccel = NO
[   165.793] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[   165.793] (--) fglrx(0): Chipset: "AMD Radeon HD 7600M Series" (Chipset = 0x6840)
[   165.793] (--) fglrx(0): (PciSubVendor = 0x103c, PciSubDevice = 0x183e)
[   165.793] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[   165.793] (--) fglrx(0): Linear framebuffer (phys) at 0x40000000
[   165.793] (--) fglrx(0): MMIO registers at 0x62000000
[   165.794] (--) fglrx(0): I/O port at 0x00004000
[   165.794] (==) fglrx(0): ROM-BIOS at 0x000c0000
[   165.809] (II) fglrx(0): AC Adapter is used
[   165.809] (II) fglrx(0): AMD Video BIOS revision 9 or later detected
[   165.809] (--) fglrx(0): Video RAM: 2097152 kByte, Type: DDR3
[   165.810] (II) fglrx(0): PCIE card detected
[   165.810] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
[   165.810] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[   165.828] (II) fglrx(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x80000000)
[   165.828] (II) fglrx(0): RandR 1.2 support is enabled!
[   165.828] (II) fglrx(0): RandR 1.2 rotation support is enabled!
[   165.828] (==) fglrx(0): Center Mode is disabled
[   165.828] (II) Loading sub module "fb"
[   165.828] (II) LoadModule: "fb"
[   165.828] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   165.828] (II) Module fb: vendor="X.Org Foundation"
[   165.828]    compiled for 1.13.4, module version = 1.0.0
[   165.828]    ABI class: X.Org ANSI C Emulation, version 0.4
[   165.828] (II) Loading sub module "ddc"
[   165.828] (II) LoadModule: "ddc"
[   165.828] (II) Module "ddc" already built-in
[   165.913] (II) fglrx(0): Eyefinity capable adapter detected.
[   165.913] (II) fglrx(0): Adapter AMD Radeon HD 7600M Series has 6 configurable heads and 0 displays connected.
[   165.913] (==) fglrx(0):  PseudoColor visuals disabled
[   165.913] (II) Loading sub module "ramdac"
[   165.913] (II) LoadModule: "ramdac"
[   165.913] (II) Module "ramdac" already built-in
[   165.913] (==) fglrx(0): NoDRI = NO
[   165.913] (==) fglrx(0): Capabilities: 0x00000000
[   165.913] (==) fglrx(0): CapabilitiesEx: 0x00000000
[   165.913] (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
[   165.913] (==) fglrx(0): UseFastTLS=0
[   165.913] (II) fglrx(0): TearFreeDesktop is not supported on PowerXpress systems currently.
[   165.913] (--) Depth 24 pixmap format is 32 bpp
[   165.913] (II) LoadModule: "glesx"
[   165.913] (II) Loading /usr/lib64/xorg/modules/glesx.so
[   166.068] (II) Module glesx: vendor="X.Org Foundation"
[   166.068]    compiled for 1.4.99.906, module version = 1.0.0
[   166.068] Loading extension GLESX
[   166.094] (II) fglrx(0): [DRI2] Setup complete
[   166.094] (II) fglrx(0): [DRI2]   DRI driver: i965
[   166.094] (II) fglrx(0): Allocated new frame buffer 1408x768 stride 5632, untiled
[   166.111] (II) UXA(0): Driver registered support for the following operations:
[   166.111] (II)         solid
[   166.111] (II)         copy
[   166.111] (II)         composite (RENDER acceleration)
[   166.111] (II)         put_image
[   166.111] (II)         get_image
[   166.111] (==) fglrx(0): Backing store disabled
[   166.111] (==) fglrx(0): Silken mouse enabled
[   166.117] (II) fglrx(0): Initializing HW Cursor
[   166.117] (II) fglrx(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   166.118] (**) fglrx(0): DPMS enabled
[   166.118] (==) fglrx(0): Intel XvMC decoder enabled
[   166.118] (II) fglrx(0): Set up textured video
[   166.119] (II) fglrx(0): [XvMC] xvmc_vld driver initialized.
[   166.119] (II) fglrx(0): direct rendering: DRI2 Enabled
[   166.119] (WW) fglrx(0): Option "VendorName" is not used
[   166.119] (WW) fglrx(0): Option "ModelName" is not used
[   166.119] (WW) fglrx(0): Option "Shadow" is not used
[   166.119] (WW) fglrx(0): Option "Tiling" is not used
[   166.119] (WW) fglrx(0): Option "LinearFramebuffer" is not used
[   166.119] (==) fglrx(0): hotplug detection: "enabled"
[   166.125] (EE)
[   166.125] (EE) Backtrace:
[   166.141] (EE) 0: /usr/bin/X (xorg_backtrace+0x34) [0x595be4]
[   166.141] (EE) 1: /usr/bin/X (0x400000+0x1999e9) [0x5999e9]
[   166.141] (EE) 2: /lib64/libpthread.so.0 (0x7f045f31e000+0x10bf0) [0x7f045f32ebf0]
[   166.141] (EE) 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xclIn32+0x0) [0x7f045c87db00]
[   166.142] (EE) 4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xilReadReg32_R600+0xe) [0x7f045ca5a26e]
[   166.142] (EE) 5: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxPxScreenInit+0xa4) [0x7f045ca21b94]
[   166.142] (EE) 6: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxScreenInit+0xce0) [0x7f045c9ff310]
[   166.142] (EE) 7: /usr/bin/X (AddScreen+0x8a) [0x43b1ea]
[   166.142] (EE) 8: /usr/bin/X (InitOutput+0x3fd) [0x47dead]
[   166.142] (EE) 9: /usr/bin/X (0x400000+0x29958) [0x429958]
[   166.142] (EE) 10: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7f045dfd960d]
[   166.142] (EE) 11: /usr/bin/X (0x400000+0x29e9d) [0x429e9d]
[   166.142] (EE)
[   166.142] (EE) Segmentation fault at address 0x70180
[   166.142]
Fatal server error:
[   166.142] Caught signal 11 (Segmentation fault). Server aborting
[   166.142]
[   166.142] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   166.142] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   166.142] (EE)
[   166.163] Server terminated with error (1). Closing log file.

so,i try again,and noting happened,i hope someone help me?because sometimes i need that ati card for games.
Thanks!!!
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1365

PostPosted: Thu Jun 27, 2013 4:22 pm    Post subject: Reply with quote

Quote:
[ 166.125] (EE) Backtrace:
[ 166.141] (EE) 0: /usr/bin/X (xorg_backtrace+0x34) [0x595be4]
[ 166.141] (EE) 1: /usr/bin/X (0x400000+0x1999e9) [0x5999e9]
[ 166.141] (EE) 2: /lib64/libpthread.so.0 (0x7f045f31e000+0x10bf0) [0x7f045f32ebf0]
[ 166.141] (EE) 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xclIn32+0x0) [0x7f045c87db00]
[ 166.142] (EE) 4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xilReadReg32_R600+0xe) [0x7f045ca5a26e]
[ 166.142] (EE) 5: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxPxScreenInit+0xa4) [0x7f045ca21b94]
[ 166.142] (EE) 6: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxScreenInit+0xce0) [0x7f045c9ff310]
[ 166.142] (EE) 7: /usr/bin/X (AddScreen+0x8a) [0x43b1ea]
[ 166.142] (EE) 8: /usr/bin/X (InitOutput+0x3fd) [0x47dead]
[ 166.142] (EE) 9: /usr/bin/X (0x400000+0x29958) [0x429958]
[ 166.142] (EE) 10: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7f045dfd960d]
[ 166.142] (EE) 11: /usr/bin/X (0x400000+0x29e9d) [0x429e9d]


You seem to get a backtrace, we can't really help with that as it requires developers to look into it and fix the problem; please file a bug at https://bugs.gentoo.org where they can help you further.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum