Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge @preserved-rebuild
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
peterab85
n00b
n00b


Joined: 05 Jan 2013
Posts: 4

PostPosted: Wed Jun 26, 2013 1:03 pm    Post subject: emerge @preserved-rebuild Reply with quote

Hi All

I recently upgraded all of my packages on my Gentoo server using: emerge --update --deep --with-bdeps=y world

This resulted in over 100 packages being updated, however I am not fully sure what was updated, I had not done an update since Jan this year.

Now when I install packages I get the following error:

Code:

!!! existing preserved libs:
>>> package: x11-libs/libXdmcp-1.1.1
 *  - /usr/lib64/libXdmcp.so.6.0.0
 *      used by /usr/lib64/libxcb.so.1.1.0 (preserved)
>>> package: x11-libs/libxcb-1.9
 *  - /usr/lib64/libxcb.so.1.1.0
 *      used by /usr/lib64/libX11.so.6.3.0 (preserved)
>>> package: x11-libs/libXext-1.3.1
 *  - /usr/lib64/libXext.so.6.4.0
 *      used by /opt/icedtea-bin-6.1.12.5/jre/lib/amd64/libsplashscreen.so (dev-java/icedtea-bin-6.1.12.5)
>>> package: x11-libs/libX11-1.5.0
 *  - /usr/lib64/libX11.so.6.3.0
 *      used by /opt/icedtea-bin-6.1.12.5/bin/appletviewer (dev-java/icedtea-bin-6.1.12.5)
 *      used by /opt/icedtea-bin-6.1.12.5/bin/policytool (dev-java/icedtea-bin-6.1.12.5)
 *      used by /opt/icedtea-bin-6.1.12.5/jre/bin/policytool (dev-java/icedtea-bin-6.1.12.5)
 *      used by /opt/icedtea-bin-6.1.12.5/jre/lib/amd64/libsplashscreen.so (dev-java/icedtea-bin-6.1.12.5)
>>> package: x11-libs/libXau-1.0.7
 *  - /usr/lib64/libXau.so.6.0.0
 *      used by /usr/lib64/libxcb.so.1.1.0 (preserved)
Use emerge @preserved-rebuild to rebuild packages using these libraries



I have ran "emerge @preserved-rebuild" however the same message appears again when I sync or install a package. Has anyone else had this problem or know how to solve it?

Thanks in advance.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4837
Location: Gothenburg, Sweden

PostPosted: Wed Jun 26, 2013 5:58 pm    Post subject: Reply with quote

You have a binary package (icedtea-bin) that links to libX11.so.6.3.0, that links to libxcb.so.1.1.0 that links to some more libs. Regardless of how many times you try to re-emerge the binary it will, of course, not change its linkage. Your options include installing the from source version, or uninstalling it if you don't use it.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Section_8
Guru
Guru


Joined: 22 May 2004
Posts: 488
Location: Arlington, TX, US

PostPosted: Wed Jun 26, 2013 8:20 pm    Post subject: Reply with quote

I had this happening a few months ago with Googleearth (also a binary package). I'm not sure how, but eventually, after some update, these messages stopped appearing.
Back to top
View user's profile Send private message
peterab85
n00b
n00b


Joined: 05 Jan 2013
Posts: 4

PostPosted: Thu Jun 27, 2013 9:24 am    Post subject: Reply with quote

I unmerged icedtea-bin and re emerged it and this error has now gone away. I was previously trying to unmerge icetea however this didn't work. Thanks for everyone's help.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Thu Jun 27, 2013 9:49 am    Post subject: Reply with quote

When preserved-libs has stuck libraries you can remove the libraries and emerge the packages again (or run `revdep-rebuild` instead) to get rid of those stuck libraries.
Back to top
View user's profile Send private message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2021
Location: Barcelona

PostPosted: Sat Jul 06, 2013 10:54 am    Post subject: Reply with quote

In my case:

Code:
Core2Duo ~ # emerge @preserved-rebuild
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 2) dev-java/oracle-jdk-bin-1.7.0.25
 * jdk-7u25-linux-x64.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...               [ ok ]
>>> Unpacking source...
>>> Unpacking jdk-7u25-linux-x64.tar.gz to /var/tmp/portage/dev-java/oracle-jdk-bin-1.7.0.25/work
>>> Source unpacked in /var/tmp/portage/dev-java/oracle-jdk-bin-1.7.0.25/work
>>> Preparing source in /var/tmp/portage/dev-java/oracle-jdk-bin-1.7.0.25/work/jdk1.7.0_25 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-java/oracle-jdk-bin-1.7.0.25/work/jdk1.7.0_25 ...
...
...
...
>> Completed installing oracle-jdk-bin-1.7.0.25 into /var/tmp/portage/dev-java/oracle-jdk-bin-1.7.0.25/image/

ecompressdir: bzip2 -9 /usr/share/doc

>>> Installing (1 of 2) dev-java/oracle-jdk-bin-1.7.0.25
 * Updating desktop mime database ...
 * System nsplugin is already set, not changing it.
 * You can change nsplugin with eselect java-nsplugin.
 * Updating desktop mime database ...

>>> Emerging (2 of 2) dev-java/oracle-jre-bin-1.7.0.25
 * jre-7u25-linux-x64.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...               [ ok ]
>>> Unpacking source...
>>> Unpacking jre-7u25-linux-x64.tar.gz to /var/tmp/portage/dev-java/oracle-jre-bin-1.7.0.25/work
>>> Source unpacked in /var/tmp/portage/dev-java/oracle-jre-bin-1.7.0.25/work
>>> Preparing source in /var/tmp/portage/dev-java/oracle-jre-bin-1.7.0.25/work/jre1.7.0_25 ...
>>> Source prepared.
...
...
...
>>> Installing (2 of 2) dev-java/oracle-jre-bin-1.7.0.25
 * Updating desktop mime database ...
 * System nsplugin is already set, not changing it.
 * You can change nsplugin with eselect java-nsplugin.
 * Updating desktop mime database ...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-video/ffmpeg-1.0.7
 *  - /usr/lib64/libavcodec.so.53
 *  - /usr/lib64/libavcodec.so.53.61.100
 *      used by /opt/oracle-jdk-bin-1.7.0.25/jre/lib/amd64/fxavcodecplugin-53.so (dev-java/oracle-jdk-bin-1.7.0.25)
 *      used by /opt/oracle-jre-bin-1.7.0.25/lib/amd64/fxavcodecplugin-53.so (dev-java/oracle-jre-bin-1.7.0.25)
 *  - /usr/lib64/libavformat.so.53
 *  - /usr/lib64/libavformat.so.53.32.100
 *      used by /opt/oracle-jdk-bin-1.7.0.25/jre/lib/amd64/fxavcodecplugin-53.so (dev-java/oracle-jdk-bin-1.7.0.25)
 *      used by /opt/oracle-jre-bin-1.7.0.25/lib/amd64/fxavcodecplugin-53.so (dev-java/oracle-jre-bin-1.7.0.25)
Use emerge @preserved-rebuild to rebuild packages using these libraries
Core2Duo ~ #


_________________
pcmaster
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1031
Location: De Meern, The Netherlands

PostPosted: Mon Aug 05, 2013 6:06 pm    Post subject: Reply with quote

After having used revdep-rebuild for years I am now trying to move to emerge @preserved-rebuild but run into questions.

I now have the following situation, where apparently 2 versions of the JPEG library are present. Following the portage section of the handbook:
Code:
TitanGentoo2 ~ # portageq list_preserved_libs /
media-libs/libjpeg-turbo-1.3.0-r2 /usr/lib64/libjpeg.so.8.0.2 /usr/lib64/libjpeg.so.8
If I then inspect the library directory (64-bit):
Code:
TitanGentoo2 ~ # ls -l /usr/lib64/libjpeg.so*
lrwxrwxrwx 1 root root     17 Aug  2 10:43 /usr/lib64/libjpeg.so -> libjpeg.so.62.1.0
lrwxrwxrwx 1 root root     17 Aug  2 10:43 /usr/lib64/libjpeg.so.62 -> libjpeg.so.62.1.0
-rwxr-xr-x 1 root root 285216 Aug  2 10:43 /usr/lib64/libjpeg.so.62.1.0
lrwxrwxrwx 1 root root     16 Aug  1 20:21 /usr/lib64/libjpeg.so.8 -> libjpeg.so.8.0.2
-rwxr-xr-x 1 root root 285232 Aug  1 20:21 /usr/lib64/libjpeg.so.8.0.2
a few observations can be made:
  • First, why is /usr/lib64/libjpeg.so linked to the old library?
  • Second, if I want to remove the old library, do I only remove /usr/lib64/libjpeg.so.62.1.0 or also one or more symbolic links? I know that I have to rebuild media-libs/libjpeg-turbo-1.3.0-r2:
Code:
TitanGentoo2 ~ # equery b /usr/lib/libjpeg.so.62.1.0
 * Searching for /usr/lib/libjpeg.so.62.1.0 ...
media-libs/libjpeg-turbo-1.3.0-r2 (/usr/lib64/libjpeg.so.62.1.0)
TitanGentoo2 ~ # equery b /usr/lib/libjpeg.so.8.0.2
 * Searching for /usr/lib/libjpeg.so.8.0.2 ...
media-libs/libjpeg-turbo-1.3.0-r2 (/usr/lib64/libjpeg.so.8.0.2)
I could of course use trial and error but it would help me more to know what caused this and hopefully gain some insight :)
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2242
Location: Netherlands

PostPosted: Mon Aug 05, 2013 6:22 pm    Post subject: Reply with quote

Helena,
Plse read the changelog of media-libs/libjpeg-turbo at August 1.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1031
Location: De Meern, The Netherlands

PostPosted: Mon Aug 05, 2013 6:41 pm    Post subject: Reply with quote

@gerard82,
Thanks; I do not understand everything but it appears I have to leave both versions of the library in place and change nothing, correct?
André.
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2242
Location: Netherlands

PostPosted: Mon Aug 05, 2013 7:00 pm    Post subject: Reply with quote

No,remove libjpeg.so.8 and it's symlink.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1031
Location: De Meern, The Netherlands

PostPosted: Mon Aug 12, 2013 9:45 am    Post subject: Reply with quote

gerard82 wrote:
No,remove libjpeg.so.8 and it's symlink.
Gerard.
Thanks I have done that. This implied a lot of rebuilds, of course.
Back to top
View user's profile Send private message
Clete2
Guru
Guru


Joined: 09 Aug 2003
Posts: 530
Location: Bloomington, Illinois

PostPosted: Fri Mar 28, 2014 5:32 pm    Post subject: Reply with quote

I don't mean to bump this, but I will anyway.

Code:
emerge --unmerge icedtea-bin && emerge icedtea-bin


Works for me. I don't even have libX11 installed anymore. I confirmed that it does not exist in /usr/lib64/.
_________________
My Blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum