Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Unable to start KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Tue Jun 25, 2013 11:57 pm    Post subject: [SOLVED] Unable to start KDE Reply with quote

Hello,

as the title implies, for some reason I cannot start KDE.

I followed the guide, that can be found here:

http://wiki.gentoo.org/wiki/KDE

Code:
startx


Leads to a screen showing biefly the nvidia logo (I am using the nvidia drivers and not noveau), when back at console level I get the message:

Code:
/root/.xinitrc: line1: exec: startkde: not found


I emerged the startkde package (kde-base/kdebase/startkde), however that did not fix the described behaviour.

One thing I noticed ist that consolekit although emerged seems not to be present, for whatever reason.


Last edited by Dippmopser on Fri Jun 28, 2013 11:00 pm; edited 2 times in total
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Wed Jun 26, 2013 1:04 am    Post subject: Reply with quote

Point zero: you should absolutely never ever run X as root!
Create a normal user. Aside from security concerns, there is a fair amount of software that will not work as root.

Startkde should be enough to get a working, if minimal, KDE. Consolekit is not required for a basic GUI. There is no need to worry about it.

First, lets narrow the problem space. Try testing X. The easiest way is to use the command X -retro & sleep 5; killall X This will give you a test screen on a white and black background with a large black X cursor. The remaining commands will wait 5 seconds and then return you to the terminal by killing the X server. If that fails, please pastbin your xorg log. You can use wgetpaste. You may need to emerge it. The way you use it is to wgetpaste /var/log/Xorg.0.log and post the url returned.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Wed Jun 26, 2013 1:26 am    Post subject: Reply with quote

Hello,

the command you provided, did exactly what you described, where do I go from here?

...

Yes I read that working as root is not recommanded, since I am setting up gentoo on an older machine just for testing proposes and to get to know the system, I did not give it much thought, since no real work will ever be done with that machine anyways.

EDIT:

I created a normal user and ran startx again...
now I get the following:

/etc/X11/xinit/xinitrc: linie 59: twn: command not found
/etc/X11/xinit/xinitrc: linie 63: exec: xterm: command not found
/etc/X11/xinit/xinitrc: linie 60: xclock: command not found
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Wed Jun 26, 2013 1:37 am    Post subject: Reply with quote

Try typing startkde in the terminal. If that fails, there should be a binary in /usr/bin called startkde or similar. I can't remember exactly what it was called. If you can't find it, it probably failed to install. This would be a problem and we will need to see logs of the failed packages.

EDIT: those errors are normal. They refer to the default X window manager which naturally you haven't installed. You will need to edit the user's .xinitrc for startx to look for KDE.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Wed Jun 26, 2013 1:46 am    Post subject: Reply with quote

startkde does not work (command not found)

In /usr/bin, there is no startkde the only file starting with "start" is "startx"

emerging "kde-base/kdebase-startkde" gave me no error msgs whatsoever.

How do I edit the user's .xintrc to look for KDE? Where can this be found and what do I have to insert?
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Wed Jun 26, 2013 1:56 am    Post subject: Reply with quote

Now I am a bit confused. I believe that .xinitrc should contain
Code:
exec startkde


This means there should be a binary called startkde in /usr/bin or somewhere else in your $PATH. I can't imagine why it was not installed. Can you please post the output of emerge -pv kde-base/kdebase-startkde? you can use wgetpaste instead of copying by hand. Add | wgetpaste to the command. It will need to be installed, of course.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
imaginasys
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2009
Posts: 83
Location: Québec

PostPosted: Wed Jun 26, 2013 4:59 am    Post subject: Reply with quote

KDE4 has a different place than KDE3 for startkde . You should use the full path with the name.

Find where is startkde : $ which startkde

Should be in "/usr/local/bin/startkde"

and try to put : /usr/local/bin/startkde in your .xinitrc (or whatever the path is).

or try it on a command line : xinit /usr/local/bin/startkde

The package kdemeta contains startkde. The package startkde is just a bare bone kde with no application at all.

Regards,
BT :mrgreen:
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5267

PostPosted: Wed Jun 26, 2013 10:06 am    Post subject: Reply with quote

imaginasys wrote:
... :roll: ...

Obviously, it shouldn't be in /usr/local.

IIRC, setting XSESSION to a valid value (from /etc/X11/Sessions choices) either in /etc/env.d/ or in your shell init file (i.e. .bashrc) could help.
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Wed Jun 26, 2013 11:03 am    Post subject: Reply with quote

The output of wgetpaste (as suggested by "The Doctor"), can be found here:

http://bpaste.net/show/109935/

What imaginasys suggested did not work

Code:
xinit /usr/local/bin/startkde


=> No such file or directory

I'am not sure I understand, what VoidMage suggested (I am really new to Linux).

EDIT:At the danger of appearing stupid again:

Is there a function/command I can use, to search for files in a shell?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Wed Jun 26, 2013 12:34 pm    Post subject: Reply with quote

if startkde is not in /usr/bin then your system
is hosed (or you actually don't have kde installed)

do you have eix installed?

If so what is the output of

eix -I kde
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Ahenobarbi
Developer
Developer


Joined: 02 Apr 2009
Posts: 345
Location: Warsaw, PL

PostPosted: Wed Jun 26, 2013 1:26 pm    Post subject: Reply with quote

Dippmopser wrote:
The output of wgetpaste (as suggested by "The Doctor"), can be found here:

http://bpaste.net/show/109935/


Looks like you don't have kde-base/kdebase-startkde installed. What command you used to emerge kde-base/kdebase-startkde ?[/code]

Dippmopser wrote:
Is there a function/command I can use, to search for files in a shell?


find
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Wed Jun 26, 2013 2:33 pm    Post subject: Reply with quote

Quote:
What command you used to emerge kde-base/kdebase-startkde ?


This one:

Code:
emerge kde-base/kdebase-startkde


Besides I emerged kde-base/kde-meta at first, since the guide pointed out, that this is all one would need.

When that did not work, I emerged kdebase-startkde separately.

What do you mean with my system is "hoesed"?

I just emerged eix, the output can be found here:

http://bpaste.net/show/109979/
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Wed Jun 26, 2013 6:00 pm    Post subject: Reply with quote

your eix output show you have only kde-env installed;
you should have a very large number of kde packages

I would suggest trying to re-emerge kde-meta and post
the output
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Wed Jun 26, 2013 7:06 pm    Post subject: Reply with quote

Clearly, something is failing to emerge because you are missing base packages that the meta package would pull.

Perhaps it would be worth your time to install fluxbox and xterm just to get a working GUI and make it easier to read portage's output. The [ebuild N ] in the output indicates that it has not been installed. Startkde is a dependency of kdebase-meta so it should have been installed either way.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Wed Jun 26, 2013 8:20 pm    Post subject: Reply with quote

OK, what I am doing now is

Code:
emerge kde-base/kde-meta | wgetpate


Let's see if that yields something conclusive, if not I'll try fluxbox.

EDIT:

Here is the output:

http://bpaste.net/show/110075/

Still kde does not work
Back to top
View user's profile Send private message
Ahenobarbi
Developer
Developer


Joined: 02 Apr 2009
Posts: 345
Location: Warsaw, PL

PostPosted: Wed Jun 26, 2013 9:46 pm    Post subject: Reply with quote

emerge fails, there is a problem when emerging boost

Code:
>>> Failed to emerge dev-libs/boost-1.49.0-r2, Log file:


the actual error is

Code:
{standard input}: Assembler messages:
{standard input}:28378: Warning: end of file not at end of a line; newline inserted
{standard input}:28945: Error: invalid operands (*UND* and .gcc_except_table sections) for `-'
x86_64-pc-linux-gnu-g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.gentoo.org/> for instructions.
...skipped <pbin.v2/libs/test/build/gcc-4.6/gentoorelease/boost.locale.icu-off/pch-off/threading-multi>libboost_unit_test_framework-mt-1_49.so.1.49.0 for lack of <pbin.v2/libs/test/build/gcc-4.6/gentoorelease/boost.locale.icu-off/pch-off/threading-multi>unit_test_parameters.o...
...skipped <pstage/lib>libboost_unit_test_framework-mt-1_49.so.1.49.0 for lack of <pbin.v2/libs/test/build/gcc-4.6/gentoorelease/boost.locale.icu-off/pch-off/threading-multi>libboost_unit_test_framework-mt-1_49.so.1.49.0...
...skipped <pstage/lib>libboost_unit_test_framework-mt-1_49.so for lack of <pstage/lib>libboost_unit_test_framework-mt-1_49.so.1.49.0...
gcc.compile.c++ bin.v2/libs/wave/build/gcc-4.6/gentoorelease/boost.locale.icu-off/pch-off/threading-multi/instantiate_cpp_exprgrammar.o


could you post

emerge --info boost
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Wed Jun 26, 2013 11:44 pm    Post subject: Reply with quote

Sure, here you go:

http://bpaste.net/show/110091/

EDIT:

I installed fluxbox according to this guide:

http://www.gentoo.org/doc/en/fluxbox-config.xml

Now I get a desktop, however the emerging slim, as suggested, requieres this boost-thingy and emerging that fails again.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5267

PostPosted: Thu Jun 27, 2013 9:00 am    Post subject: Reply with quote

Well, it might be not enough disk space, but far more likely is that '-j3' combined with 1GB total RAM is simply not enough for boost.
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Thu Jun 27, 2013 12:04 pm    Post subject: Reply with quote

Could you go into a little more detail?


According to the Gentoo-Handbook the jX-Setting depends on the number of processors or provessor cores that is.

So with a Dual-Core CPU I set it to j3, how is that setting affected by the amount of RAM?

However I can surely reduce this to j1 to be on the save side or do you thank that 1GB RAM is generally not enough to run boost?
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Thu Jun 27, 2013 6:59 pm    Post subject: Reply with quote

The jX setting says run X parallel jobs using X times more ram. Under normal conditions, this isn't a problem and can actually speed up the emerge. However, if you run out of memory then you just can't go any farther and the build fails. You can override this on a one time basis by using MAKEOPTS="-j1" emerge -1 boost Keep in mind that most computers have 3-4 times more ram than your box does.

You should be able to start fluxbox with startfluxbox or modify startx to do it. Slim isn't required for fluxbox to run.

However, this does raise a point worth considering. I don't know if 1Gig of ram is enough for KDE. The lowest I ever had was 2 Gigs a few years ago.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Thu Jun 27, 2013 11:51 pm    Post subject: Reply with quote

1GB should be enough since I ran kubuntu a week ago on the same hardware.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Fri Jun 28, 2013 12:00 pm    Post subject: Reply with quote

the issue is not memory to RUN boost but
how much memory needed to COMPILE boost
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Dippmopser
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2013
Posts: 92

PostPosted: Fri Jun 28, 2013 4:39 pm    Post subject: Reply with quote

Hello again,

I re-emerged the kde meta package.

When I now type "startkde", I get the message:

Code:
Display is not set or cannot connect to the X server.


I followed the guide mentioned in my first post.

EDIT: I searched to forums, so just that you know,

/etc/X11/xinit/xinitrc

the first line is set to

exec startkde

I get the message mentioned above nonetheless

EDIT 2:

EUREKA

I just re-emerged kdm (emerge kdm)

Now KDE works. Why is kdm not part of the meta-package I wonder?

PS: It would be a nice thing, to update the gentoo Handbook for, especially for newcomer, inserting the following in Section 5

Quote:
MAKEOPTS

With MAKEOPTS you define how many parallel compilations should occur when you install a package. A good choice is the number of CPUs (or CPU cores) in your system plus one, but this guideline isn't always perfect.

For example the amount of RAM installed, plays a major role in the compiling process. Systems with little RAM (1GB or less) should try a small J-Flag (1 or 2) no matter how many CPU-Cores there are, or risiking to run out of RAM, resulting in errors during the compilation process.


Or somethong of similar meaning.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum