Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo, pm-utils, gnome, hibernate - reload bluetooth
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 05 Mar 2013
Posts: 1

PostPosted: Tue Jun 25, 2013 10:33 pm    Post subject: gentoo, pm-utils, gnome, hibernate - reload bluetooth Reply with quote

Greetings ppl.
As one can see from topic, it's 'wide' question, so posted here and on 'Other things' branch.
I'm using gentoo ~amd64

parmasse tempos # eix pm-utils
[I] sys-power/pm-utils
Available versions: 1.4.1 1.4.1-r2 {alsa debug networkmanager ntp VIDEO_CARDS="intel radeon"}
Installed versions: 1.4.1-r2(17:19:05 23.04.2013)(alsa -debug -ntp VIDEO_CARDS="intel -radeon")
Description: Suspend and hibernation utilities

parmasse tempos # eix gnome-base/gnome
[I] gnome-base/gnome
Available versions: (2.0) 2.32.1-r2 (~)3.6.2 [M](~)3.8.0
{accessibility +bluetooth (+)cdr cups dvdr +extras +fallback ldap mono policykit}
Installed versions: 3.6.2(2.0)(16:31:14 12.04.2013)(bluetooth cdr cups fallback -accessibility -extras)
Description: Meta package for GNOME 3, merge this package to install

THe problem is that after hibernation my bluetooth device is not started.
After googling, I found 2 solutions - add SUSPEND_MODULES to /etc/pm/config.d/modules or simply load/unload btusb. Second variant worked, but only when I run "sudo pm-hibernate".
More googling showed to set SUID, but this doesn't helped as long as even if 98-bluetooth is under 4755, it can't call and use rmmod && modprobe.
One more googling showed to set "username ALL = NOPASSWD: /usr/sbin/pm-hibernate", and yep - when i run "sudo pm-hibernate" now it doesn't ask for password. BUT I need to run it manually, 'cause using 'hibernate' from menu seems to call pm-hibernate without sudo and this doesn't work.
Setting suid (4755) to /usr/sbin/pm-hibernate seems to give no result.
Even tried to mv /usr/sbin/pm-hibernate to /usr/sbin/pm-hibernate-original, make script "sudp pm-hibernate-original", set NOPASSWD sudoer for both files - the result is the same. When 'sudo pm-hibernate' from console - all works, when hibernate from menu - no bluetooth.
As excuse for 'digging' in this way can say, that both this runs (console and menu) showed in /var/log/pm-suspend.log and both say they successfully run /etc/pm/sleep.d/98-bluetooth. Yep, it 's rights 0755.

What am I missing or can't see? How to get this script (rmmod && modprobe) get run on wakeup? Yep, there is other script - but it invokes "echo on" to device and udevadm, that requires root to, so - doesn't metter.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum