Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Boot Probleme mit grub2 im UEFI Modus
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 345

PostPosted: Tue Jun 25, 2013 5:06 pm    Post subject: [Solved]Boot Probleme mit grub2 im UEFI Modus Reply with quote

Hallo @all

Ich habe seit einiger Zeit ein Problem mit grub2.

Erstaml zu meiner Hardwar:
Mainboard: Asrock 970 Extreme4 (Bios version 2.30 UEFI version 2.3.1)
CPU: Amd FX-8350
Grafikkarten: 2x Amd Radeon HD7770 GHz Edition (CrossfireX)
Speicher: 4x4GB Transcend 1333 MHz
Festplatten: 2x Sandisk 64 GB SSD (1x Windows8, 1x Gentoo) 1x 1TB Seagate 7200.11 (Alle Sata3)
Netzteil: Thermaltake Berlin 630 Watt

Ich benutze gcc-4.8.1, binutils-2.23.50.2 und glibc-2.17 (Als Linker benutze ich gold zusammen mit lto, für grub2 aber den bfd linker und kein lto).

Das Problem bestand allerdings auch früher schon, bevor ich mein System mit lto aufgesetzt hatte.

Immer wenn ich versuche von der SSD zu booten (Die erste SSD mit Windows enthält auch die Efi Boot Partition, grub wähle ich im UEFI Bootmanager zum starten aus) zeigt er mir das Grub Menü, dort kann ich dann einen eintrag auswählen (Windows kann ich von hier aus ohne Probleme starten) und sobald ich Linux starten will zeigt er mir noch die Bootmeldung Gentoo x64 Startet ... (Selbst definiert) und hängt sich auf.

Dann kann man warten warten warten oder reset drücken.

Der selbe Kernel startet allerdings von einem Usb Stick aus (Sysresccd mir veränderter grub-370.cfg und er enthält auch den Kernel).

Die Festplatten sind im Gpt Format.
Ich habe auch schon diverse optionen durchprobiert, die in verschiedenen Foren als Lösung vorgeschlagen wurden (Auch im einzigen Beitrag hier im Forum) allerdings brachte der Parameter edd=off oder edd=skipmbr nichts.

Ebenfalls das Komprimierungsformat des Kernels ist unerheblich (Lzo, gzip, bzip2 starten alle nicht).

Ich hoffe jemand kann mir bei dem Problem helfen, bekomme es nicht gelöst, die einzige möglichkeit das System zu starten ist per USB Stick (Was ich seit knapp einem Jahr schon so mache, hatte das Problem schon wieder vergessen bis ich jetzt mal versucht habe es wieder per Festplatte zu starten.)


Last edited by Child_of_Sun_24 on Tue Jun 25, 2013 9:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Tue Jun 25, 2013 5:53 pm    Post subject: Reply with quote

Diesen Effekt hatte ich auch vor ein paar Wochen. Das Problerm ist gcc.
Grub2 scheint mit gcc-4.8 nicht sauber gebaut zu werden. Baue (und installiere) grub mit einem gcc-4.7 und alles sollte wieder funktionieren.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 345

PostPosted: Tue Jun 25, 2013 8:33 pm    Post subject: Reply with quote

Ich werde es mal versuchen, danke für die schnelle Antwort.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2193
Location: Germany

PostPosted: Tue Jun 25, 2013 9:09 pm    Post subject: Reply with quote

Jo, klingt nach https://bugs.gentoo.org/show_bug.cgi?id=468136
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 345

PostPosted: Tue Jun 25, 2013 9:36 pm    Post subject: Reply with quote

Den Bug hatte ich nicht gefunden, aber das neukompilieren mit gcc-4.7.3 hat geholfen, jetzt startet er wieder vernünftig.

Danke nochmal :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum