Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conexión con CD minimal ~x86_64
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1463

PostPosted: Thu Aug 15, 2013 7:39 pm    Post subject: Reply with quote

Por lo que vi en un pantallazo la interface wireless usa el driver rt2800usb la otra el susodicho r8169 y que ninguno de los dos funciona con el kernel-3.8.13, sin embargo funcionan con el CD de instalación.
Si lo de arriba es correcto podrias copiar el kernel y los modulos del CD de instalación e intentar arracar con ese kernel o mejor copiar la .config al kernel que tienes y luego hacer genkernel all --oldconfig.
Esto último no es muy didactico de por si aunque funcione pero despues con tiempo comparando una y otra configuración seguramente verias donde falla ahora.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Aug 15, 2013 7:54 pm    Post subject: Reply with quote

Luciernaga wrote:
esteban_conde wrote:
Quote:
r8168-8.028.00 requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED

El mensaje es que para compilar es necesaro que esa opcion esté deshabilitada, seguramente debido a que son incompatibles.


¿Incompatible? ... qué con quién ....
Lo cual demuestra que el controlador r8169 de la instalación, o sea, el que se configura en el núcleo no es igual que el que pretende instalarse con emerge ... digo.
...
Es incompatible la construcción del driver r8168 usando emerge si tienes el driver r8169 de las fuentes del kernel construido, da igual que sea modulo que esté integrado en el nucleo.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Aug 15, 2013 8:01 pm    Post subject: Reply with quote

Luciernaga wrote:
Estoy leyendo algunas páginas (en inglés) sobre mi problema del controlador r8168 y me quedo en ascuas ...
...
A mí, ésta me parece muy interesante:
https://forums.gentoo.org/viewtopic-t-908834-start-0.html
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Aug 15, 2013 8:04 pm    Post subject: Reply with quote

Luciernaga wrote:
...
Por otra parte emerger r8168 no me lo acepta el sistema
...
Esto no es dar mucha infromación...

Luciernaga wrote:
...
y ahora estoy instalando desde cero nuevamente ...
...
...pero ya no importa.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Aug 15, 2013 8:10 pm    Post subject: Reply with quote

Luciernaga wrote:
...
El caso es que no me funciona, he compilado el núcleo "deshabilitando" la opción R8169 y al emerger r8168 me vuelve a dar el error que tengo posteado anteriormente ...
...
Entonces es que no lo has deshabilitado en las fuentes del kernel que portage cree que estás usando según tengas configurado con eselect kernel.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Aug 15, 2013 8:29 pm    Post subject: Reply with quote

Luciernaga wrote:
...
Tengo dos interfaces de red WiFi (la Alfa (AWUS036NH) y una SMC EZ Connect N (SMCWUSBS-N2), las dos funcionan con el LiveCD de Gentoo último, se conectan convenientemente con net-setup pero una vez inicio desde disco duro con la instalación nueva fallan ... con el mensaje en pantalla que tengo posteado anteriormente ... además dmesg me reporta lo siguiente:
[IMG]http://img801.imageshack.us/img801/572/ykyx.jpg[/IMG]
...
Necesitas
Code:
sys-kernel/linux-firmware
Te sugiero que, cuando hagas una nueva instalación, instales el paquete antes de salir del chroot.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Thu Aug 15, 2013 8:39 pm    Post subject: Reply with quote

Luciernaga wrote:
Ahora voy con la interfaz cableada de Realtek ... atendiendo en la recompilación lo siguiente:
[IMG]http://img197.imageshack.us/img197/2645/fui0.jpg[/IMG]
[IMG]http://img809.imageshack.us/img809/1584/y378.jpg[/IMG]
La compilación termina OK.
Al emerger r8169 da fallo porque no existe la ebuild ...
Ahora al emerger r8168 se interrumpe con este log ...
 * Package: net-misc/r8168-8.028.00
 * Repository: gentoo
 * Maintainer: joker@gentoo.org
 * USE: abi_x86_64 amd64 consolekit elibc_glibc kernel_linux multilib policykit userland_GNU
 * FEATURES: preserve-libs sandbox
...
* ERROR: net-misc/r8168-8.028.00 failed (compile phase):
...
Necesitas la versión 8.035.00-r1 del ebuild que es la que aplica un parche para que funciones con kernels 3.8. Tendrás que desenmascararla en package.keywords.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 377
Location: LANDETE (Cuenca)

PostPosted: Thu Aug 15, 2013 9:08 pm    Post subject: Reply with quote

Vale, vale, vale .... voy a estudiar concienzudamente todas esas respuestas a ver si las puedo digerir ... con el tiempo ... y a ver qué pasa ... no vaya a ser que tire por la tangente ... digo ...
Muchas gracias a todos y saludetes :)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum