Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge-delta-webrsync tries to fetch an old delta and fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Darknight
Guru
Guru


Joined: 26 Jan 2004
Posts: 455
Location: Italy

PostPosted: Mon Jun 24, 2013 9:55 am    Post subject: Emerge-delta-webrsync tries to fetch an old delta and fails Reply with quote

Code:
emerge-delta-webrsync
Looking for available base versions for a delta
fetching patches
--2013-06-24 11:45:33--  http://mirror.switch.ch/ftp/mirror/gentoo/snapshots/deltas/snapshot-20130615-20130616.patch.bz2.md5sum
Resolving mirror.switch.ch... 2001:620:0:8::20, 130.59.10.36
Connecting to mirror.switch.ch|2001:620:0:8::20|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-06-24 11:45:33 ERROR 404: Not Found.

Tried the official mirror too.
After this it tries to update the tree with the files it has (not sure what it's doing since I deleted all the snapshots I found) and won't try to fetch newer deltas, for example.
I ended up using emerge-webrsync but this didn't reset the delta-webrsync state. I'd like to make it work again. Unfortunately I'm unable to find where emerge-delta-webrsync stores its information about the first needed delta.
Pointers?
Thanks in advance.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Tue Jun 25, 2013 6:02 pm    Post subject: Reply with quote

emerge-webrsync gets the data for the date from the date command. Issue date from a root prompt to see the current system date and time. If not properly set set a new date with:
Code:
date <new date>

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
cbai
n00b
n00b


Joined: 26 Jun 2013
Posts: 1

PostPosted: Wed Jun 26, 2013 5:33 am    Post subject: Reply with quote

you can reset the delta state by removing all the "snapshot-20*" and "portage-20*" files in /usr/portage/distfiles
Back to top
View user's profile Send private message
Darknight
Guru
Guru


Joined: 26 Jan 2004
Posts: 455
Location: Italy

PostPosted: Wed Jun 26, 2013 7:23 am    Post subject: Reply with quote

@eyoung100: good advice but I run ntpd and the date is ok.
@cbai: deleting "portage-20*" did the trick, I had already deleted all snapshots.
Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum