Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 24 Oct 2009
Posts: 13

PostPosted: Sun Jun 23, 2013 4:20 pm    Post subject: [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)] Reply with quote

Hi guys,

not sure if this is the right forum to post my problem....

I tried to install vuze (via emerge and after i tried the binary download) and everytime when searching something in vuze i get the following error in the console (no differences between the portage and manually downloaded binary version) and no search results are displayed.


DEBUG::Sun Jun 23 18:06:30 CEST
  Skin Event Show caused an error for listener added locally
    SWTSkinObjectBasic::setIsVisible::306, SWTSkinObjectBrowser::setIsVisible::262, SWTSkinObjectContainer$3::runSupport::281, AERunnable::run::38, RunnableLock::run::35, Synchronizer::runAsyncMessages::135, Display::runAsyncMessages::3537, Display::readAndDispatch::3189, SWTThread::<init>::293, SWTThread::createInstance::63, Initializer::<init>::163, NativeConstructorAccessorImpl::newInstance0::-2, NativeConstructorAccessorImpl::newInstance::57, DelegatingConstructorAccessorImpl::newInstance::45, Constructor::newInstance::526, Main::<init>::114, Main::main::292, NativeMethodAccessorImpl::invoke0::-2, NativeMethodAccessorImpl::invoke::57, DelegatingMethodAccessorImpl::invoke::43, Method::invoke::606, MainExecutor$1::run::37, Thread::run::724
   at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(
   at org.eclipse.swt.widgets.Display.runAsyncMessages(
   at org.eclipse.swt.widgets.Display.readAndDispatch(
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(
   at com.aelitis.azureus.ui.swt.Initializer.<init>(
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance(
   at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
   at java.lang.reflect.Constructor.newInstance(
   at org.gudy.azureus2.ui.swt.Main.<init>(
   at org.gudy.azureus2.ui.swt.Main.main(
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(
   at java.lang.reflect.Method.invoke(
   at com.aelitis.azureus.launcher.MainExecutor$
Browser: org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
Browser: org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
Browser: org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
Browser: org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]


emerge --info
Portage (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
System uname: Linux-3.7.10-gentoo-x86_64-Intel-R-_Core-TM-_i7-3630QM_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:    16335056 total,  12971072 free
KiB Swap:   15623144 total,  15623144 free
Timestamp of tree: Sun, 23 Jun 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-march=corei7 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=corei7 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl alsa amd64 apache2 bash-completion berkdb bindist branding bzip2 cairo cdinstall cdr cli consolekit cracklib crypt crypto cups cxx dbus dri dvb dvd dvdr encode firefox fortran g3dvl gcj gdbm gif gimp gpm gtk hal iconv ieee1394 imap innodb ipv6 java jpeg lock mime mmx modules mp3 mudflap multilib mysql ncurses nls nocd nptl nsplugin opengl openmp pam pcre png policykit python readline rss samba sasl session sql sse sse2 ssl startup-notification svg swt tcpd tiff truetype udev unicode usb win32codecs xcomposite xine xml xml2 xscreensaver xulrunner xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Im having already the latest firefox browser installed. Does anybody have a idea what i could try?
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 04 Jul 2012
Posts: 1553

PostPosted: Sun Jun 23, 2013 4:32 pm    Post subject: Reply with quote

Please file bugs at such that this bug can get fixed within the package. This environment variable should very likely be set by the package or the package should document setting it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum