Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error Building SciPy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
colsandurz
n00b
n00b


Joined: 01 May 2009
Posts: 22

PostPosted: Sat Jun 22, 2013 1:08 am    Post subject: Error Building SciPy Reply with quote

When I try to build SciPy I get this error:

Code:
 # emerge -uav sci-libs/scipy

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "dev-python/cython[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)]".
!!! One of the following packages is required to complete your request:
- sci-libs/scipy-0.12.0::gentoo (Change USE: -python_targets_python3_3 -python_targets_python2_7, this change violates use flag constraints defined by sci-libs/scipy-0.12.0: 'any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 )')
(dependency required by "sci-libs/scipy-0.12.0" [ebuild])
(dependency required by "sci-libs/scipy" [argument])


I have cython 0.16 installed.

Here's my make.conf

Code:
# cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="ffmpeg kpathsea extra ntfs ntfsprogs wifi java latex -bindist hdaps nsplugin nspluginwrapper multilib vim-syntax vim-pager fontconfig doc matroska ogg theora X bash-completion dri kdrive sqlite truetype python mmx sse sse2 alsa qt4  dia extensions gnutls fuse vim examples webkit threads pdf pdflib pulseaudio udev cdda fftw lapack blas -gnome -dvd -cdr -debug -bluetooth -emacs -xemacs -hal private-headers git consolekit dbus policykit kde xvfb -aqua json minizip upnp -semantic-desktop -handbook"

PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_3"

MAKEOPTS="-j1"

ACCEPT_LICENSE="*"

EMERGE_DEFAULT_OPTS="--autounmask=n"

LINGUAS="en"

PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/gamerlay/"

INPUT_DEVICES="keyboard mouse synaptics"

PORTAGE_ELOG_SYSTEM="save"
PORTAGE_ELOG_CLASSES="warn info error log"
PORT_LOGDIR="/var/log/portage/elog/"


VIDEO_CARDS="intel"

GENTOO_MIRRORS="rsync://mirrors.rit.edu/gentoo/ ftp://ftp.lug.udel.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ rsync://rsync.gtlib.gatech.edu/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/"


I'm not really sure what this error means since I'm building with python 2.7, I don't have -python_single_target_python2_7 anywhere and scipy claims it can be built against python 2.7 (the any-of ..... line).

What's going on here?
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Sat Jun 22, 2013 1:28 pm    Post subject: Reply with quote

My guess is that the unstable scipy-0.12.0 already uses the new Python-r1 eclass, while stable cython-0.16 doesn't, which makes it impossible to satisfy the python* flags.

My recommendation is to update to a newer cython package that uses the python-r1 eclass.

I can support this claim by:
Code:
gentbox ~ # emerge -va scipy

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by sci-libs/scipy-0.12.0
# required by scipy (argument)
=dev-python/cython-0.19.1 ~amd64

Would you like to add these changes to your config files? [Yes/No] n

emerge: there are no ebuilds built with USE flags to satisfy "virtual/python-imaging[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)]".
!!! One of the following packages is required to complete your request:
- sci-libs/scipy-0.12.0::gentoo (Change USE: -python_targets_python3_2 -python_targets_python2_7, this change violates use flag constraints defined by sci-libs/scipy-0.12.0: 'any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 )')EMERGE_DEFAULT_OPTS="--autounmask=n"
(dependency required by "sci-libs/scipy-0.12.0" [ebuild])
(dependency required by "scipy" [argument])

So as you can see, autounmask has the same recommendation.

You give yourself an unnecessary headache by having
Code:
EMERGE_DEFAULT_OPTS="--autounmask=n"

I trust autounmask these days and when using --ask, it's also convenient to use
Code:
EMERGE_DEFAULT_OPTS="--autounmask-write"

It asks if you want to make the changes and then you can selectively apply them with dispatch conf.

Good luck with getting scipy running and with your research/project :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum