Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] xmonad freeze
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 386
Location: Cracow, Poland

PostPosted: Wed Jun 19, 2013 3:33 pm    Post subject: [solved] xmonad freeze Reply with quote

Hi,
I just emerge xmonad-0.11.1-r1 (USE=hscolour) with xmonad-contrib-0.11.1. I (USE= hscolour xft) use slim as login manager, but after starting xmonad login screen freeze (on slim) and nothing happend. I can switch alt+f1 to terminal and restart xdm/slim but I can't run xmonad so I change line:
Code:
xmonad

to:
Code:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session xmonad

to /etc/X11/Sessions/xmonad.
It didn't helped.

I didn't find any debug/log file for xmonad to try find out what is going on? Anyway any basic tips what could be wrong?


Last edited by emc on Mon Jun 24, 2013 3:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
nictki
n00b
n00b


Joined: 10 Jan 2007
Posts: 36
Location: somewhere else...

PostPosted: Thu Jun 20, 2013 11:01 am    Post subject: Reply with quote

Hy,

do you have any errors when you run
Code:
xmonad --recompile

_________________
github
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 386
Location: Cracow, Poland

PostPosted: Thu Jun 20, 2013 6:01 pm    Post subject: Reply with quote

nictki wrote:
Hy,

do you have any errors when you run
Code:
xmonad --recompile

Code:
$ xmonad --recompile
xmonad: /home/emc/.xmonad/xmonad.errors: openFile: does not exist (No such file or director
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 386
Location: Cracow, Poland

PostPosted: Thu Jun 20, 2013 8:17 pm    Post subject: Reply with quote

Code:
# touch /home/emc/.xmonad/xmonad.errors

Code:
# xmonad --recompile
Error detected while loading xmonad configuration file: /home/emc/.xmonad/xmonad.hs

<no location info>: can't find file: xmonad.hs

Please check the file for errors.

Warning: Missing charsets in String to FontSet conversion

Code:
# cp /usr/share/xmonad-0.11/ghc-7.4.2/man/xmonad.hs ~/.xmonad

Code:
# xmonad --recompile
Error detected while loading xmonad configuration file: /home/emc/.xmonad/xmonad.hs

xmonad.hs:132:64: Not in scope: `help'

Please check the file for errors.

Warning: Missing charsets in String to FontSet conversion

What now?
Back to top
View user's profile Send private message
nictki
n00b
n00b


Joined: 10 Jan 2007
Posts: 36
Location: somewhere else...

PostPosted: Sun Jun 23, 2013 9:24 am    Post subject: Reply with quote

Hy,

the easy way is to comment this line:

Code:
 , ((modMask .|. shiftMask, xK_slash ), spawn ("echo \"" ++ help ++ "\" | xmessage -file -"))


to

Code:
 --,((modMask .|. shiftMask, xK_slash ), spawn ("echo \"" ++ help ++ "\" | xmessage -file -"))


and it's should be working

usefull link:
http://xmonad.org/documentation.htm
_________________
github
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 386
Location: Cracow, Poland

PostPosted: Mon Jun 24, 2013 3:14 pm    Post subject: Reply with quote

thx, yes it helped!
Back to top
View user's profile Send private message
nictki
n00b
n00b


Joined: 10 Jan 2007
Posts: 36
Location: somewhere else...

PostPosted: Tue Jun 25, 2013 7:00 am    Post subject: Reply with quote

welcome
_________________
github
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum