Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] SDL games x86 bug returns? (eg: heroes)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
CleanTestr
n00b
n00b


Joined: 15 Jan 2013
Posts: 47
Location: somewhere in Rural Nebraska, USA

PostPosted: Sun Jun 16, 2013 12:56 am    Post subject: [SOLVED] SDL games x86 bug returns? (eg: heroes) Reply with quote

(I cross-posted this from Games and Gamers, since SDL stuff seems to wind up here..)

[Edit] this is a dbus-launch issue, see 3rd post below [/Edit]

This is on x86:

Code:
XDM authorization key matches an existing client!
heroes: No joystick found (run with `-J' to suppress this message).
XDM authorization key matches an existing client!
heroes: Failed to open visual: No available video device


A former thread dealing with this problem (note that the 'fix' explained there, doesn't do it
for me):

https://forums.gentoo.org/viewtopic-t-716898-highlight-matches+existing+client.html

This being the debian bug filed originally (in Sep 2007):

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440874

ldd /usr/games/bin/heroes | grep lib[SXx] :

Code:
libSDL_mixer-1.2.so.0 => /usr/lib/libSDL_mixer-1.2.so.0 (0xb773b000)
libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xb76e2000)


strace -eopen,socket,connect /usr/games/bin/heroes

@pastebin: http://bpaste.net/show/107413/

..

.. But, on hardened/no-hardened no-multilib:

ldd /usr/games/bin/heroes | grep lib[SXx] :

Code:
libSDL_mixer-1.2.so.0 => /usr/lib64/libSDL_mixer-1.2.so.0 (0xb773b000)
libSDL-1.2.so.0 => /usr/lib64/libSDL-1.2.so.0 (0xb76e2000)


strace -eopen,socket,connect /usr/games/bin/heroes

@pastebin: http://bpaste.net/show/107458/

doesn't error out, and in fact runs the game :)
_________________
Stan: A signal? Why didn't you wake me?
790: It was a distress signal. They only lead to trouble, so I always ignore them. --Lexx


Last edited by CleanTestr on Sat Aug 10, 2013 5:10 pm; edited 2 times in total
Back to top
View user's profile Send private message
CleanTestr
n00b
n00b


Joined: 15 Jan 2013
Posts: 47
Location: somewhere in Rural Nebraska, USA

PostPosted: Sun Jun 16, 2013 1:25 am    Post subject: Reply with quote

This seems to shed some light on the issue (I'm using e16):

http://www.linuxquestions.org/questions/slackware-14/problem-with-starting-openbox-in-slackware-14-0-a-4175436019/

and

http://www.linuxquestions.org/questions/slackware-14/14-0-beta1-xdm-authorization-key-matches-an-existing-client-xfce4-session-4175418231/

seem to have helped some ppl.
_________________
Stan: A signal? Why didn't you wake me?
790: It was a distress signal. They only lead to trouble, so I always ignore them. --Lexx
Back to top
View user's profile Send private message
CleanTestr
n00b
n00b


Joined: 15 Jan 2013
Posts: 47
Location: somewhere in Rural Nebraska, USA

PostPosted: Sun Jun 16, 2013 1:46 am    Post subject: Reply with quote

Yes.

modifying

http://www.linuxquestions.org/questions/slackware-14/14-0-beta1-xdm-authorization-key-matches-an-existing-client-xfce4-session-4175418231/

to /etc/X11/xinit/xinitrc.e16

Code:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
    exec ck-launch-session /usr/bin/starte16
else
    exec /usr/bin/starte16
fi

works on x86 and hardened/no-hardened no-multilib.
_________________
Stan: A signal? Why didn't you wake me?
790: It was a distress signal. They only lead to trouble, so I always ignore them. --Lexx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum