Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOL] Virtualgl 2.3 upgrade breaks working bumblebee install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Iesos
n00b
n00b


Joined: 12 Jan 2007
Posts: 44

PostPosted: Sat Jun 15, 2013 11:30 am    Post subject: [SOL] Virtualgl 2.3 upgrade breaks working bumblebee install Reply with quote

Hi,

As the virtualgl 2.3.2-r1 arrived in portage some time ago, I masked it since it was breaking my install, and reverted to 2.1 (I think it was). Now there only is 2.3.2 in portage and optirun does not work properly.

If I try to run glxgears:

$ optirun glxgears

it works (also glxspheres work). glxgears and glxspheres does not work (Xlib: extension "GLX" missing on display ":0.0".) when I do not use optirun. Also glxinfo seems to produce what it should when I use optirun. When I try something else

$ optirun bash
$ optirun [...] wine [...] Diablo3.exe

it fails with 'Xlib: extension "GLX" missing on display ":0.0".', same for all other programs I tested. I have tried to look at

$ nvidia-settings -c :8

this displays CRT as "disabled", is this something? I have looked at

$ optirun -vvv <some game>

that gives

Code:
[ 3331.572265] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 3331.572451] [INFO]Configured driver: nvidia
[ 3331.572593] [DEBUG]optirun version 3.2.1 starting...
[ 3331.572612] [DEBUG]Active configuration:
[ 3331.572615] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 3331.572619] [DEBUG] X display: :8
[ 3331.572622] [DEBUG] LD_LIBRARY_PATH: /usr/lib64/opengl/nvidia/lib:/usr/lib32/opengl/nvidia/lib:/usr/lib/opengl/nvidia/lib
[ 3331.572625] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 3331.572628] [DEBUG] Accel/display bridge: virtualgl
[ 3331.572631] [DEBUG] VGL Compression: proxy
[ 3331.572634] [DEBUG] VGLrun extra options:
[ 3331.572637] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 3333.858385] [INFO]Response: Yes. X is active.

[ 3333.858401] [INFO]Running application using virtualgl.
[ 3333.858500] [DEBUG]Process vglrun started, PID 3842.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
[ 3333.989246] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 3333.989280] [DEBUG]Socket closed.
[ 3333.989304] [DEBUG]Killing all remaining processes.


compared to

$ optirun -vvv glxgears

that gives
Code:


[ 6422.171156] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 6422.171347] [INFO]Configured driver: nvidia
[ 6422.171503] [DEBUG]optirun version 3.2.1 starting...
[ 6422.171510] [DEBUG]Active configuration:
[ 6422.171513] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 6422.171516] [DEBUG] X display: :8
[ 6422.171519] [DEBUG] LD_LIBRARY_PATH: /usr/lib64/opengl/nvidia/lib:/usr/lib32/opengl/nvidia/lib:/usr/lib/opengl/nvidia/lib
[ 6422.171522] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 6422.171525] [DEBUG] Accel/display bridge: virtualgl
[ 6422.171528] [DEBUG] VGL Compression: proxy
[ 6422.171531] [DEBUG] VGLrun extra options:
[ 6422.171534] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 6424.444904] [INFO]Response: Yes. X is active.

[ 6424.444918] [INFO]Running application using virtualgl.
[ 6424.445016] [DEBUG]Process vglrun started, PID 32603.
[ 6425.213081] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 6425.213119] [DEBUG]Socket closed.
[ 6425.213139] [DEBUG]Killing all remaining processes.



TLDR: Optirun works only for glxgears and glxspheres, for any other application it fails with 'Xlib: extension "GLX" missing on display ":0.0".'. How to solve this?


Last edited by Iesos on Sun Jun 16, 2013 8:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Iesos
n00b
n00b


Joined: 12 Jan 2007
Posts: 44

PostPosted: Sun Jun 16, 2013 8:32 pm    Post subject: Reply with quote

Closing this, solution is found here:

https://github.com/Bumblebee-Project/Bumblebee/issues/437
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum