Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[python] Problema al actualizar SciPy y relacionados
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
koyo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2003
Posts: 126
Location: Colombia

PostPosted: Sat Jun 15, 2013 1:57 am    Post subject: [python] Problema al actualizar SciPy y relacionados Reply with quote

Hola a todos.

Acabo de ejecutar eix-syn a fin de actualizar mi sistema e instalar nuevos paquetes, cuando ejecuto:
Code:

emerge --update --newuse --deep --with-bdeps=y -avq @world


El siguiente mensaje de error aparece>

Code:
 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


emerge: there are no ebuilds built with USE flags to satisfy "virtual/python-imaging[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)]".
!!! One of the following packages is required to complete your request:
- sci-libs/scipy-0.12.0::gentoo (Change USE: -python_targets_python3_2 -python_targets_python2_7)
(dependency required by "sci-libs/scipy-0.12.0" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Navegando en algunas conversaciones del foro encuentro algunas posibles soluciones:
https://forums.gentoo.org/viewtopic-t-961262-highlight-pythonimaging.html
https://forums.gentoo.org/viewtopic-t-961926-start-0-postdays-0-postorder-asc-highlight-pythonimaging.html

El error sigue apareciendo, he probado a deshabilitar el soporte de Python 3.2 tanto en SciPy como en virtual/python-imaging sin ningun exito.

Cualquier ayuda muchas gracias.
_________________
Paucad Sed Matura


Last edited by koyo on Mon Jun 17, 2013 2:30 am; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Sat Jun 15, 2013 10:55 am    Post subject: Reply with quote

Prueba a actualizar portage:
Code:
# emerge --sync
# emerge --oneshot portage

Si sigues con el problema publica la salida de:
Code:
emerge --info
Back to top
View user's profile Send private message
koyo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2003
Posts: 126
Location: Colombia

PostPosted: Mon Jun 17, 2013 2:36 am    Post subject: Reply with quote

Muchas gracias por tu respuesta.

Segui tus recomendacion, pero el error persiste. Te copio el error y la informacion que me solicitas. Muchas gracias por tu ayuda.

emerge --update --newuse --deep --with-bdeps=y -avq @world :
 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


emerge: there are no ebuilds built with USE flags to satisfy "virtual/python-imaging[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)]".
!!! One of the following packages is required to complete your request:
- sci-libs/scipy-0.12.0::gentoo (Change USE: -python_targets_python3_2 -python_targets_python2_7, this change violates use flag constraints defined by sci-libs/scipy-0.12.0: 'any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 )')
(dependency required by "sci-libs/scipy-0.12.0" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


emerge --info:
Portage 2.1.12.2 (default/linux/amd64/13.0, gcc-4.7.2, glibc-2.15-r3, 3.7.9-gentoo x86_64)
=================================================================
System uname: Linux-3.7.9-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2650_0_@_2.00GHz-with-gentoo-2.2
KiB Mem:    32923996 total,   9866364 free
KiB Swap:   15380828 total,  15364140 free
Timestamp of tree: Mon, 17 Jun 2013 00:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo science nbigaouette
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j17"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/nbigaouette"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl acpi amd64 apache2 bash-completion berkdb bidi bzip2 cjk cli cracklib crypt cxx dbus fat fortran gcj gdbm gif gnutls gpm hal hfs iconv inotify jfs kdeenablefinal lm_sensors lzo memlimit mmx modules mpi mudflap multilib ncurses nls nptl openmp pam pcre png rar readline session sse sse2 ssl ssse3 svg sysfs szip tcpd threads tiff udev unicode usb visualization xcb xpm zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" OPENMPI_RM="pbs" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
Paucad Sed Matura
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Mon Jun 17, 2013 3:58 pm    Post subject: Reply with quote

¿Qué uses tienes asignadas a python-imaging?
Code:
equery uses python-imaging
Back to top
View user's profile Send private message
soren.harward
n00b
n00b


Joined: 23 Jun 2003
Posts: 10

PostPosted: Wed Jun 19, 2013 3:55 am    Post subject: Reply with quote

Favor de disculpar mi espanol; el ingles es mi lenguage nativo.

Crea un archivo "/etc/portage/package.env/scipy" con el contenido:
Code:
sci-libs/scipy sci-libs/scipy.conf

y crea otro archivo "/etc/portage/env/sci-libs/scipy.conf" con el contenido:
Code:
PYTHON_TARGETS="python2_7"


Actualiza scipy de nuevo.
Back to top
View user's profile Send private message
koyo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2003
Posts: 126
Location: Colombia

PostPosted: Fri Jun 21, 2013 2:57 pm    Post subject: Reply with quote

La salida del comando es la siguiente:

equery uses python-imaging:
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for virtual/python-imaging-1:
 U I
 - - python_targets_python2_5 : Build with Python 2.5
 - - python_targets_python2_6 : Build with Python 2.6
 + + python_targets_python2_7 : Build with Python 2.7
 - - tk                       : Adds support for Tk GUI toolkit

_________________
Paucad Sed Matura
Back to top
View user's profile Send private message
koyo
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2003
Posts: 126
Location: Colombia

PostPosted: Fri Jun 21, 2013 3:07 pm    Post subject: Reply with quote

soren.harward wrote:
Favor de disculpar mi espanol; el ingles es mi lenguage nativo.

Crea un archivo "/etc/portage/package.env/scipy" con el contenido:
Code:
sci-libs/scipy sci-libs/scipy.conf

y crea otro archivo "/etc/portage/env/sci-libs/scipy.conf" con el contenido:
Code:
PYTHON_TARGETS="python2_7"


Actualiza scipy de nuevo.


Gracias por tu respuesta, probé tu solución y este es el resultado, tristemente no exitoso:

emerge --update --newuse --deep --with-bdeps=y -avq @world:
 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/bottleneck-0.6.0
# required by dev-python/pandas-0.11.0
# required by @selected
# required by @world (argument)
>=sci-libs/scipy-0.12.0 python_targets_python3_2

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

emerge: there are no ebuilds built with USE flags to satisfy "virtual/python-imaging[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)]".
!!! One of the following packages is required to complete your request:
- sci-libs/scipy-0.12.0::gentoo (Change USE: -python_targets_python3_2 -python_targets_python2_7, this change violates use flag constraints defined by sci-libs/scipy-0.12.0: 'any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 )')
(dependency required by "sci-libs/scipy-0.12.0" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

_________________
Paucad Sed Matura
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Fri Jun 21, 2013 6:51 pm    Post subject: Reply with quote

¿Que paquete necesita python-imaging?
Code:
equery depends python-imaging
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum