Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Lenovo Secure USB flash disk not recognized
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
q-parser
n00b
n00b


Joined: 11 Jul 2006
Posts: 35
Location: Slovakia

PostPosted: Thu Jun 13, 2013 10:09 pm    Post subject: [Solved] Lenovo Secure USB flash disk not recognized Reply with quote

I went through the forums and found that only thread that touches my problem is this:
https://forums.gentoo.org/viewtopic-t-787868.html

I've got 8GB USB flash disk Lenovo Ultra Secure key. It is recognized as an ehci but no DSF is created upon insertion (into usb 2 port, for usb 3 port I get the messages mentioned in the post above).
I tried it under Knoppix (via virtualbox on my gentoo) and it works fine, so I'm just missing something in the kernel (not genkernel obviously).
My other USB flash disk works fine (corsair 8gb usb 3.0).

dmesg on my system upon insertion:
Code:

[ 5309.252047] ehci-pci 0000:00:1d.0: port 1 remote wakeup
[ 5309.252058] usb usb2: usb wakeup-resume
[ 5309.252061] usb usb2: usb auto-resume
[ 5309.252063] ehci-pci 0000:00:1d.0: resume root hub
[ 5309.252074] hub 2-0:1.0: hub_resume
[ 5309.252088] hub 2-0:1.0: port 1: status 0507 change 0000
[ 5309.252097] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0000
[ 5309.252229] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0000
[ 5309.277210] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0002
[ 5309.277245] ehci-pci 0000:00:1d.0: GetStatus port:1 status 001005 0  ACK POWER sig=se0 PE CONNECT
[ 5309.288189] usb 2-1: usb wakeup-resume
[ 5309.288202] usb 2-1: finish resume
[ 5309.288466] hub 2-1:1.0: hub_resume
[ 5309.288619] hub 2-1:1.0: port 1: status 0101 change 0001
[ 5309.390069] ehci-pci 0000:00:1d.0: reused qh ffff88021548da00 schedule
[ 5309.390076] usb 2-1: link qh256-0001/ffff88021548da00 start 1 [1/0 us]
[ 5309.390087] hub 2-0:1.0: resume on port 1, status 0
[ 5309.390092] hub 2-1:1.0: state 7 ports 8 chg 0002 evt 0000
[ 5309.390287] hub 2-1:1.0: port 1, status 0101, change 0000, 12 Mb/s
[ 5309.401121] hub 2-1:1.0: port 1 not reset yet, waiting 10ms
[ 5309.463042] usb 2-1.1: new high-speed USB device number 13 using ehci-pci
[ 5309.474029] hub 2-1:1.0: port 1 not reset yet, waiting 10ms
[ 5309.548921] usb 2-1.1: skipped 1 descriptor after interface
[ 5309.549165] usb 2-1.1: default language 0x0409
[ 5309.550155] usb 2-1.1: udev 13, busnum 2, minor = 140
[ 5309.550159] usb 2-1.1: New USB device found, idVendor=17ef, idProduct=3843
[ 5309.550163] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5309.550166] usb 2-1.1: Product: Secure Key     
[ 5309.550168] usb 2-1.1: Manufacturer: Lenovo 
[ 5309.550171] usb 2-1.1: SerialNumber: 0810161234430
[ 5309.550333] usb 2-1.1: usb_probe_device
[ 5309.550334] usb 2-1.1: configuration #1 chosen from 1 choice
[ 5309.550521] usb 2-1.1: adding 2-1.1:1.0 (config #1, interface 0)
[ 5309.550538] usb-storage 2-1.1:1.0: usb_probe_interface
[ 5309.550541] usb-storage 2-1.1:1.0: usb_probe_interface - got id
[ 5309.550605] scsi21 : usb-storage 2-1.1:1.0
[ 5309.550677] usb 2-1.1: adding 2-1.1:1.1 (config #1, interface 1)
[ 5309.550695] usbhid 2-1.1:1.1: usb_probe_interface
[ 5309.550696] usbhid 2-1.1:1.1: usb_probe_interface - got id
[ 5309.550698] usbhid 2-1.1:1.1: couldn't find an input interrupt endpoint
[ 5310.552642] scsi: unknown device type 21
[ 5310.552647] scsi 21:0:0:0: Unknown           Lenovo   Secure Key       1.00 PQ: 2 ANSI: 2


the same on knoppix:
Code:

[ 1606.283214] usb 1-1: new high-speed USB device number 4 using ehci_hcd
[ 1606.499731] usb 1-1: New USB device found, idVendor=17ef, idProduct=3843
[ 1606.499734] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1606.499736] usb 1-1: Product: Secure Key     
[ 1606.499737] usb 1-1: Manufacturer: Lenovo 
[ 1606.499739] usb 1-1: SerialNumber: 0810161234430
[ 1606.501605] scsi4 : usb-storage 1-1:1.0
[ 1606.501677] usbhid 1-1:1.1: couldn't find an input interrupt endpoint
[ 1607.547374] scsi: unknown device type 21
[ 1607.547379] scsi 4:0:0:0: Unknown           Lenovo   Secure Key       1.00 PQ: 2 ANSI: 2
[ 1607.547455] scsi 4:0:0:0: Attached scsi generic sg2 type 21
[ 1607.556303] scsi 4:0:0:1: Direct-Access     Lenovo   Secure Key       1.00 PQ: 0 ANSI: 2
[ 1607.556380] sd 4:0:0:1: Attached scsi generic sg3 type 0
[ 1607.586891] sd 4:0:0:1: [sdb] 16439524 512-byte logical blocks: (8.41 GB/7.83 GiB)
[ 1607.595937] sd 4:0:0:1: [sdb] Write Protect is off
[ 1607.595941] sd 4:0:0:1: [sdb] Mode Sense: 0b 00 00 08
[ 1607.604954] sd 4:0:0:1: [sdb] No Caching mode page present
[ 1607.604956] sd 4:0:0:1: [sdb] Assuming drive cache: write through
[ 1607.658872] sd 4:0:0:1: [sdb] No Caching mode page present
[ 1607.658875] sd 4:0:0:1: [sdb] Assuming drive cache: write through
[ 1607.771738]  sdb: sdb1 sdb2


my kernel config around usb:
Code:

# USB Host Controller Drivers
#
# CONFIG_USB_C67X00_HCD is not set
CONFIG_USB_XHCI_HCD=y
# CONFIG_USB_XHCI_HCD_DEBUGGING is not set
CONFIG_USB_EHCI_HCD=y
# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
# CONFIG_USB_EHCI_TT_NEWSCHED is not set
CONFIG_USB_EHCI_PCI=y
# CONFIG_USB_OXU210HP_HCD is not set
# CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_ISP1760_HCD is not set
# CONFIG_USB_ISP1362_HCD is not set
CONFIG_USB_OHCI_HCD=y
# CONFIG_USB_OHCI_HCD_PLATFORM is not set
# CONFIG_USB_EHCI_HCD_PLATFORM is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_UHCI_HCD=y
# CONFIG_USB_SL811_HCD is not set
# CONFIG_USB_R8A66597_HCD is not set
# CONFIG_USB_CHIPIDEA is not set

...

#
CONFIG_USB_STORAGE=y



I googled for this issue as well, but there is no mention of this flash disk and linux anywhere (or maybe I wasn't looking properly).

Could anybody give me some hint?

Thank you


Last edited by q-parser on Fri Jun 14, 2013 8:02 am; edited 1 time in total
Back to top
View user's profile Send private message
s4e8
Apprentice
Apprentice


Joined: 29 Jul 2006
Posts: 191

PostPosted: Thu Jun 13, 2013 11:34 pm    Post subject: Reply with quote

you need
Code:

CONFIG_SCSI_MULTI_LUN=y
Back to top
View user's profile Send private message
q-parser
n00b
n00b


Joined: 11 Jul 2006
Posts: 35
Location: Slovakia

PostPosted: Fri Jun 14, 2013 8:02 am    Post subject: Reply with quote

You were right. Now it works.
Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum