Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gcc] 2 versiones conjuntas [solucionado]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 616
Location: Zaragoza (Spain)

PostPosted: Thu Jun 13, 2013 8:41 pm    Post subject: [gcc] 2 versiones conjuntas [solucionado] Reply with quote

Ayer después de hacer la actualización de udev (no muy bien) también se actualizó gcc, pero .... no desinstaló la antigua versión

Code:
# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.4
 [2] x86_64-pc-linux-gnu-4.7.3 *


además, me ha fallado la última actualización de mplayer y ... como no indica nada en especial ... supongo que puede ser derivado de esto.

Code:
x86_64-pc-linux-gnu-gcc -MD -MP -Wundef  -Wstrict-prototypes -Wmissing-prototypes -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99  -march=nocona -O2 -pipe -fno-tree-vectorize -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I. -Iffmpeg  -D_REENTRANT -I/usr/include/directfb -I/usr/include/libgtop-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include    -I/usr/include -I/usr/include/freetype2  -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -c -o loader/wrapper.o loader/wrapper.S
loader/wrapper.S: Assembler messages:
loader/wrapper.S:31: Error: `pusha' is not supported in 64-bit mode
loader/wrapper.S:34: Error: operand type mismatch for `push'
loader/wrapper.S:38: Error: operand type mismatch for `push'
loader/wrapper.S:40: Error: operand type mismatch for `push'
loader/wrapper.S:45: Error: operand type mismatch for `push'
loader/wrapper.S:46: Error: operand type mismatch for `push'
loader/wrapper.S:55: Error: `popa' is not supported in 64-bit mode
loader/wrapper.S:57: Error: invalid instruction suffix for `pop'
loader/wrapper.S:58: Error: invalid instruction suffix for `push'
loader/wrapper.S:64: Error: invalid instruction suffix for `push'
loader/wrapper.S:65: Error: `pusha' is not supported in 64-bit mode
loader/wrapper.S:68: Error: operand type mismatch for `push'
loader/wrapper.S:72: Error: operand type mismatch for `push'
loader/wrapper.S:74: Error: operand type mismatch for `push'
loader/wrapper.S:79: Error: operand type mismatch for `push'
loader/wrapper.S:80: Error: operand type mismatch for `push'
loader/wrapper.S:87: Error: `popa' is not supported in 64-bit mode
make: *** [loader/wrapper.o] Error 1
make: *** Se espera a que terminen otras tareas....
 * ERROR: media-video/mplayer-1.1-r1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-video/mplayer-1.1-r1'`,
 * the complete build log and the output of `emerge -pqv '=media-video/mplayer-1.1-r1'`.
 * This ebuild is from an overlay named 'gentoo-zh': '/var/lib/layman/gentoo-zh/'
 * The complete build log is located at '/var/tmp/portage/media-video/mplayer-1.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/mplayer-1.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/mplayer-1.1-r1/work/MPlayer-1.1'
 * S: '/var/tmp/portage/media-video/mplayer-1.1-r1/work/MPlayer-1.1'

>>> Failed to emerge media-video/mplayer-1.1-r1, Log file:

>>>  '/var/tmp/portage/media-video/mplayer-1.1-r1/temp/build.log'

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"


Last edited by Theasker on Fri Jun 14, 2013 10:52 am; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Thu Jun 13, 2013 10:55 pm    Post subject: Reply with quote

Quote:
This ebuild is from an overlay named 'gentoo-zh'

Quizá tenga algo que ver. Tienes la misma versión en los repositorios oficiales.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 616
Location: Zaragoza (Spain)

PostPosted: Fri Jun 14, 2013 10:51 am    Post subject: Reply with quote

Pues si que era eso, he eliminado el overlay y a funcionar.
Mira que estuve revisando la salida del error y no caí en eso. Lo había leído pero no supuse que tendría algo que ver.

Gracias y disculpad por la pérdida de tiempo
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum