Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with vlc on a raspberry pi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
mvaterlaus
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 145
Location: Switzerland

PostPosted: Wed Jun 12, 2013 8:23 am    Post subject: problems with vlc on a raspberry pi Reply with quote

hi guys,
I don't know, if this is the right forum. I have a problem with vlc on my raspberry pi. It won't display any videos. I compiled vlc and ffmpeg with the following use flags:
Code:

testpi ~ # emerge -pv vlc ffmpeg

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-video/ffmpeg-0.10.7  USE="X aac alsa bindist bzip2 encode hardcoded-tables mp3 truetype xvid zlib (-3dnow) (-3dnowext) (-aacplus) (-altivec) (-amr) (-avx) -cdio (-celt) -cpudetection -debug -dirac -doc -faac (-frei0r) -gnutls -gsm (-ieee1394) -jack -jpeg2k -libass -libv4l (-mmx) (-mmxext) -modplug (-neon) -network -openal -openssl -oss -pic -pulseaudio (-rtmp) (-schroedinger) -sdl -speex (-ssse3) -static-libs {-test} -theora -threads -v4l (-vaapi) (-vdpau) (-vis) -vorbis (-vpx) (-x264)" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher" 0 kB

[ebuild   R   ~] media-video/vlc-2.0.6  USE="X a52 avcodec avformat dts dvbpsi encode ffmpeg gcrypt mp3 mpeg ncurses png postproc qt4 sdl skins swscale truetype udev xcb xv -aac -aalib -alsa (-altivec) -atmo (-audioqueue) -avahi -bidi (-bluray) -cdda -cddb -dbus -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) (-dvb) (-dvd) (-dxva2) -egl -fbosd -flac (-fluidsynth) -fontconfig -gme -gnome -gnutls -growl -httpd (-ieee1394) (-ios-vout) -jack -kate -kde -libass -libcaca -libnotify -libproxy -libsamplerate (-libtar) -libtiger -linsys (-lirc) -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) (-mmx) -modplug (-mtp) (-musepack) (-neon) -ogg -omxil -opengl -optimisememory -opus -oss -portaudio (-projectm) -pulseaudio -pvr -rtsp -run-as-root -samba (-schroedinger) -sdl-image -shine -shout (-sid) -speex -sqlite (-sse) -svg -switcher -taglib -theora -twolame (-upnp) -v4l (-vaapi) -vcdx -vlm -vorbis (-waveout) (-wingdi) -wma-fixed (-x264) -xml -xosd (-zvbi)" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB


The USE flags are the same as on my desktop, and my desktop shows the videos without any problems. On the pi, vlc starts to display the video, but I can't see any images.
First I tought, maybe the pi has not enough gpu memory, so I configured more in config.txt as follows:
Code:

testpi ~ # cat /boot/config.txt
# Display mode
hdmi_group=2
hdmi_mode=16

# GPU Memory (Default is 64MB)
gpu_mem=256


I used hdmi_group=2 because otherwise the monitor would not be filled over the whole screen. Also, I do not use any DE for the pi, only plain X.
It would be great, if someone could lead me in to the right direction or give me a clue where to look for this problem.

regards
Back to top
View user's profile Send private message
HolgerB
n00b
n00b


Joined: 07 Sep 2011
Posts: 46

PostPosted: Thu Jun 13, 2013 7:41 am    Post subject: Reply with quote

256MB for the GPU should be sufficient since I run XBMC on an old 256 MB raspi with 128MB for the GPU. Unless I am completely wrong an basic X environment should be sufficient. What I do not know is if VLC is of any use on a Raspi since it does not support hardware decoding from the GPU. The Raspi CPU itself does not have a lot of power. So playing back anything demanding will most likely be no fun :(

I run Raspian on my Raspi and omxplayer. With -o hdmi I can play back 1080p stuff via HDMI controlled from an ssh session. Work like a charm.

For more on mplayer under Gentoo without X you might consider reading this:
https://forums.gentoo.org/viewtopic-t-941610-postdays-0-postorder-asc-start-0.html?sid=9f8ef68caf74a48f924e701f57cd751e

HTH....
Back to top
View user's profile Send private message
mvaterlaus
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 145
Location: Switzerland

PostPosted: Thu Jun 13, 2013 1:59 pm    Post subject: Reply with quote

hi HolgerB,
thanks for pointing that out. for now I will first try to install mplayer, since the dependencies are less than installing layman for getting omxplayer from the overlay. I will report back, if I have any luck.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1355

PostPosted: Sun Jun 23, 2013 3:10 pm    Post subject: Reply with quote

Layman doesn't have much dependencies unless you intentionally enable them all, just enable the one you need for the overlay if you want or need to give omxplayer a try.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum