Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to control fan control temperature
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
irenicus09
n00b
n00b


Joined: 07 Jun 2013
Posts: 3

PostPosted: Fri Jun 07, 2013 9:09 pm    Post subject: How to control fan control temperature Reply with quote

Hello I'm kinda new to Gentoo, can someone help me with what tools are out there to control the fan & keep the temp of my laptop at a minimum?

Thanks.
Back to top
View user's profile Send private message
bug_report
n00b
n00b


Joined: 17 Sep 2010
Posts: 61
Location: Frankfurt, Germany

PostPosted: Sat Jun 08, 2013 11:49 am    Post subject: Reply with quote

Are you new to Gentoo or to Linux in general? Which Linux distribution do you know and which tools did you use? Most probably, you can use the same tools on your Gentoo system.

To keep laptop temperatures at a minimum, a whole bunch of steps is required:
1) Proper BIOS settings
2) set CPU frequency governor to "on demand" with cpufrequtils
3) enable power management of devices with powertop
4) Configure your desktop environment

On many systems, fan control is set up by BIOS. On some systems, you can control fan with lm_sensors. But this can be dangerous...
Back to top
View user's profile Send private message
irenicus09
n00b
n00b


Joined: 07 Jun 2013
Posts: 3

PostPosted: Sat Jun 08, 2013 1:09 pm    Post subject: Reply with quote

Thanks for your reply...I've been using linux for a few years now. Currently I'm using Sabayon Linux (Gentoo based) & they have 2 package managers one of which is portage (Gentoo's package manager).

I'm aware of powertop but I prefer to use laptop-mode-tools for keeping power usage at a minimum. I'll look into cpufrequtils, thanks for that.

As for DE I'm on Gnome3...was a big fan of Openbox still am, but had to switch for convenience....but I think the main reason for overheating has something to do with my internal Radeon card...I've not been able to properly set it up & I think it keeps on running. It's a hybrid ATI 8750 model, here's the details:

Code:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device c706
        Kernel driver in use: i915

01:00.0 Display controller: Advanced Micro Devices [AMD] nee ATI Mars [Radeon HD 8670A/8750M]
        Subsystem: Samsung Electronics Co Ltd Device c706
        Kernel driver in use: fglrx_pci
        Kernel modules: radeon, fglrx



The amdcccle didn't work due to some error [device not found, etc.] so I've defaulted to xorg driver...I don't even know whats running, but the intel based card is doing fine I guess.
Code:
eselect opengl list
Available OpenGL implementations:
  [1]   ati
  [2]   xorg-x11 *


The symptoms have decreased some what and that's a good thing...less hotter than it was before after following these steps:

https://forum.sabayon.org/viewtopic.php?f=56&t=29426&start=30

Let me know what other info I can provide to be helpful. Thanks :)
Back to top
View user's profile Send private message
bug_report
n00b
n00b


Joined: 17 Sep 2010
Posts: 61
Location: Frankfurt, Germany

PostPosted: Sat Jun 08, 2013 2:21 pm    Post subject: Reply with quote

Which notebook do you have? A Samsung? I have a Samsung P50-Pro with hybrid graphics and the first thing I did was to disable the Nvidia chip using bbswitch. I use the Intel integrated graphics controller only and it' fast enough for me.

So maybe sou should try to completely disable your ati grahics chip and see if power consumption goes down - just to find out if it is really the ati graphics controller that causes you pain. Those hybrid graphics systems have caused problems for years, although with latest kernel, xorg and driver releases, it should be better...

Also you should try powertop release 2.3 to display power management settings (rightmost tab). Of course, you can continue to use laptop-mode-tools to set power management settings.
Back to top
View user's profile Send private message
irenicus09
n00b
n00b


Joined: 07 Jun 2013
Posts: 3

PostPosted: Sat Jun 08, 2013 3:56 pm    Post subject: Reply with quote

Ya I have a samsung series 3 notebook with hybrid graphics and apparently there's no physical switch from what I've observed and there's no option in the Bios to enable / disable discrete graphics...so I dunno whats going on. I've been told directly from AMD forums that it takes 5-6 months or more for the drivers of the latest graphics card to arrive even for windows...so I'm not sure how long I've to wait...it's already been 2-3 months now I think.

And I'll try powertop as per your recommendation.

Thanks.
Back to top
View user's profile Send private message
bug_report
n00b
n00b


Joined: 17 Sep 2010
Posts: 61
Location: Frankfurt, Germany

PostPosted: Sat Jun 08, 2013 5:22 pm    Post subject: Reply with quote

From my experience, for notebooks it takes 6 months until most of the hardware works under Linux - and up to two years until nearly all of the hardware works.

Have you tried acpi_call? The program calls a BIOS function to shut down the discrete graphics chip. Maybe it will work on your notebook.

Look here: https://wiki.archlinux.org/index.php/Hybrid_graphics, section 'Fully Power Down Discrete GPU',
and here: https://github.com/mkottman/acpi_call to download source code.

You''ll need to run the script turn_off_gpu.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum